summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-point-to-correct-location-of-ngraph-headers.patch
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-09-27 22:55:27 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-09-30 15:34:44 +0800
commit90b225ce8a00aafd94d0aef5f85e73adce91d5f2 (patch)
tree2325156bd0cd0c4ab837e946181345d7d8c88ddb /dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-point-to-correct-location-of-ngraph-headers.patch
parent096598691de246c23902d49d228c7562ba2c9cc5 (diff)
downloadmeta-intel-90b225ce8a00aafd94d0aef5f85e73adce91d5f2.tar.gz
dldt-inference-engine: upgrade 2019r1.1 -> 2019r2
* Release notes: https://software.intel.com/en-us/articles/OpenVINO-RelNotes * Enable unit tests to be built and tested using ptest mechanism. * Include patches from Clear Linux for build fixes. * Switch to using python3 and threading to using TBB. Switch ENABLE_OPENCV to off so opencv from system is used. * Remove do_install and patch Makefiles instead to install libraries correctly. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-point-to-correct-location-of-ngraph-headers.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-point-to-correct-location-of-ngraph-headers.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-point-to-correct-location-of-ngraph-headers.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-point-to-correct-location-of-ngraph-headers.patch
new file mode 100644
index 00000000..f335d247
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-point-to-correct-location-of-ngraph-headers.patch
@@ -0,0 +1,39 @@
1From 8335bac5c53b6cfe611a1c4987ca47aa6a60549f Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Fri, 27 Sep 2019 23:06:18 +0800
4Subject: [PATCH] point to correct location of ngraph headers
5
6Upstream-Status: Pending
7Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
8---
9 inference-engine/src/inference_engine/CMakeLists.txt | 2 +-
10 inference-engine/tests/unit/CMakeLists.txt | 3 ++-
11 2 files changed, 3 insertions(+), 2 deletions(-)
12
13diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
14index c0c803d..a4425fd 100644
15--- a/inference-engine/src/inference_engine/CMakeLists.txt
16+++ b/inference-engine/src/inference_engine/CMakeLists.txt
17@@ -99,7 +99,7 @@ target_include_directories(${TARGET_NAME} PUBLIC
18 target_include_directories(${TARGET_NAME} SYSTEM PRIVATE "${IE_MAIN_SOURCE_DIR}/thirdparty/pugixml/src")
19 target_include_directories(${TARGET_NAME} SYSTEM PRIVATE "${IE_MAIN_SOURCE_DIR}/thirdparty/ngraph/src")
20 target_include_directories(${TARGET_NAME} SYSTEM PRIVATE "${IE_MAIN_SOURCE_DIR}/thirdparty/ocv")
21-include_directories(${TARGET_NAME} "/usr/include/ngraph")
22+include_directories(${TARGET_NAME} "${NGRAPH_INCLUDES}")
23
24 if(ENABLE_MKL_DNN)
25 target_include_directories(${TARGET_NAME} SYSTEM PRIVATE "${IE_MAIN_SOURCE_DIR}/thirdparty/mkl-dnn/src/cpu/xbyak")
26diff --git a/inference-engine/tests/unit/CMakeLists.txt b/inference-engine/tests/unit/CMakeLists.txt
27index d83e088..29115d2 100644
28--- a/inference-engine/tests/unit/CMakeLists.txt
29+++ b/inference-engine/tests/unit/CMakeLists.txt
30@@ -85,7 +85,8 @@ target_include_directories(${TARGET_NAME} PRIVATE
31 ${IE_MAIN_SOURCE_DIR}/src/extension
32 ${IE_MAIN_SOURCE_DIR}/src/extension/common
33 ${IE_MAIN_SOURCE_DIR}/thirdparty/ngraph/src
34- "${CMAKE_CURRENT_SOURCE_DIR}/mocks")
35+ "${CMAKE_CURRENT_SOURCE_DIR}/mocks"
36+ ${NGRAPH_INCLUDES})
37
38 set_target_properties(${TARGET_NAME} PROPERTIES COMPILE_PDB_NAME ${TARGET_NAME})
39