summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-08-25 16:10:36 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-08-27 09:55:39 +0800
commit011b2d6c1922d99ac90827cd894616943e592d4f (patch)
tree90e704a61764d5ce288148973f33201bd68897cc /dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch
parent036ca44cbb943f1bf46ad060d6f2e58ff276dfa7 (diff)
downloadmeta-intel-011b2d6c1922d99ac90827cd894616943e592d4f.tar.gz
openvino-inference-engine: upgrade 2021.3 -> 2021.4
Refresh patches and add zlib to DEPENDS. Also fetch pybind11 as it's needed by ngraph. Release notes: https://software.intel.com/content/www/us/en/develop/articles/openvino-2021-4-lts-relnotes.html Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch
new file mode 100644
index 00000000..5e7cfb38
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch
@@ -0,0 +1,43 @@
1From 1a3f315323a0b1d1affed01e85cbbf0a677718e8 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:45:48 +0800
4Subject: [PATCH] Disable Werror
5
6Don't treat warnings as errors. This just leads to failures every time
7we upgrade the compiler.
8
9Upstream-Status: Inappropriate
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12---
13 inference-engine/thirdparty/clDNN/CMakeLists.txt | 1 -
14 ngraph/CMakeLists.txt | 1 -
15 2 files changed, 2 deletions(-)
16
17diff --git a/inference-engine/thirdparty/clDNN/CMakeLists.txt b/inference-engine/thirdparty/clDNN/CMakeLists.txt
18index d14da47860..08ed695c0d 100644
19--- a/inference-engine/thirdparty/clDNN/CMakeLists.txt
20+++ b/inference-engine/thirdparty/clDNN/CMakeLists.txt
21@@ -518,7 +518,6 @@ foreach(__CLDNN_CompilerFlagName IN ITEMS "CMAKE_CXX_FLAGS" "CMAKE_C_FLAGS")
22 MultiProcessorCompilation
23 DeadCodeEliminate
24 ExtensionsEnabled
25- TreatWarnAsErrorEnabled
26 WarnLevel4
27 NoFastMath
28 StackProtector
29diff --git a/ngraph/CMakeLists.txt b/ngraph/CMakeLists.txt
30index a05ca3b15c..ae888c4cb2 100644
31--- a/ngraph/CMakeLists.txt
32+++ b/ngraph/CMakeLists.txt
33@@ -197,7 +197,6 @@ if (WIN32)
34 endif()
35
36 if (NOT CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
37- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Werror")
38 endif()
39
40 if(WIN32)
41--
422.32.0
43