summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-09-27 22:55:27 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-09-30 15:34:44 +0800
commit90b225ce8a00aafd94d0aef5f85e73adce91d5f2 (patch)
tree2325156bd0cd0c4ab837e946181345d7d8c88ddb /dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
parent096598691de246c23902d49d228c7562ba2c9cc5 (diff)
downloadmeta-intel-90b225ce8a00aafd94d0aef5f85e73adce91d5f2.tar.gz
dldt-inference-engine: upgrade 2019r1.1 -> 2019r2
* Release notes: https://software.intel.com/en-us/articles/OpenVINO-RelNotes * Enable unit tests to be built and tested using ptest mechanism. * Include patches from Clear Linux for build fixes. * Switch to using python3 and threading to using TBB. Switch ENABLE_OPENCV to off so opencv from system is used. * Remove do_install and patch Makefiles instead to install libraries correctly. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb88
1 files changed, 88 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
new file mode 100644
index 00000000..207b206e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
@@ -0,0 +1,88 @@
1SUMMARY = "OpenVINO(TM) Toolkit - Deep Learning Deployment Toolkit"
2HOMEPAGE = "https://github.com/opencv/dldt"
3DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
4deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic."
6
7SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \
8 https://download.01.org/opencv/2019/openvinotoolkit/R2/inference_engine/firmware_ma2450_676.zip;name=ma2450 \
9 https://download.01.org/opencv/2019/openvinotoolkit/R2/inference_engine/firmware_ma2x8x_mdk_R8_9.zip;name=ma2x8x \
10 file://0001-R2-Build-fixes.patch;patchdir=../ \
11 file://0002-R2-Install-DLDT-headers-libs-sample-Apps.patch;patchdir=../ \
12 file://0003-use-GNUInstallDirs-on-nix.patch;patchdir=../ \
13 file://0003-Supply-firmware-at-build-time.patch;patchdir=../ \
14 file://0004-disable-werror.patch;patchdir=../ \
15 file://0005-point-to-correct-location-of-ngraph-headers.patch;patchdir=../ \
16 file://run-ptest \
17 "
18SRCREV = "ba6e22b1b5ee4cbefcc30e8d9493cddb0bb3dfdf"
19
20SRC_URI[ma2450.md5sum] = "a241a063db7eaa3de70ebf89817960e0"
21SRC_URI[ma2450.sha256sum] = "7fb1aa10c0fde8315fe2af65356a00f09f030d811adddc98731ec28b35368786"
22
23SRC_URI[ma2x8x.md5sum] = "cebebec8d05c70c3d69ed5ceaa11a06b"
24SRC_URI[ma2x8x.sha256sum] = "93640eb13e235d3f71a83cd503c36ff8a63235349e1f528d9030eca417ba8c1e"
25
26LICENSE = "Apache-2.0"
27LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
28
29inherit cmake ptest
30
31S = "${WORKDIR}/git/inference-engine"
32
33EXTRA_OECMAKE += " \
34 -DVPU_FIRMWARE_MA2450_FILE=../mvnc/MvNCAPI-ma2450.mvcmd \
35 -DVPU_FIRMWARE_MA2X8X_FILE=../mvnc/MvNCAPI-ma2x8x.mvcmd \
36 -DENABLE_OPENCV=0 \
37 -DENABLE_SAMPLES_CORE=1 \
38 -DENABLE_PLUGIN_RPATH=0 \
39 -DENABLE_GNA=0 \
40 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
41 -DTHREADING=TBB \
42 -DCMAKE_INSTALL_LOCAL_ONLY=OFF \
43 -DCMAKE_BUILD_TYPE=DebugWithRelInfo \
44 -DNGRAPH_INCLUDES=${STAGING_INCDIR}/ngraph \
45 -DENABLE_TESTS="${@bb.utils.contains('PTEST_ENABLED', '1', '1', '0', d)}" \
46 -DBUILD_GMOCK=1 \
47 -DBUILD_GTEST=0 \
48 -DINSTALL_GMOCK=0 \
49 -DINSTALL_GTEST=0 \
50 "
51
52DEPENDS += "libusb1 \
53 ade \
54 mkl-dnn \
55 opencv \
56 pugixml \
57 ngraph \
58 tbb \
59 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gflags', '0', d)} \
60 "
61
62COMPATIBLE_HOST = '(x86_64).*-linux'
63COMPATIBLE_HOST_libc-musl = "null"
64
65PACKAGECONFIG ?= ""
66PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1, -DENABLE_CLDNN=0, opencl-icd-loader, opencl-icd-loader intel-compute-runtime"
67
68do_install_ptest_base_prepend() {
69 # While not a Makefile based project that strictly falls into the category of
70 # what ptest helps with, adding the unit tests here as ptest would help.
71 # Create a dummy Makefile so installation doesn't fail.
72 touch ${WORKDIR}/Makefile
73 mv ${D}${bindir}/InferenceEngineUnitTests ${D}${PTEST_PATH}/
74}
75
76# Move inference engine samples into a separate package
77PACKAGES =+ "${PN}-samples"
78
79FILES_${PN}-dev = "${includedir} \
80 ${libdir}/cmake \
81 ${libdir}/libinference_engine.so \
82 "
83
84FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \
85 ${datadir}/openvino \
86 "
87
88FILES_${PN}-samples = "${bindir}"