summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
diff options
context:
space:
mode:
authorChin Huat Ang <chin.huat.ang@intel.com>2019-10-17 16:34:14 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-10-21 07:20:21 +0800
commit649456856dc38086e7d43d740d68198e3395b067 (patch)
tree68a604f7a99dda2b6641b493296d20ecdf559cd7 /dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
parentb128d14ff61d8097f779ef6c3d35a7ed84994b20 (diff)
downloadmeta-intel-649456856dc38086e7d43d740d68198e3395b067.tar.gz
dldt-inference-engine: update 2019r2 -> 2019r3
Refresh patches so that they apply cleanly on 2019r3. Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb87
1 files changed, 0 insertions, 87 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
deleted file mode 100644
index 3e3dd667..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
+++ /dev/null
@@ -1,87 +0,0 @@
1SUMMARY = "OpenVINO(TM) Toolkit - Deep Learning Deployment Toolkit"
2HOMEPAGE = "https://github.com/opencv/dldt"
3DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
4deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic."
6
7SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \
8 file://0001-R2-Build-fixes.patch;patchdir=../ \
9 file://0002-R2-Install-DLDT-headers-libs-sample-Apps.patch;patchdir=../ \
10 file://0003-use-GNUInstallDirs-on-nix.patch;patchdir=../ \
11 file://0003-Supply-firmware-at-build-time.patch;patchdir=../ \
12 file://0004-disable-werror.patch;patchdir=../ \
13 file://0005-point-to-correct-location-of-ngraph-headers.patch;patchdir=../ \
14 file://0001-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch;patchdir=../ \
15 file://0001-mock_engine-install-to-CMAKE_INSTALL_LIBDIR.patch;patchdir=../ \
16 file://run-ptest \
17 "
18SRCREV = "ba6e22b1b5ee4cbefcc30e8d9493cddb0bb3dfdf"
19
20LICENSE = "Apache-2.0"
21LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
22
23inherit cmake ptest python3native
24
25S = "${WORKDIR}/git/inference-engine"
26
27EXTRA_OECMAKE += " \
28 -DENABLE_VPU=OFF \
29 -DENABLE_OPENCV=0 \
30 -DENABLE_SAMPLES_CORE=1 \
31 -DENABLE_PLUGIN_RPATH=0 \
32 -DENABLE_GNA=0 \
33 -DPYTHON_EXECUTABLE=${PYTHON} \
34 -DTHREADING=TBB \
35 -DCMAKE_INSTALL_LOCAL_ONLY=OFF \
36 -DCMAKE_BUILD_TYPE=DebugWithRelInfo \
37 -DNGRAPH_INCLUDES=${STAGING_INCDIR}/ngraph \
38 -DENABLE_TESTS="${@bb.utils.contains('PTEST_ENABLED', '1', '1', '0', d)}" \
39 -DBUILD_GMOCK=1 \
40 -DBUILD_GTEST=0 \
41 -DINSTALL_GMOCK=0 \
42 -DINSTALL_GTEST=0 \
43 "
44
45DEPENDS += "libusb1 \
46 ade \
47 opencv \
48 pugixml \
49 ngraph \
50 tbb \
51 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gflags', '0', d)} \
52 "
53
54COMPATIBLE_HOST = '(x86_64).*-linux'
55COMPATIBLE_HOST_libc-musl = "null"
56
57PACKAGECONFIG ?= ""
58PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1, -DENABLE_CLDNN=0, opencl-icd-loader, opencl-icd-loader intel-compute-runtime"
59PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native, python3"
60
61do_install_ptest_base_prepend() {
62 # While not a Makefile based project that strictly falls into the category of
63 # what ptest helps with, adding the unit tests here as ptest would help.
64 # Create a dummy Makefile so installation doesn't fail.
65 touch ${WORKDIR}/Makefile
66 mv ${D}${bindir}/InferenceEngineUnitTests ${D}${PTEST_PATH}/
67 mv ${D}${libdir}/libmock_engine.so ${D}${PTEST_PATH}/
68}
69
70FILES_${PN}-dev = "${includedir} \
71 ${libdir}/cmake \
72 ${libdir}/libinference_engine.so \
73 "
74
75FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \
76 ${datadir}/openvino \
77 "
78
79# Move inference engine samples into a separate package
80PACKAGES =+ "${PN}-samples"
81
82FILES_${PN}-samples = "${bindir}"
83
84# Package for inference engine python API
85PACKAGES =+ "${PN}-${PYTHON_PN}"
86
87FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}/openvino"