summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.1.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-11-22 12:33:22 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-11-24 22:34:33 +0800
commit9b25d40cb91c82560a95e4f410b57201af14c7fc (patch)
tree4f263bd56b6901240349ececfa27dd9a4de04a4d /dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.1.0.bb
parenta3b2f8bb5920021d775be5b9fd81abc2c44d9202 (diff)
downloadmeta-intel-9b25d40cb91c82560a95e4f410b57201af14c7fc.tar.gz
openvkl: upgrade 1.0.1 -> 1.1.0
Release notes: vklExamples improvements: asynchronous rendering, multiple viewports, docking, and more Fixed bug in openvkl_utility_vdb which could lead to crashes when creating VDB volumes with temporally constant tiles Superbuild updates to latest versions of dependencies Minimum rkcommon version is now 1.8.0 Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.1.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.1.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.1.0.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.1.0.bb
new file mode 100644
index 00000000..30ae4f48
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.1.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Intel(R) Open Volume Kernel Library"
2DESCRIPTION = "Intel(R) Open Volume Kernel Library (Intel(R) Open VKL) is a \
3collection of high-performance volume computation kernels. The target users \
4of Open VKL are graphics application engineers who want to improve the \
5performance of their volume rendering applications by leveraging Open VKL’s \
6performance-optimized kernels, which include volume traversal and sampling \
7functionality for a variety of volumetric data formats. The kernels are optimized \
8for the latest Intel(R) processors with support for SSE, AVX, AVX2, and AVX-512 \
9instructions."
10HOMEPAGE = "https://www.openvkl.org/"
11
12LICENSE = "Apache-2.0 & BSD-3-Clause & MIT & Zlib"
13LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \
14 file://third-party-programs.txt;md5=69ec7caf49616c471161b921f53d5ec0 \
15 file://testing/external/half.hpp;beginline=1;endline=17;md5=4b60058493630c3bd0ef145470f04a7b"
16
17inherit pkgconfig cmake
18
19S = "${WORKDIR}/git"
20
21SRC_URI = "git://github.com/openvkl/openvkl.git;protocol=https;branch=master \
22 "
23SRCREV = "b2cfd8ab94420489e2ed9a25fb0d512c2577e5de"
24
25COMPATIBLE_HOST = '(x86_64).*-linux'
26
27DEPENDS = "ispc-native rkcommon embree"
28
29EXTRA_OECMAKE += " \
30 -DISPC_EXECUTABLE=${STAGING_BINDIR_NATIVE}/ispc \
31 "
32PACKAGES =+ "${PN}-examples"
33FILES:${PN}-examples = "\
34 ${bindir} \
35 "