summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2023.3.0.bb
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2024-02-06 09:04:28 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2024-02-06 11:41:37 +0800
commite21437f2aee9db23941201d108eeaad224f0f170 (patch)
tree116f948bd544947eb3f92d15995ee669f1387f5f /dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2023.3.0.bb
parent0593838afaa2d5548bf33df58b92750ceff178d8 (diff)
downloadmeta-intel-e21437f2aee9db23941201d108eeaad224f0f170.tar.gz
openvino-model-optimizer: upgrade 2023.2.0 -> 2023.3.0
Release Notes: https://github.com/openvinotoolkit/openvino/releases/tag/2023.3.0 Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2023.3.0.bb')
-rw-r--r--dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2023.3.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2023.3.0.bb b/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2023.3.0.bb
new file mode 100644
index 00000000..51237d32
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2023.3.0.bb
@@ -0,0 +1,33 @@
1SUMMARY = "OpenVINO Model Optimzer"
2DESCRIPTION = "Model Optimizer is a cross-platform command-line tool that \
3facilitates the transition between the training and deployment \
4environment, performs static model analysis, and adjusts deep \
5learning models for optimal execution on end-point target devices."
6HOMEPAGE = "https://01.org/openvinotoolkit"
7
8SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2023/3;lfs=0 \
9 "
10SRCREV = "ceeafaf64f346c6f14a67c612e131da5c27ef620"
11
12LICENSE = "Apache-2.0"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
14
15CVE_PRODUCT = "intel:openvino"
16S = "${WORKDIR}/git"
17
18inherit setuptools3
19
20SETUPTOOLS_SETUP_PATH = "${WORKDIR}/git/tools/mo"
21
22RDEPENDS:${PN} += " \
23 python3-defusedxml \
24 python3-fastjsonschema \
25 python3-networkx \
26 python3-numpy \
27 python3-protobuf \
28 python3-requests \
29 python3-urllib3 \
30 bash \
31 "
32
33UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+\.\d+\.\d+))$"