summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2020r1.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-04-14 10:53:06 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-04-14 10:53:06 +0800
commit39bbb90d275c7cc38bb2201d11cab03d2916a296 (patch)
tree875c998628aae34832ad7da54cb1634ce5379e76 /dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2020r1.bb
parent147aac32fa67bcaf717870c592a7b411a39fe09c (diff)
downloadmeta-intel-39bbb90d275c7cc38bb2201d11cab03d2916a296.tar.gz
dldt-model-optimizer: upgrade 2019r3.1 -> 2020r1
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2020r1.bb')
-rw-r--r--dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2020r1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2020r1.bb b/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2020r1.bb
new file mode 100644
index 00000000..26068acc
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2020r1.bb
@@ -0,0 +1,33 @@
1SUMMARY = "OpenVINO Model Optimzer"
2DESCRIPTION = "Model Optimizer is a cross-platform command-line tool that \
3facilitates the transition between the training and deployment \
4environment, performs static model analysis, and adjusts deep \
5learning models for optimal execution on end-point target devices."
6HOMEPAGE = "https://01.org/openvinotoolkit"
7
8SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2020 \
9 "
10SRCREV = "b2140c083a068a63591e8c2e9b5f6b240790519d"
11
12LICENSE = "Apache-2.0"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
14
15CVE_PRODUCT = "intel:openvino"
16
17S = "${WORKDIR}/git"
18
19do_install() {
20 mkdir -p ${D}${datadir}/openvino/model-optimizer
21 cp -r model-optimizer ${D}${datadir}/openvino/
22}
23
24RDEPENDS_${PN} += " \
25 python3-numpy \
26 python3-protobuf \
27 python3-defusedxml \
28 python3-networkx \
29 python3-test-generator \
30 bash \
31 "
32
33FILES_${PN} += "${datadir}/openvino"