summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb
diff options
context:
space:
mode:
authorChin Huat Ang <chin.huat.ang@intel.com>2019-11-01 11:24:28 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-11-29 06:41:59 +0800
commitb7bfdc347c1ed477e7842354d0ab5b8e2d76775a (patch)
tree1d4e8ce78996fbb2681c09c1c6e03a4ef84c2e0e /dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb
parentb478b4c415fdb45d4435af595d3edcf9c63f6cb4 (diff)
downloadmeta-intel-b7bfdc347c1ed477e7842354d0ab5b8e2d76775a.tar.gz
dldt-model-optimizer: upgrade 2019r3 -> 2019r3.1
Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb')
-rw-r--r--dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb b/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb
new file mode 100644
index 00000000..33847ad4
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "OpenVINO Model Optimzer"
2DESCRIPTION = "Model Optimizer is a cross-platform command-line tool that \
3facilitates the transition between the training and deployment \
4environment, performs static model analysis, and adjusts deep \
5learning models for optimal execution on end-point target devices."
6HOMEPAGE = "https://01.org/openvinotoolkit"
7
8SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \
9 "
10SRCREV = "fe3f978b98c86eaeed3cbdc280e1ffd0bc50d278"
11
12LICENSE = "Apache-2.0"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
14
15S = "${WORKDIR}/git"
16
17do_install() {
18 mkdir -p ${D}${datadir}/openvino/model-optimizer
19 cp -r model-optimizer ${D}${datadir}/openvino/
20}
21
22RDEPENDS_${PN} += " \
23 python3-numpy \
24 python3-protobuf \
25 python3-defusedxml \
26 python3-networkx \
27 python3-test-generator \
28 bash \
29 "
30
31FILES_${PN} += "${datadir}/openvino"