summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-10-25 16:23:50 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-10-25 22:02:18 +0800
commitd8584ea9d7c5207b6c08abbbedbd1b7f64a4fe4b (patch)
treee4f5f815f2563e0fa818bbc68fb94e8c6dd9d70d /dynamic-layers/clang-layer
parent82a05e9558a7cd2981d2dec2094a86f83bff1377 (diff)
downloadmeta-intel-d8584ea9d7c5207b6c08abbbedbd1b7f64a4fe4b.tar.gz
intel-graphics-compiler: add PACKAGECONFIG for VectorCompiler
Allow users to disable it but enable by default. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb13
1 files changed, 7 insertions, 6 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb
index 9ed828bc..44899fa3 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb
@@ -24,7 +24,7 @@ export B
24 24
25S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
26 26
27inherit cmake 27inherit cmake pkgconfig
28 28
29CXXFLAGS:append = " -Wno-error=nonnull" 29CXXFLAGS:append = " -Wno-error=nonnull"
30 30
@@ -36,21 +36,22 @@ DEPENDS:append:class-target = " clang-cross-x86_64 intel-graphics-compiler-nativ
36 36
37RDEPENDS:${PN} += "opencl-clang" 37RDEPENDS:${PN} += "opencl-clang"
38 38
39PACKAGECONFIG ??= "vc"
40PACKAGECONFIG[vc] = "-DIGC_BUILD__VC_ENABLED=ON -DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR=ON -DIGC_OPTION__USE_KHRONOS_SPIRV_TRANSLATOR_IN_VC=ON -DIGC_OPTION__SPIRV_TRANSLATOR_MODE=Prebuilds,-DIGC_BUILD__VC_ENABLED=OFF,"
41
39EXTRA_OECMAKE = " \ 42EXTRA_OECMAKE = " \
40 -DIGC_OPTION__LLVM_PREFERRED_VERSION=${LLVMVERSION} \ 43 -DIGC_OPTION__LLVM_PREFERRED_VERSION=${LLVMVERSION} \
41 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \ 44 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
42 -DVC_INTRINSICS_SRC="${S}/vc-intrinsics" \ 45 -DVC_INTRINSICS_SRC="${S}/vc-intrinsics" \
43 -DIGC_OPTION__LLVM_MODE=Prebuilds \ 46 -DIGC_OPTION__LLVM_MODE=Prebuilds \
44 -DIGC_BUILD__VC_ENABLED=ON \
45 -DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR=ON \
46 -DIGC_OPTION__USE_KHRONOS_SPIRV_TRANSLATOR_IN_VC=ON \
47 -DIGC_OPTION__SPIRV_TRANSLATOR_MODE=Prebuilds \
48 " 47 "
49 48
50do_install:append:class-native () { 49do_install:append:class-native () {
51 install -d ${D}${bindir} 50 install -d ${D}${bindir}
52 install ${B}/IGC/Release/elf_packager ${D}${bindir}/ 51 install ${B}/IGC/Release/elf_packager ${D}${bindir}/
53 install ${B}/IGC/Release/CMCLTranslatorTool ${D}${bindir}/ 52 if ${@bb.utils.contains('PACKAGECONFIG', 'vc', 'true', 'false', d)}; then
53 install ${B}/IGC/Release/CMCLTranslatorTool ${D}${bindir}/
54 fi
54} 55}
55 56
56BBCLASSEXTEND = "native nativesdk" 57BBCLASSEXTEND = "native nativesdk"