summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2023-05-30 09:03:01 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-05-30 15:10:17 +0800
commitc8fc88b7ed082706af30aac7d4cf4e7201f62542 (patch)
tree1f1ad78fea4e1cb4bd079ec9d85e2a018d5c2425 /dynamic-layers/clang-layer
parent1340aeb6c799c41eae7703bf3d7fded2d54a952d (diff)
downloadmeta-intel-c8fc88b7ed082706af30aac7d4cf4e7201f62542.tar.gz
intel-compute-runtime: fix build with gcc13
Dont turn warnings to errors. Helps when compiling with gcc13. | /build/poky/build/tmp/work/corei7-64-poky-linux/intel-compute-runtime/23.09.25812.14-r0/recipe-sysroot/usr/include/c++/13.1.1/bits/stl_algobase.h:398:11: error: '*(unsigned char (*)[7])((char*)&<unnamed> + offsetof(NEO::ArgDescValue, NEO::ArgDescValue::elements.StackVec<NEO::ArgDescValue::Element, 1, unsigned char>::onStackMemRawBytes[0]))' may be used uninitialized [-Werror=maybe-uninitialized] | 398 | { *__to = *__from; } | | Also, include cstdint header to get rid of other gcc13 specific errors. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch56
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch16
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.13.26032.30.bb2
3 files changed, 74 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch
new file mode 100644
index 00000000..7f75cbb8
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch
@@ -0,0 +1,56 @@
1From 078af5b7ac3086d336f76183b798771263491c34 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 30 May 2023 11:07:10 +0800
4Subject: [PATCH] add missing cstdint header to fix compile with gcc13
5
6Include the headers as per:
7https://gcc.gnu.org/gcc-13/porting_to.html
8
9Upstream-Status: Pending
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12---
13 opencl/test/unit_test/built_ins/built_ins_file_names.h | 1 +
14 shared/test/common/os_interface/linux/sys_calls_linux_ult.h | 1 +
15 third_party/aot_config_headers/platforms.h | 1 +
16 3 files changed, 3 insertions(+)
17
18diff --git a/opencl/test/unit_test/built_ins/built_ins_file_names.h b/opencl/test/unit_test/built_ins/built_ins_file_names.h
19index 08dc38d406..e04f916e71 100644
20--- a/opencl/test/unit_test/built_ins/built_ins_file_names.h
21+++ b/opencl/test/unit_test/built_ins/built_ins_file_names.h
22@@ -9,6 +9,7 @@
23
24 #include <string>
25 #include <vector>
26+#include <cstdint>
27
28 namespace NEO {
29 std::vector<std::string> getBuiltInFileNames(bool imagesSupport);
30diff --git a/shared/test/common/os_interface/linux/sys_calls_linux_ult.h b/shared/test/common/os_interface/linux/sys_calls_linux_ult.h
31index 9f1fd4dacb..e64dd40254 100644
32--- a/shared/test/common/os_interface/linux/sys_calls_linux_ult.h
33+++ b/shared/test/common/os_interface/linux/sys_calls_linux_ult.h
34@@ -7,6 +7,7 @@
35
36 #pragma once
37
38+#include <cstdint>
39 #include <iostream>
40 #include <poll.h>
41 #include <sys/stat.h>
42diff --git a/third_party/aot_config_headers/platforms.h b/third_party/aot_config_headers/platforms.h
43index 056d615503..d2024d1b54 100644
44--- a/third_party/aot_config_headers/platforms.h
45+++ b/third_party/aot_config_headers/platforms.h
46@@ -7,6 +7,7 @@
47
48 #include <map>
49 #include <string>
50+#include <cstdint>
51
52 #pragma once
53
54--
552.37.3
56
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch
new file mode 100644
index 00000000..20d9b847
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch
@@ -0,0 +1,16 @@
1Upstream-Status: Inappropriate
2Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
3
4diff --git a/CMakeLists.txt b/CMakeLists.txt
5index d52e089778..bc0cf35014 100644
6--- a/CMakeLists.txt
7+++ b/CMakeLists.txt
8@@ -727,7 +727,7 @@ if(NOT MSVC)
9 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-noexcept-type") # Added for gtest
10 endif()
11 endif()
12- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Werror=vla")
13+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror=vla")
14
15 if(USE_SANITIZE_UB)
16 check_cxx_compiler_flag(-fsanitize=undefined COMPILER_SUPPORTS_UNDEFINED_BEHAVIOR_SANITIZER)
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.13.26032.30.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.13.26032.30.bb
index 644c978b..f6cdf5fd 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.13.26032.30.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.13.26032.30.bb
@@ -9,6 +9,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \
9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b" 9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b"
10 10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/23.13 \ 11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/23.13 \
12 file://disable-werror.patch \
13 file://add-missing-cstdint-header-to-fix-compile-with-gcc13.patch \
12 " 14 "
13 15
14SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch \ 16SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch \