summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2024-02-27 23:01:58 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2024-02-28 10:01:22 +0800
commita89665f17ce0856e88bc073594ce9ccdc9e0c2e5 (patch)
tree344fc066c26abba58344cfbd3ff109b4f6a2c850 /dynamic-layers/clang-layer
parente56ace026b2e1b35274cbed0ff0fb04e83a5532b (diff)
downloadmeta-intel-a89665f17ce0856e88bc073594ce9ccdc9e0c2e5.tar.gz
intel-compute-runtime: upgrade 23.22.26516.18 -> 24.05.28454.6
Drop the patch that has already been merged. License-Update: OpenCL-Headers are now Apache-2.0 licensed. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch56
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch25
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.05.28454.6.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.22.26516.18.bb)9
3 files changed, 20 insertions, 70 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch
deleted file mode 100644
index e39d801b..00000000
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1From 41d9b88b2edfcb9fee82ccfc68bd6030a282292c Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 30 May 2023 11:07:10 +0800
4Subject: [PATCH] add missing cstdint header to fix compile with gcc13
5
6Include the headers as per:
7https://gcc.gnu.org/gcc-13/porting_to.html
8
9Upstream-Status: Pending
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12---
13 opencl/test/unit_test/built_ins/built_ins_file_names.h | 1 +
14 shared/test/common/os_interface/linux/sys_calls_linux_ult.h | 1 +
15 third_party/aot_config_headers/platforms.h | 1 +
16 3 files changed, 3 insertions(+)
17
18diff --git a/opencl/test/unit_test/built_ins/built_ins_file_names.h b/opencl/test/unit_test/built_ins/built_ins_file_names.h
19index 08dc38d406..e04f916e71 100644
20--- a/opencl/test/unit_test/built_ins/built_ins_file_names.h
21+++ b/opencl/test/unit_test/built_ins/built_ins_file_names.h
22@@ -9,6 +9,7 @@
23
24 #include <string>
25 #include <vector>
26+#include <cstdint>
27
28 namespace NEO {
29 std::vector<std::string> getBuiltInFileNames(bool imagesSupport);
30diff --git a/shared/test/common/os_interface/linux/sys_calls_linux_ult.h b/shared/test/common/os_interface/linux/sys_calls_linux_ult.h
31index f30d425abe..1bc78d3335 100644
32--- a/shared/test/common/os_interface/linux/sys_calls_linux_ult.h
33+++ b/shared/test/common/os_interface/linux/sys_calls_linux_ult.h
34@@ -7,6 +7,7 @@
35
36 #pragma once
37
38+#include <cstdint>
39 #include <dirent.h>
40 #include <iostream>
41 #include <poll.h>
42diff --git a/third_party/aot_config_headers/platforms.h b/third_party/aot_config_headers/platforms.h
43index 919e2714f2..ee82cb7ff2 100644
44--- a/third_party/aot_config_headers/platforms.h
45+++ b/third_party/aot_config_headers/platforms.h
46@@ -7,6 +7,7 @@
47
48 #include <map>
49 #include <string>
50+#include <cstdint>
51
52 #pragma once
53
54--
552.34.1
56
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch
index 7bbe9e8e..265fcfa2 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch
@@ -1,4 +1,4 @@
1From 0521d87f3f2cc1ceab89e72e1015d195cb9d17f0 Mon Sep 17 00:00:00 2001 1From a6361d635e5f3046853883f3ac06fb175116933c Mon Sep 17 00:00:00 2001
2From: Dongwon Kim <dongwon.kim@intel.com> 2From: Dongwon Kim <dongwon.kim@intel.com>
3Date: Sat, 21 Aug 2021 16:09:39 -0700 3Date: Sat, 21 Aug 2021 16:09:39 -0700
4Subject: [PATCH] Build not able to locate cpp_generation_tool. 4Subject: [PATCH] Build not able to locate cpp_generation_tool.
@@ -8,26 +8,26 @@ Upstream-Status: Inappropriate [oe specific]
8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> 8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
9Signed-off-by: Dongwon Kim <dongwon.kim@intel.com> 9Signed-off-by: Dongwon Kim <dongwon.kim@intel.com>
10--- 10---
11 shared/source/built_ins/kernels/CMakeLists.txt | 8 ++++---- 11 shared/source/built_ins/kernels/CMakeLists.txt | 10 +++++-----
12 1 file changed, 4 insertions(+), 4 deletions(-) 12 1 file changed, 5 insertions(+), 5 deletions(-)
13 13
14diff --git a/shared/source/built_ins/kernels/CMakeLists.txt b/shared/source/built_ins/kernels/CMakeLists.txt 14diff --git a/shared/source/built_ins/kernels/CMakeLists.txt b/shared/source/built_ins/kernels/CMakeLists.txt
15index 8ac6faf4d6..031e128149 100644 15index ed85a37c52..f7c9e79137 100644
16--- a/shared/source/built_ins/kernels/CMakeLists.txt 16--- a/shared/source/built_ins/kernels/CMakeLists.txt
17+++ b/shared/source/built_ins/kernels/CMakeLists.txt 17+++ b/shared/source/built_ins/kernels/CMakeLists.txt
18@@ -81,9 +81,9 @@ function(compile_builtin core_type platform_type builtin bits builtin_options mo 18@@ -107,9 +107,9 @@ function(compile_builtin core_type platform_it builtin bits builtin_options mode
19 ) 19 )
20 add_custom_command( 20 add_custom_command(
21 OUTPUT ${OUTPUT_FILE_CPP} 21 OUTPUT ${OUTPUT_FILE_CPP}
22- COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${BINARY_OUTPUT}.bin --output ${OUTPUT_FILE_CPP} --array ${mode}_${BASENAME} --platform ${platform_it_lower} --revision_id ${REVISION_ID} 22- COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${BINARY_OUTPUT}.bin --output ${OUTPUT_FILE_CPP} --array ${mode}_${BASENAME} --device ${RELEASE_FILENAME}
23+ COMMAND cpp_generate_tool --file ${BINARY_OUTPUT}.bin --output ${OUTPUT_FILE_CPP} --array ${mode}_${BASENAME} --platform ${platform_it_lower} --revision_id ${REVISION_ID} 23+ COMMAND cpp_generate_tool --file ${BINARY_OUTPUT}.bin --output ${OUTPUT_FILE_CPP} --array ${mode}_${BASENAME} --device ${RELEASE_FILENAME}
24 WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} 24 WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
25- DEPENDS ${OUTPUT_FILES_BINARIES} $<TARGET_FILE:cpp_generate_tool> 25- DEPENDS ${OUTPUT_FILES_BINARIES} $<TARGET_FILE:cpp_generate_tool>
26+ DEPENDS ${OUTPUT_FILES_BINARIES} cpp_generate_tool 26+ DEPENDS ${OUTPUT_FILES_BINARIES} cpp_generate_tool
27 ) 27 )
28 list(APPEND BUILTINS_COMMANDS "${OUTPUT_FILE_CPP}") 28 list(APPEND BUILTINS_COMMANDS "${OUTPUT_FILE_CPP}")
29 else() 29 else()
30@@ -134,9 +134,9 @@ function(generate_cpp_spirv builtin) 30@@ -159,9 +159,9 @@ function(generate_cpp_spirv builtin)
31 ) 31 )
32 add_custom_command( 32 add_custom_command(
33 OUTPUT ${OUTPUT_FILE_CPP} 33 OUTPUT ${OUTPUT_FILE_CPP}
@@ -39,6 +39,13 @@ index 8ac6faf4d6..031e128149 100644
39 ) 39 )
40 set(OUTPUT_LIST_CPP_FILES ${OUTPUT_LIST_CPP_FILES} ${OUTPUT_FILE_CPP} PARENT_SCOPE) 40 set(OUTPUT_LIST_CPP_FILES ${OUTPUT_LIST_CPP_FILES} ${OUTPUT_FILE_CPP} PARENT_SCOPE)
41 else() 41 else()
42@@ -277,4 +277,4 @@ if(NOT "${OUTPUT_LIST_CPP_FILES}" STREQUAL "")
43 )
44 endif()
45
46-apply_macro_for_each_core_type("SUPPORTED")
47\ No newline at end of file
48+apply_macro_for_each_core_type("SUPPORTED")
42-- 49--
432.37.3 502.43.2
44 51
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.22.26516.18.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.05.28454.6.bb
index f3372672..60125171 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.22.26516.18.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.05.28454.6.bb
@@ -4,18 +4,17 @@ is an open source project to converge Intel's development efforts \
4on OpenCL(TM) compute stacks supporting the GEN graphics hardware \ 4on OpenCL(TM) compute stacks supporting the GEN graphics hardware \
5architecture." 5architecture."
6 6
7LICENSE = "MIT" 7LICENSE = "MIT & Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \ 8LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \
9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b" 9 file://third_party/opencl_headers/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
10 10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/23.22 \ 11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/24.05 \
12 file://disable-werror.patch \ 12 file://disable-werror.patch \
13 file://add-missing-cstdint-header-to-fix-compile-with-gcc13.patch \
14 file://allow-to-find-cpp-generation-tool.patch \ 13 file://allow-to-find-cpp-generation-tool.patch \
15 file://external-ocloc.patch \ 14 file://external-ocloc.patch \
16 " 15 "
17 16
18SRCREV = "f6bf19f1dde6b852676c319a7c67a0a4c3f25d02" 17SRCREV = "23a9725e62c8181193c90e5e5207507a1f136587"
19 18
20S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
21 20