summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2023-01-09 12:07:30 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-01-09 17:14:30 +0800
commit7d7aaa0826756bd7fb22e606e6d4a53ce3709497 (patch)
tree15972d8577b183bf5d70f178f3940cea0fad1135 /dynamic-layers/clang-layer
parent1ef50594738845e8228fb1caa9b90f1ab6331b41 (diff)
downloadmeta-intel-7d7aaa0826756bd7fb22e606e6d4a53ce3709497.tar.gz
intel-graphics-compiler: fix buildpaths warnings
Clone SPIRV-Tools and Headers in S instead of WORKDIR so they don't escape file-prefix-map substitutions. Fixes buildpaths warnings: | WARNING: intel-graphics-compiler-1.0.12812.9-r0 do_package_qa: QA Issue: File /usr/lib/.debug/libigc.so.1.0.1 in package intel-graphics-compiler-dbg contains reference to TMPDIR [buildpaths] Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-external-SPIRV-Tools-change-path-to-tools-and-header.patch33
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.12812.9.bb5
2 files changed, 36 insertions, 2 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-external-SPIRV-Tools-change-path-to-tools-and-header.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-external-SPIRV-Tools-change-path-to-tools-and-header.patch
new file mode 100644
index 00000000..79d70d3e
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-external-SPIRV-Tools-change-path-to-tools-and-header.patch
@@ -0,0 +1,33 @@
1From 776692307258f273d54b81c00701a0ad01c9f4e4 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 9 Jan 2023 11:43:05 +0800
4Subject: [PATCH] external/SPIRV-Tools: change path to tools and headers
5
6We clone the SPIRV headers and tools in a different directory to ensure
7file path substitutions take place.
8
9Upstream-Status: Inappropriate
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12---
13 external/SPIRV-Tools/CMakeLists.txt | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/external/SPIRV-Tools/CMakeLists.txt b/external/SPIRV-Tools/CMakeLists.txt
17index 076079f7c..3b2059f88 100644
18--- a/external/SPIRV-Tools/CMakeLists.txt
19+++ b/external/SPIRV-Tools/CMakeLists.txt
20@@ -42,8 +42,8 @@ else() #By default use build from sources
21 message(STATUS "[SPIRV-Tools] : Building from source")
22 message(STATUS "[SPIRV-Tools] : Current source dir: ${CMAKE_CURRENT_SOURCE_DIR}")
23
24- set(SPIRV-Headers_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/../../SPIRV-Headers") # used in subdirectory
25- set(SPIRV-Tools_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/../../SPIRV-Tools")
26+ set(SPIRV-Headers_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/../SPIRV-Headers") # used in subdirectory
27+ set(SPIRV-Tools_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/../SPIRV-Tools")
28
29 set(SPIRV-Tools_OUTPUT_DIR "${IGC_OPTION__OUTPUT_DIR}/external/SPIRV-Tools/build")
30 set(IGC_BUILD__SPIRV-Headers_DIR "${SPIRV-Headers_SOURCE_DIR}")
31--
322.37.3
33
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.12812.9.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.12812.9.bb
index e5a3f858..dbd0c934 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.12812.9.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.12812.9.bb
@@ -10,14 +10,15 @@ LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc
10 10
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;name=igc;branch=releases/igc-1.0.12812 \ 11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;name=igc;branch=releases/igc-1.0.12812 \
12 git://github.com/intel/vc-intrinsics.git;protocol=https;destsuffix=git/vc-intrinsics;name=vc;nobranch=1 \ 12 git://github.com/intel/vc-intrinsics.git;protocol=https;destsuffix=git/vc-intrinsics;name=vc;nobranch=1 \
13 git://github.com/KhronosGroup/SPIRV-Tools.git;protocol=https;destsuffix=SPIRV-Tools;name=spirv-tools;branch=sdk-1.3.204 \ 13 git://github.com/KhronosGroup/SPIRV-Tools.git;protocol=https;destsuffix=git/SPIRV-Tools;name=spirv-tools;branch=sdk-1.3.204 \
14 git://github.com/KhronosGroup/SPIRV-Headers.git;protocol=https;destsuffix=SPIRV-Headers;name=spirv-headers;branch=master \ 14 git://github.com/KhronosGroup/SPIRV-Headers.git;protocol=https;destsuffix=git/SPIRV-Headers;name=spirv-headers;branch=master \
15 file://0003-Improve-Reproducibility-for-src-package.patch \ 15 file://0003-Improve-Reproducibility-for-src-package.patch \
16 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \ 16 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \
17 file://c707d1e2244aec988bdd5d2a7473ef3a32a5bac7.patch \ 17 file://c707d1e2244aec988bdd5d2a7473ef3a32a5bac7.patch \
18 file://d1761dfc3ca6b54bac0ee213389a65f84d2aa9b7.patch \ 18 file://d1761dfc3ca6b54bac0ee213389a65f84d2aa9b7.patch \
19 file://e09e752949e7af0231884d1b11ea907e3e8b1611.patch \ 19 file://e09e752949e7af0231884d1b11ea907e3e8b1611.patch \
20 file://fix-build-with-llvm12.patch \ 20 file://fix-build-with-llvm12.patch \
21 file://0001-external-SPIRV-Tools-change-path-to-tools-and-header.patch \
21 " 22 "
22 23
23SRC_URI:append:class-native = " file://0001-fix-tblgen.patch" 24SRC_URI:append:class-native = " file://0001-fix-tblgen.patch"