summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-08-05 21:52:16 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-08-21 12:27:06 +0800
commit9c62233238a72a913090c175662f4b2550a2e3dd (patch)
tree805b6d058aac022bfcd6399d5885f6fa08c6610c /dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb
parent10b74dda871b4ce8244ef65f7c6463fd2217b181 (diff)
downloadmeta-intel-9c62233238a72a913090c175662f4b2550a2e3dd.tar.gz
opencl-clang: move to a separate recipe
Since this is managed as a separate repository, build it as a separate component instead of bundling with LLVM/clang. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb
new file mode 100644
index 00000000..6599c9b6
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Common clang is a thin wrapper library around clang"
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4
5LICENSE = "NCSA"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-80;protocol=https \
9 file://point-to-correct-llvm-tblgen.patch \
10 "
11
12SRCREV = "daf5e4dd718477ae8cf89a283c653939d9182f15"
13
14S = "${WORKDIR}/git"
15
16inherit cmake
17DEPENDS += "clang clang-native"
18
19DEPENDS_append_class-target = " opencl-clang-native"
20LDFLAGS_append_class-native = " -fuse-ld=lld"
21
22COMPATIBLE_HOST = '(x86_64).*-linux'
23COMPATIBLE_HOST_libc-musl = "null"
24
25EXTRA_OECMAKE += "\
26 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
27 -DCMAKE_SKIP_RPATH=TRUE \
28 "
29
30do_install_append_class-native() {
31 install -d ${D}${bindir}
32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
33}
34
35BBCLASSEXTEND = "native nativesdk"