summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-08-05 21:52:16 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-08-21 12:27:06 +0800
commit9c62233238a72a913090c175662f4b2550a2e3dd (patch)
tree805b6d058aac022bfcd6399d5885f6fa08c6610c /dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch
parent10b74dda871b4ce8244ef65f7c6463fd2217b181 (diff)
downloadmeta-intel-9c62233238a72a913090c175662f4b2550a2e3dd.tar.gz
opencl-clang: move to a separate recipe
Since this is managed as a separate repository, build it as a separate component instead of bundling with LLVM/clang. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch
new file mode 100644
index 00000000..b0bfa6ee
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch
@@ -0,0 +1,38 @@
1From 40be69a2c9460aea40beab8734684050988b9322 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 26 Mar 2019 14:11:29 +0800
4Subject: [PATCH] point to correct llvm-tblgen
5
6Let llvm-tblgen path be passed from recipe itself.
7
8Also since we're going to do the patching ourselves, no need to look for
9git through cmake.
10
11Upstream-Status: Inappropriate [OE specific]
12
13---
14 CMakeLists.txt | 4 ++--
15 1 file changed, 2 insertions(+), 2 deletions(-)
16
17diff --git a/CMakeLists.txt b/CMakeLists.txt
18index 174133b..be409e5 100644
19--- a/CMakeLists.txt
20+++ b/CMakeLists.txt
21@@ -53,7 +53,7 @@ endif(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
22 include(AddLLVM)
23 include(TableGen)
24
25-find_package(Git REQUIRED)
26+#find_package(Git REQUIRED)
27
28 if (NOT WIN32)
29 add_subdirectory( linux_linker )
30@@ -102,7 +102,7 @@ endif(NOT USE_PREBUILT_LLVM)
31 set (COMPILE_OPTIONS_TD opencl_clang_options.td)
32 set (COMPILE_OPTIONS_INC opencl_clang_options.inc)
33
34-set(LLVM_TABLEGEN_EXE "llvm-tblgen")
35+#set(LLVM_TABLEGEN_EXE "llvm-tblgen")
36 set(LLVM_TARGET_DEFINITIONS ${COMPILE_OPTIONS_TD})
37 if(USE_PREBUILT_LLVM)
38 set(TABLEGEN_ADDITIONAL -I ${LLVM_INCLUDE_DIRS})