summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-10-13 23:41:39 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-10-15 13:18:40 +0800
commita3ba71f4b98ebcdbc0207990d10c828cd94201b6 (patch)
treeacf893df2a0d20aee2b6b8dae822457eeaab5500 /dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb
parentc265ab944f6590d151a1e1f8a8358771ef3ade4f (diff)
downloadmeta-intel-a3ba71f4b98ebcdbc0207990d10c828cd94201b6.tar.gz
igc: upgrade 1.0.4756 -> 1.0.5176
Include compatibility for both LLVM 10 and LLVM 11. Vector Compiler fails to compile for LLVM 11 so disable the build for now. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb42
1 files changed, 0 insertions, 42 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb
deleted file mode 100644
index e13f34b9..00000000
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb
+++ /dev/null
@@ -1,42 +0,0 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
8 file://IGC/Compiler/LegalizationPass.cpp;beginline=1;endline=25;md5=4abf1738ff96b18e34186eb763e28eeb \
9 file://NOTICES.txt;md5=b12e73994de4fbe0f688cf0bc91512a0"
10
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \
12 file://0001-skip-execution-of-ElfPackager.patch \
13 file://link-to-LLVMGenXIntrinsics.patch \
14 file://improve_src_package_reproducibility.patch \
15 "
16
17SRCREV = "3623209b10b357ddb3a3d6eac3551c53ebc897f7"
18
19# Used to replace with relative path in reproducibility patch
20export B
21
22S = "${WORKDIR}/git"
23
24inherit cmake
25
26COMPATIBLE_HOST = '(x86_64).*-linux'
27COMPATIBLE_HOST_libc-musl = "null"
28
29DEPENDS += " flex-native bison-native clang opencl-clang vc-intrinsics"
30DEPENDS_append_class-target = " clang-cross-x86_64"
31
32RDEPENDS_${PN} += "opencl-clang"
33
34EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=10.0.0 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DINSTALL_SPIRVDLL=0"
35
36BBCLASSEXTEND = "native nativesdk"
37
38UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$"
39
40FILES_${PN} += " \
41 ${libdir}/igc/NOTICES.txt \
42 "