summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb
diff options
context:
space:
mode:
authorLee Chee Yang <chee.yang.lee@intel.com>2020-09-22 10:33:59 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-09-24 08:50:39 +0800
commita01cbe26e343f2c5cd42e134b05d3e99c73ad9e6 (patch)
tree3e491eb107510305cc9a55183f39d5ab7c8e48e3 /dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb
parent254e3a79b3a37045f829848e0a5e04801bec1439 (diff)
downloadmeta-intel-a01cbe26e343f2c5cd42e134b05d3e99c73ad9e6.tar.gz
intel-graphics-compiler: improve src package reproducibility
Improve the reproducibility of intel-graphics-compiler-src by replacing the absolute build path with relative one in bison compiled files. The --file-prefix-map could only work on bison 3.7 onward so add it only when bison is newer than 3.7. │ │ │ -#ifndef YY_CISA_YOCTO_POKY_MASTER_BUILD_TMP_WORK_SKYLAKE_64_POKY_LINUX_INTEL_GRAPHICS_COMPILER_1_0_4241_R0_BUILD_IGC_VISA_CISA_TAB_HPP_INCLUDED │ │ │ -# define YY_CISA_YOCTO_POKY_MASTER_BUILD_TMP_WORK_SKYLAKE_64_POKY_LINUX_INTEL_GRAPHICS_COMPILER_1_0_4241_R0_BUILD_IGC_VISA_CISA_TAB_HPP_INCLUDED │ │ │ +#ifndef YY_CISA_YOCTO_POKY_MASTER_BUILD_2_TMP_WORK_SKYLAKE_64_POKY_LINUX_INTEL_GRAPHICS_COMPILER_1_0_4241_R0_BUILD_IGC_VISA_CISA_TAB_HPP_INCLUDED │ │ │ +# define YY_CISA_YOCTO_POKY_MASTER_BUILD_2_TMP_WORK_SKYLAKE_64_POKY_LINUX_INTEL_GRAPHICS_COMPILER_1_0_4241_R0_BUILD_IGC_VISA_CISA_TAB_HPP_INCLUDED Also suppress #line directives in scanner that have the build path: │ │ │ -#line 2593 "/yocto/poky-master/build/tmp/work/skylake-64-poky-linux/intel-graphics-compiler/1.0.4241-r0/build/IGC/visa/lex.CISA.cpp" │ │ │ +#line 2593 "/yocto/poky-master/build-2/tmp/work/skylake-64-poky-linux/intel-graphics-compiler/1.0.4241-r0/build/IGC/visa/lex.CISA.cpp" Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb
index 406f9f18..e13f34b9 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb
@@ -11,10 +11,14 @@ LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \ 11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \
12 file://0001-skip-execution-of-ElfPackager.patch \ 12 file://0001-skip-execution-of-ElfPackager.patch \
13 file://link-to-LLVMGenXIntrinsics.patch \ 13 file://link-to-LLVMGenXIntrinsics.patch \
14 file://improve_src_package_reproducibility.patch \
14 " 15 "
15 16
16SRCREV = "3623209b10b357ddb3a3d6eac3551c53ebc897f7" 17SRCREV = "3623209b10b357ddb3a3d6eac3551c53ebc897f7"
17 18
19# Used to replace with relative path in reproducibility patch
20export B
21
18S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
19 23
20inherit cmake 24inherit cmake