summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch
diff options
context:
space:
mode:
authorLee Chee Yang <chee.yang.lee@intel.com>2020-09-10 15:09:16 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-09-10 15:18:20 +0800
commitc6ca760d24dc016434e79a6aceeb608fba890a3c (patch)
treea906478e13f93a58df7f49d501b14756d684a213 /dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch
parent059166879397fea8fe6689f53c7434003b81e742 (diff)
downloadmeta-intel-c6ca760d24dc016434e79a6aceeb608fba890a3c.tar.gz
intel-graphics-compiler: improve src package reproducibility
Improve the reproducibility of intel-graphics-compiler-src by replacing the absolute build path with relative one in bison compiled files. │ │ │ -#ifndef YY_CISA_YOCTO_POKY_MASTER_BUILD_TMP_WORK_SKYLAKE_64_POKY_LINUX_INTEL_GRAPHICS_COMPILER_1_0_4241_R0_BUILD_IGC_VISA_CISA_TAB_HPP_INCLUDED │ │ │ -# define YY_CISA_YOCTO_POKY_MASTER_BUILD_TMP_WORK_SKYLAKE_64_POKY_LINUX_INTEL_GRAPHICS_COMPILER_1_0_4241_R0_BUILD_IGC_VISA_CISA_TAB_HPP_INCLUDED │ │ │ +#ifndef YY_CISA_YOCTO_POKY_MASTER_BUILD_2_TMP_WORK_SKYLAKE_64_POKY_LINUX_INTEL_GRAPHICS_COMPILER_1_0_4241_R0_BUILD_IGC_VISA_CISA_TAB_HPP_INCLUDED │ │ │ +# define YY_CISA_YOCTO_POKY_MASTER_BUILD_2_TMP_WORK_SKYLAKE_64_POKY_LINUX_INTEL_GRAPHICS_COMPILER_1_0_4241_R0_BUILD_IGC_VISA_CISA_TAB_HPP_INCLUDED Also suppress #line directives in scanner that have the build path: │ │ │ -#line 2593 "/yocto/poky-master/build/tmp/work/skylake-64-poky-linux/intel-graphics-compiler/1.0.4241-r0/build/IGC/visa/lex.CISA.cpp" │ │ │ +#line 2593 "/yocto/poky-master/build-2/tmp/work/skylake-64-poky-linux/intel-graphics-compiler/1.0.4241-r0/build/IGC/visa/lex.CISA.cpp" Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch
new file mode 100644
index 00000000..e9e9b439
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch
@@ -0,0 +1,31 @@
1From 88b961ce4e2c9744631c51d13fa638e8a8a6c2a9 Mon Sep 17 00:00:00 2001
2From: Lee Chee Yang <chee.yang.lee@intel.com>
3Date: Wed, 2 Sep 2020 08:28:35 +0800
4Subject: [PATCH] Improve Reproducibility for src package
5
6Improve reproducibility for intel-graphics-compiler-src package.
7needs to pass build path as environment variable to the build.
8
9Upstream-Status: Inappropriate [applying --file-prefix-map in such way does not work for upstream]
10Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com>
11---
12 visa/CMakeLists.txt | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/visa/CMakeLists.txt b/visa/CMakeLists.txt
16index 9c169592..ecea91db 100644
17--- a/visa/CMakeLists.txt
18+++ b/visa/CMakeLists.txt
19@@ -105,8 +105,8 @@ endif()
20 # Set up the bison and flex targets. These commands will set up commands to generate the appropriate
21 # source files from the input grammars. It will also set up the dependencies correctly for any
22 # library or executable that uses the generated source
23-BISON_TARGET(CISAParser CISA.y ${CMAKE_CURRENT_BINARY_DIR}/CISA.tab.cpp COMPILE_FLAGS "-vt -p CISA")
24-FLEX_TARGET(CISAScanner CISA.l ${CMAKE_CURRENT_BINARY_DIR}/lex.CISA.cpp COMPILE_FLAGS "-PCISA ${WIN_FLEX_FLAG}")
25+BISON_TARGET(CISAParser CISA.y ${CMAKE_CURRENT_BINARY_DIR}/CISA.tab.cpp COMPILE_FLAGS "-vt -p CISA --file-prefix-map=$ENV{B}=/igc/")
26+FLEX_TARGET(CISAScanner CISA.l ${CMAKE_CURRENT_BINARY_DIR}/lex.CISA.cpp COMPILE_FLAGS "-PCISA -L ${WIN_FLEX_FLAG} ")
27 ADD_FLEX_BISON_DEPENDENCY(CISAScanner CISAParser)
28
29 add_custom_target(CISAScanner_target DEPENDS ${FLEX_CISAScanner_OUTPUTS} ${BISON_CISAParser_OUTPUTS})
30--
312.25.1