summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.24.17065.bb
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-06-26 10:24:08 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-06-26 11:54:15 +0800
commit69abe5db6a85b24876bf85596cfa875658da7e2f (patch)
tree5a48309280d06fa0411eb7ac0fbee9798cda3aae /dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.24.17065.bb
parentcd220f66c40155b2bd5bc97182405f184c52099d (diff)
downloadmeta-intel-69abe5db6a85b24876bf85596cfa875658da7e2f.tar.gz
intel-compute-runtime: upgrade 20.20.16837 -> 20.24.17065
Release notes: https://github.com/intel/compute-runtime/releases/tag/20.24.17065 Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.24.17065.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.24.17065.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.24.17065.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.24.17065.bb
new file mode 100644
index 00000000..22fbf031
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.24.17065.bb
@@ -0,0 +1,53 @@
1SUMMARY = "The Intel(R) Graphics Compute Runtime for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compute Runtime for OpenCL(TM) \
3is an open source project to converge Intel's development efforts \
4on OpenCL(TM) compute stacks supporting the GEN graphics hardware \
5architecture."
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=ae27f47fd6755510247c19e547e4c804 \
9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b"
10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \
12 "
13SRC_URI_append_class-target = " file://allow-to-find-cpp-generation-tool.patch"
14
15SRCREV = "22076663e44135e6b7a83ad3ccd76d8a100a78ed"
16
17S = "${WORKDIR}/git"
18
19DEPENDS += " intel-graphics-compiler gmmlib clang"
20DEPENDS_append_class-target = " intel-compute-runtime-native"
21
22RDEPENDS_${PN} += " intel-graphics-compiler gmmlib"
23
24inherit cmake pkgconfig
25
26COMPATIBLE_HOST = '(x86_64).*-linux'
27COMPATIBLE_HOST_libc-musl = "null"
28
29EXTRA_OECMAKE = " \
30 -DIGC_DIR=${STAGING_INCDIR}/igc \
31 -DBUILD_TYPE=Release \
32 -DSKIP_UNIT_TESTS=1 \
33 -DCCACHE_ALLOWED=FALSE \
34 "
35EXTRA_OECMAKE_append_class-target = " \
36 -Dcloc_cmd_prefix=ocloc \
37 "
38do_install_append_class-native() {
39 install -d ${D}${bindir}
40 install ${B}/bin/cpp_generate_tool ${D}${bindir}/
41}
42
43SOLIBS = ".so"
44FILES_SOLIBSDEV = ""
45
46FILES_${PN} += " \
47 ${libdir}/intel-opencl/libigdrcl.so \
48 ${libdir}/libocloc.so \
49 "
50
51BBCLASSEXTEND = "native nativesdk"
52
53UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"