summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-04-24 13:38:34 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-04-27 16:23:50 +0800
commitd45a72dc4b912b8f754d3a4e17593b49ac5a2f6b (patch)
treefc3c36859eab817c264cee6ed6ea4d968558e33f /dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch
parentd8d1cc3023aa63049fe18052120d74a1e9cae16e (diff)
downloadmeta-intel-d45a72dc4b912b8f754d3a4e17593b49ac5a2f6b.tar.gz
llvm-project-source: allow to use with zeus release
In order to use latest opencl versions with zeus, carrying llvm9 specific patches, and conditinally applying based on LLVMVERSION. In zeus release, LLVMVERSION points to 9.x. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch b/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch
new file mode 100644
index 00000000..9a7b8445
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch
@@ -0,0 +1,51 @@
1From 48e50f06b1bbed94cdf5207587161d4bfce7366e Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 21 Aug 2019 14:35:31 +0800
4Subject: [PATCH] llvm-spirv: skip building tests
5
6Some of these need clang to be built and since we're building this in-tree,
7that leads to problems when compiling libcxx, compiler-rt which aren't built
8in-tree.
9
10Instead of using SPIRV_SKIP_CLANG_BUILD to skip clang build and adding this to
11all components, disable the building of tests altogether.
12
13Upstream-Status: Inappropriate
14
15Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
16Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
17---
18 CMakeLists.txt | 10 ----------
19 1 file changed, 10 deletions(-)
20
21diff --git a/CMakeLists.txt b/CMakeLists.txt
22index 1208741..20ca3e6 100644
23--- a/CMakeLists.txt
24+++ b/CMakeLists.txt
25@@ -15,13 +15,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
26 set(CMAKE_CXX_STANDARD 11)
27 set(CMAKE_CXX_STANDARD_REQUIRED ON)
28
29- if(LLVM_INCLUDE_TESTS)
30- set(LLVM_TEST_COMPONENTS
31- llvm-as
32- llvm-dis
33- )
34- endif(LLVM_INCLUDE_TESTS)
35-
36 find_package(LLVM 9.0.0 REQUIRED
37 COMPONENTS
38 Analysis
39@@ -56,9 +49,6 @@ set(LLVM_SPIRV_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/include)
40
41 add_subdirectory(lib/SPIRV)
42 add_subdirectory(tools/llvm-spirv)
43-if(LLVM_INCLUDE_TESTS)
44- add_subdirectory(test)
45-endif(LLVM_INCLUDE_TESTS)
46
47 install(
48 FILES
49--
502.17.1
51