summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorShashwat Pandey <shashwatx.pandey@intel.com>2017-02-23 17:26:27 +0800
committerCalifornia Sullivan <california.l.sullivan@intel.com>2017-02-28 16:05:01 -0800
commitf6e8abbfdee736e273d2943fceaec828501b5606 (patch)
treea16c3bcd78e1da21ff9628a83de0f1eb3ba275a1 /common
parent3d22362dcf015e039fb8f578d0c3bfecace82f18 (diff)
downloadmeta-intel-f6e8abbfdee736e273d2943fceaec828501b5606.tar.gz
dpdk: Add libibverbs library to support MLX config
libibverbs is a library that allows programs to use RDMA "verbs" for direct access to RDMA (currently InfiniBand and iWARP) hardware from userspace. Dpdk has some dependencies with this package to enable CONFIG_RTE_LIBRTE_MLX4_PMD config for supporting Mellanoc Connect X-3 nics with it. This config has disabled in dpdk by default. Signed-off-by: Shashwat Pandey <shashwatx.pandey@intel.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/common/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb b/common/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb
new file mode 100644
index 00000000..13943ea7
--- /dev/null
+++ b/common/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "libibverbs library to support Mellanox config"
2HOMEPAGE = "https://github.com/Mellanox/dpdk-dev-libibverbs"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=7c557f27dd795ba77cc419dddc656b51"
5
6SRC_URI = "https://github.com/Mellanox/dpdk-dev-libibverbs/archive/libibverbs-${PV}.tar.gz;name=${PN}"
7
8SRC_URI[dpdk-dev-libibverbs.md5sum] = "65234ee278eb437a7069326f37cd4d86"
9SRC_URI[dpdk-dev-libibverbs.sha256sum] = "a6471515556cb8d10ad471bb7efb8cf760b248a28aceb57d4534d50d572f56cd"
10
11COMPATIBLE_MACHINE = "intel-corei7-64"
12
13S = "${WORKDIR}/${PN}-libibverbs-${PV}"
14COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
15DEPENDS = "libnl"
16
17inherit pkgconfig autotools