summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-02-20 22:42:16 +0000
committerSaul Wold <sgw@linux.intel.com>2017-03-07 12:22:22 -0800
commitce81e55f62f22f662e3466593c9434a46142f3c5 (patch)
tree095a734c84632cf829260c70128b27c9bfca2d44 /common
parentba824ee3df4e5c3763fa36897e9eb8a3c1926178 (diff)
downloadmeta-intel-ce81e55f62f22f662e3466593c9434a46142f3c5.tar.gz
core-image-tiny-initramfs: Choose WKS_FILE correctly between architectures
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-core/images/core-image-tiny-initramfs.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/common/recipes-core/images/core-image-tiny-initramfs.bbappend b/common/recipes-core/images/core-image-tiny-initramfs.bbappend
new file mode 100644
index 00000000..bb1a4770
--- /dev/null
+++ b/common/recipes-core/images/core-image-tiny-initramfs.bbappend
@@ -0,0 +1,10 @@
1# Set WKS file depending on the MACHINE picked by the user
2def wks_intel(d):
3 if d.getVar('MACHINE', True) == "intel-core2-32":
4 d.setVar('WKS_FILE', "systemd-bootdisk-tiny32.wks")
5 elif d.getVar('MACHINE', True) == "intel-corei7-64":
6 d.setVar('WKS_FILE', "systemd-bootdisk-tiny64.wks")
7 elif d.getVar('MACHINE', True) == "intel-quark":
8 d.setVar('WKS_FILE', "mktinygalileodisk.wks")
9
10WKS_FILE_poky-tiny ?= "${@wks_intel(d)}"