summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-01 23:03:06 -0700
committerSaul Wold <sgw@linux.intel.com>2017-08-02 08:44:31 -0700
commit740e34f1e7d8cfd6bfd4bda8f78d9763d8cb0ae2 (patch)
tree107e5481d5c5225c19a1112fcff641c82269b7ec /common
parentacf1fd18c21eb9d1fd9c2d1dce4f914a59a82322 (diff)
downloadmeta-intel-740e34f1e7d8cfd6bfd4bda8f78d9763d8cb0ae2.tar.gz
qat16: Fix build when ld-is-gold is set in DISTRO_FEATURES
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-extended/qat/qat16.inc2
-rw-r--r--common/recipes-extended/qat/qat16/use-CC-for-LD.patch17
-rw-r--r--common/recipes-extended/qat/qat16_2.6.0-65.bb1
3 files changed, 19 insertions, 1 deletions
diff --git a/common/recipes-extended/qat/qat16.inc b/common/recipes-extended/qat/qat16.inc
index d45967a3..cf112bbd 100644
--- a/common/recipes-extended/qat/qat16.inc
+++ b/common/recipes-extended/qat/qat16.inc
@@ -60,7 +60,7 @@ do_unpack2() {
60addtask unpack2 after do_unpack before do_patch 60addtask unpack2 after do_unpack before do_patch
61 61
62do_compile () { 62do_compile () {
63 export LD="${LD} --hash-style=gnu" 63 export LD="${CC} -Wl,--hash-style=gnu -nostartfiles -nodefaultlibs"
64 export MACHINE="${TARGET_ARCH}" 64 export MACHINE="${TARGET_ARCH}"
65 cd ${S}/quickassist 65 cd ${S}/quickassist
66 oe_runmake 66 oe_runmake
diff --git a/common/recipes-extended/qat/qat16/use-CC-for-LD.patch b/common/recipes-extended/qat/qat16/use-CC-for-LD.patch
new file mode 100644
index 00000000..36ceedf4
--- /dev/null
+++ b/common/recipes-extended/qat/qat16/use-CC-for-LD.patch
@@ -0,0 +1,17 @@
1Use CC to do the linking, helps in linking with gold or bfd linker
2
3Upstream-Status: Inappropriate [OE-Specific]
4Signed-off-by: Khem Raj <raj.khem@gmail.com>
5Index: QAT1.6/quickassist/build_system/build_files/OS/linux_2.6.mk
6===================================================================
7--- QAT1.6.orig/quickassist/build_system/build_files/OS/linux_2.6.mk
8+++ QAT1.6/quickassist/build_system/build_files/OS/linux_2.6.mk
9@@ -89,7 +89,7 @@ EXTRA_CFLAGS+= -Wno-div-by-zero -Wfloat-
10 endif
11
12
13-LIB_SHARED_FLAGS+=-shared -soname $(LIB_SHARED)
14+LIB_SHARED_FLAGS+=-shared -Wl,-soname,$(LIB_SHARED)
15 LIB_STATIC_FLAGS=
16 EXE_FLAGS?=
17
diff --git a/common/recipes-extended/qat/qat16_2.6.0-65.bb b/common/recipes-extended/qat/qat16_2.6.0-65.bb
index ba0b4ed4..88cf66c3 100644
--- a/common/recipes-extended/qat/qat16_2.6.0-65.bb
+++ b/common/recipes-extended/qat/qat16_2.6.0-65.bb
@@ -3,6 +3,7 @@ include qat16.inc
3SRC_URI += "https://01.org/sites/default/files/page/qatmux.l.2.6.0-60.tgz;name=qat \ 3SRC_URI += "https://01.org/sites/default/files/page/qatmux.l.2.6.0-60.tgz;name=qat \
4 file://qat16_2.6.0-65-qat-add-install-target-to-makefiles.patch \ 4 file://qat16_2.6.0-65-qat-add-install-target-to-makefiles.patch \
5 file://qat16_2.6.0-65-qat-override-CC-LD-AR-only-when-it-is-not-define.patch \ 5 file://qat16_2.6.0-65-qat-override-CC-LD-AR-only-when-it-is-not-define.patch \
6 file://use-CC-for-LD.patch \
6 " 7 "
7 8
8SRC_URI_append_libc-musl = " file://0001-OsalServices-Only-use-bits-time-with-GLIBC.patch" 9SRC_URI_append_libc-musl = " file://0001-OsalServices-Only-use-bits-time-with-GLIBC.patch"