summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia
diff options
context:
space:
mode:
authorwudping <dongpingx.wu@intel.com>2016-12-25 22:16:01 -0500
committerCalifornia Sullivan <california.l.sullivan@intel.com>2017-01-03 11:12:18 -0800
commit4c928a6180b4d0baec6ebf7da20f203cd7554c49 (patch)
tree810ac17a3075f30c044f9812640448af9f601707 /common/recipes-multimedia
parent976d69576c9cc4df00afce5ffcc3d955b02b4f94 (diff)
downloadmeta-intel-4c928a6180b4d0baec6ebf7da20f203cd7554c49.tar.gz
libyami: hardware acceleration VA-API media-codec
Add libyami recipe. Libyami is intel VA-API Media codecs with hardware acceleration. It's core building block for media solution. The home website is: https://github.com/01org/libyami Signed-off-by: Xu Guangxin <guangxin.xu@intel.com> Signed-off-by: wudping <dongpingx.wu@intel.com>
Diffstat (limited to 'common/recipes-multimedia')
-rwxr-xr-xcommon/recipes-multimedia/libyami/libyami_1.0.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/common/recipes-multimedia/libyami/libyami_1.0.1.bb b/common/recipes-multimedia/libyami/libyami_1.0.1.bb
new file mode 100755
index 00000000..c4687911
--- /dev/null
+++ b/common/recipes-multimedia/libyami/libyami_1.0.1.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Yami is media infrastructure base on libva"
2DESCRIPTION = "Yet Another Media Infrastructure \
3light weight hardware codec library base on VA-API "
4
5HOMEPAGE = "https://github.com/01org/libyami"
6BUGTRACKER = "https://github.com/01org/libyami/issues/new"
7
8LICENSE = "Apache-2.0"
9SRC_URI = "https://github.com/01org/libyami/archive/libyami-${PV}.tar.gz"
10
11LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=3b83ef96387f14655fc854ddc3c6bd57"
12
13SRC_URI[md5sum] = "666909504c693f4b9186237b86ba43dc"
14SRC_URI[sha256sum] = "1051d3e3366a933c4fbfb883b3900e81a8c0e4e1cd4d5a08b9c7d4e1bf7cec34"
15
16S = "${WORKDIR}/libyami-libyami-${PV}"
17
18PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}"
19PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender"
20
21DEPENDS = "libva"
22inherit autotools pkgconfig