summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/libva
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-02-27 18:00:32 +0000
committerDarren Hart <dvhart@linux.intel.com>2015-02-27 10:11:59 -0800
commit9c4a574e556ed43e75704f28889daa53fa896ba4 (patch)
tree4e3391bd7e47451507a6c08477eef4487d1b3418 /common/recipes-multimedia/libva
parentde2894e7e32e3dfe9b1ac8930207c0a35ad89029 (diff)
downloadmeta-intel-9c4a574e556ed43e75704f28889daa53fa896ba4.tar.gz
libva: merge recipe and .inc
As there's just a single libva recipe now having .bb and .inc split only complicates packaging. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'common/recipes-multimedia/libva')
-rw-r--r--common/recipes-multimedia/libva/libva.inc46
-rw-r--r--common/recipes-multimedia/libva/libva_1.4.1.bb46
2 files changed, 44 insertions, 48 deletions
diff --git a/common/recipes-multimedia/libva/libva.inc b/common/recipes-multimedia/libva/libva.inc
deleted file mode 100644
index f7f50024..00000000
--- a/common/recipes-multimedia/libva/libva.inc
+++ /dev/null
@@ -1,46 +0,0 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "http://www.freedesktop.org/wiki/Software/vaapi"
14BUGTRACKER = "https://bugs.freedesktop.org"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20INC_PR = "r1"
21
22DEPENDS = "libdrm virtual/mesa virtual/libgles1 virtual/libgles2 virtual/egl"
23
24inherit autotools-brokensep pkgconfig
25
26EXTRA_OECONF = "--disable-dummy-driver"
27
28PACKAGECONFIG ??= "${@base_contains("DISTRO_FEATURES", "x11", "x11", "", d)} \
29 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland", "", d)}"
30PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
31PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland"
32
33PACKAGES =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl ${PN}-wayland"
34
35RDEPENDS_${PN}-tpi =+ "${PN}"
36RDEPENDS_${PN}-x11 =+ "${PN}"
37RDEPENDS_${PN}-glx =+ "${PN}-x11"
38RDEPENDS_${PN}-egl =+ "${PN}-x11"
39
40FILES_${PN}-dbg += "${libdir}/dri/.debug"
41
42FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
43FILES_${PN}-tpi =+ "${libdir}/libva-tpi*${SOLIBS}"
44FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
45FILES_${PN}-egl =+ "${libdir}/libva-egl*${SOLIBS}"
46FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"
diff --git a/common/recipes-multimedia/libva/libva_1.4.1.bb b/common/recipes-multimedia/libva/libva_1.4.1.bb
index 23a499c7..0d157da8 100644
--- a/common/recipes-multimedia/libva/libva_1.4.1.bb
+++ b/common/recipes-multimedia/libva/libva_1.4.1.bb
@@ -1,6 +1,48 @@
1require libva.inc 1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
2 12
3SRC_URI = "http://www.freedesktop.org/software/vaapi/releases/libva/${BP}.tar.bz2" 13HOMEPAGE = "http://www.freedesktop.org/wiki/Software/vaapi"
14BUGTRACKER = "https://bugs.freedesktop.org"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
4 19
20SRC_URI = "http://www.freedesktop.org/software/vaapi/releases/libva/${BP}.tar.bz2"
5SRC_URI[md5sum] = "8e3e7096750c14d1f98da807df7c1ba5" 21SRC_URI[md5sum] = "8e3e7096750c14d1f98da807df7c1ba5"
6SRC_URI[sha256sum] = "0662af0ecdf1cfd2bb47e86f5bf66009554fe12ce7bf5b9cec6a2cc43f3f4c11" 22SRC_URI[sha256sum] = "0662af0ecdf1cfd2bb47e86f5bf66009554fe12ce7bf5b9cec6a2cc43f3f4c11"
23
24DEPENDS = "libdrm virtual/mesa virtual/libgles1 virtual/libgles2 virtual/egl"
25
26inherit autotools-brokensep pkgconfig
27
28EXTRA_OECONF = "--disable-dummy-driver"
29
30PACKAGECONFIG ??= "${@base_contains("DISTRO_FEATURES", "x11", "x11", "", d)} \
31 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland", "", d)}"
32PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
33PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland"
34
35PACKAGES =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl ${PN}-wayland"
36
37RDEPENDS_${PN}-tpi =+ "${PN}"
38RDEPENDS_${PN}-x11 =+ "${PN}"
39RDEPENDS_${PN}-glx =+ "${PN}-x11"
40RDEPENDS_${PN}-egl =+ "${PN}-x11"
41
42FILES_${PN}-dbg += "${libdir}/dri/.debug"
43
44FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
45FILES_${PN}-tpi =+ "${libdir}/libva-tpi*${SOLIBS}"
46FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
47FILES_${PN}-egl =+ "${libdir}/libva-egl*${SOLIBS}"
48FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"