summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/libva/va-intel.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-11-07 10:32:26 -0800
committerSaul Wold <sgw@linux.intel.com>2017-11-20 15:33:02 -0800
commitd53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a (patch)
treefbe372dba00d45bbf9fbfbb3726708dc2590daeb /common/recipes-multimedia/libva/va-intel.bb
parent5adbf6df4fd89e7531ccccfb9cec7a5314d635f0 (diff)
downloadmeta-intel-d53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a.tar.gz
meta-intel: Reorganize the layout to remove common
Remove the concept of the common directory and move all the recipes-* dirs to the top level as a normal layer would be. layer.conf is updated appropriately Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-multimedia/libva/va-intel.bb')
-rw-r--r--common/recipes-multimedia/libva/va-intel.bb32
1 files changed, 0 insertions, 32 deletions
diff --git a/common/recipes-multimedia/libva/va-intel.bb b/common/recipes-multimedia/libva/va-intel.bb
deleted file mode 100644
index 88539e25..00000000
--- a/common/recipes-multimedia/libva/va-intel.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1DESCRIPTION = "Video Acceleration Add-ons for Intel BSPs"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5S = "${WORKDIR}"
6
7PR = "r1"
8
9def map_valibs(d):
10 # The intel implementation requires the libva-intel-driver package
11 if bb.utils.contains('MACHINE_FEATURES', 'va-impl-intel', "1", "0", d) == "1":
12 return "libva libva-intel-driver"
13 # All meta-intel video acceleration requires libva
14 return "libva"
15
16VA_IMPL = "${@map_valibs(d)}"
17
18PACKAGES = "\
19 va-intel \
20 "
21
22ALLOW_EMPTY_va-intel = "1"
23
24RDEPENDS_va-intel = " \
25 ${VA_IMPL} \
26 "
27
28COMPATIBLE_HOST = '(i.86|x86_64).*-linux*'
29
30inherit distro_features_check
31
32REQUIRED_DISTRO_FEATURES = "opengl"