summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
authorPriyalee Kushwaha <priyalee.kushwaha@intel.com>2017-06-29 12:25:02 -0700
committerSaul Wold <sgw@linux.intel.com>2017-07-31 09:00:57 -0700
commit1811a41d6f891784b2a5b65d60626add51f3d13e (patch)
tree2109ab19c7d7681309312ca0f9fa4fb3d18eb3e0 /common/recipes-kernel
parentf8500c5020c831c421d87497b67a4cefb84c6bff (diff)
downloadmeta-intel-1811a41d6f891784b2a5b65d60626add51f3d13e.tar.gz
iwlwifi: include iwlwifi OOT driver in meta-intel layer.
iwlwifi driver is built as OOT driver and replaces driver built in kernel. Signed-off-by: Kushwaha, Priyalee <priyalee.kushwaha@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/iwlwifi/iwlwifi/iwlwifi.conf12
-rw-r--r--common/recipes-kernel/iwlwifi/iwlwifi_git.bb73
2 files changed, 85 insertions, 0 deletions
diff --git a/common/recipes-kernel/iwlwifi/iwlwifi/iwlwifi.conf b/common/recipes-kernel/iwlwifi/iwlwifi/iwlwifi.conf
new file mode 100644
index 00000000..a0e5f6ff
--- /dev/null
+++ b/common/recipes-kernel/iwlwifi/iwlwifi/iwlwifi.conf
@@ -0,0 +1,12 @@
1# /etc/modprobe.d/iwlwifi.conf
2# iwlwifi will dynamically load either iwldvm or iwlmvm depending on the
3# microcode file installed on the system. When removing iwlwifi, first
4# remove the iwl?vm module and then iwlwifi.
5remove iwlwifi (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm16 -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) && /sbin/modprobe -r mac80211
6
7#options iwlwifi lar_disable=1
8#options iwlwifi nvm_file="nvm-sfp-b2-open.bin"
9options iwlmvm power_scheme=1
10
11# PCI BUS
12
diff --git a/common/recipes-kernel/iwlwifi/iwlwifi_git.bb b/common/recipes-kernel/iwlwifi/iwlwifi_git.bb
new file mode 100644
index 00000000..2999af02
--- /dev/null
+++ b/common/recipes-kernel/iwlwifi/iwlwifi_git.bb
@@ -0,0 +1,73 @@
1SUMMARY = "Intel Wireless LinuxCore 24 kernel driver"
2DESCRIPTION = "Intel Wireless LinuxCore 24 kernel driver"
3SECTION = "kernel"
4LICENSE = "GPLv2"
5
6REQUIRED_DISTRO_FEATURES = "wifi"
7
8LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
9
10inherit module
11
12PROVIDES = "kernel-module-cfg80211-${KERNEL_VERSION} \
13 kernel-module-mac80211-${KERNEL_VERSION} \
14 kernel-module-iwlmvm-${KERNEL_VERSION} \
15 kernel-module-iwlwifi-${KERNEL_VERSION} \
16 kernel-module-compat-${KERNEL_VERSION}"
17
18RPROVIDES_${PN} = "kernel-module-cfg80211-${KERNEL_VERSION} \
19 kernel-module-mac80211-${KERNEL_VERSION} \
20 kernel-module-iwlmvm-${KERNEL_VERSION} \
21 kernel-module-iwlwifi-${KERNEL_VERSION} \
22 kernel-module-compat-${KERNEL_VERSION}"
23
24PV = "30"
25SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi;branch=release/LinuxCore${PV}"
26SRC_URI += "file://iwlwifi.conf"
27
28SRCREV = "${AUTOREV}"
29
30S = "${WORKDIR}/git"
31
32SYSTEMD_AUTO_ENABLE_${PN} = "enable"
33
34CONFFILES_${PN} += "${sysconfdir}/modprobe.d/iwlwifi.conf"
35
36PACKAGES = "${PN}"
37
38RDEPENDS_${PN}="linux-firmware-iwlwifi-8000c"
39
40DEPENDS="virtual/kernel"
41KERNVER="${KERNEL_VERSION}"
42
43## modules actual
44FILES_${PN} = "/lib/modules/${KERNVER}/updates/cfg80211.ko \
45 /lib/modules/${KERNVER}/updates/compat.ko \
46 /lib/modules/${KERNVER}/updates/iwlwifi.ko \
47 /lib/modules/${KERNVER}/updates/iwlmvm.ko \
48 /lib/modules/${KERNVER}/updates/mac80211.ko \
49 ${sysconfdir}/modprobe.d/iwlwifi.conf"
50
51EXTRA_OEMAKE = "INSTALL_MOD_PATH=${D} KLIB_BUILD=${KBUILD_OUTPUT}"
52
53do_configure() {
54 CC=gcc CFLAGS= LDFLAGS= make defconfig-iwlwifi-public KLIB_BUILD=${KBUILD_OUTPUT}
55}
56
57do_install() {
58 ## install kernel objects from driver tree into target fs
59 install -m 0755 -d ${D}${base_libdir}/modules/${KERNVER}/updates/
60
61 install -m 0644 $(find ${S} -name "iwlwifi.ko") ${D}${base_libdir}/modules/${KERNVER}/updates
62 install -m 0644 $(find ${S} -name "iwlmvm.ko") ${D}${base_libdir}/modules/${KERNVER}/updates
63 install -m 0644 $(find ${S} -name "cfg80211.ko") ${D}${base_libdir}/modules/${KERNVER}/updates
64 install -m 0644 $(find ${S} -name "mac80211.ko") ${D}${base_libdir}/modules/${KERNVER}/updates
65 install -m 0644 $(find ${S} -name "compat.ko") ${D}${base_libdir}/modules/${KERNVER}/updates
66
67 ## install configs and service scripts
68 install -d ${D}${sbindir} ${D}${sysconfdir}/modprobe.d
69 install -m 0644 ${WORKDIR}/iwlwifi.conf ${D}${sysconfdir}/modprobe.d
70
71 ## this gets generated for no good reason. delete it.
72 rm -rf ${D}/usr
73}