summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux
diff options
context:
space:
mode:
authorGeorge Nita <george.nita@enea.com>2014-04-05 05:25:43 +0200
committerGeorge Nita <george.nita@enea.com>2014-04-05 05:25:43 +0200
commitfa96c2ca5e4f882adadcb3b90e09bc0abf2f76fc (patch)
tree1a22b4521591d980819dcd0d90b7964f8d6b1a32 /common/recipes-kernel/linux
parent6ef83e1cb65080174a888faef3a0791158f10ee4 (diff)
parentb26946e8e7f1f3bb68625731b493156309449f5d (diff)
downloadmeta-intel-fa96c2ca5e4f882adadcb3b90e09bc0abf2f76fc.tar.gz
Merge remote-tracking branch 'origin/master' into master-enea
Diffstat (limited to 'common/recipes-kernel/linux')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-dev.bbappend4
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend4
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.10.bbappend16
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.14.bbappend26
4 files changed, 38 insertions, 12 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
index 45b6873a..4fe4088b 100644
--- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -14,6 +14,6 @@ LINUX_VERSION_corei7-64-intel-common = "3.14-rc8"
14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
15SRCREV_meta_corei7-64-intel-common = "3689f99f4d2a051e8d3ff72345a67d4d04a88020" 15SRCREV_meta_corei7-64-intel-common = "3689f99f4d2a051e8d3ff72345a67d4d04a88020"
16SRCREV_machine_corei7-64-intel-common = "fecc3fd7d31bd93766ff4f0431fecdbbfa4c3a7c" 16SRCREV_machine_corei7-64-intel-common = "fecc3fd7d31bd93766ff4f0431fecdbbfa4c3a7c"
17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" 17KMACHINE_corei7-64-intel-common = "intel-corei7-64"
18KBRANCH_intel-corei7-64-intel-common = "standard/base" 18KBRANCH_corei7-64-intel-common = "standard/base"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
index cfb41930..f4712ef8 100644
--- a/common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
@@ -14,6 +14,6 @@ KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
15#SRCREV_meta_corei7-64-intel-common = "${AUTOREV}" 15#SRCREV_meta_corei7-64-intel-common = "${AUTOREV}"
16#SRCREV_machine_corei7-64-intel-common = "${AUTOREV}" 16#SRCREV_machine_corei7-64-intel-common = "${AUTOREV}"
17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" 17KMACHINE_corei7-64-intel-common = "intel-corei7-64"
18KBRANCH_intel-corei7-64-intel-common = "standard/preempt-rt/base" 18KBRANCH_corei7-64-intel-common = "standard/preempt-rt/base"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 902f987e..1ab0a356 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -2,18 +2,18 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON = "" 3KERNEL_FEATURES_INTEL_COMMON = ""
4 4
5LINUX_VERSION_core2-32-intel-common = "3.10.34" 5LINUX_VERSION_core2-32-intel-common = "3.10.35"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7SRCREV_meta_core2-32-intel-common = "df3aa753c8826127fb5ad811d56d57168551d6e4" 7SRCREV_meta_core2-32-intel-common = "b6e58b33dd427fe471f8827c83e311acdf4558a4"
8SRCREV_machine_core2-32-intel-common = "c7739be126930006e3bfbdb2fb070a967abc5e09" 8SRCREV_machine_core2-32-intel-common = "cee957655fe67826b2e827e2db41f156fa8f0cc4"
9KMACHINE_core2-32-intel-common = "intel-core2-32" 9KMACHINE_core2-32-intel-common = "intel-core2-32"
10KBRANCH_core2-32-intel-common = "standard/base" 10KBRANCH_core2-32-intel-common = "standard/base"
11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
12 12
13LINUX_VERSION_corei7-64-intel-common = "3.10.34" 13LINUX_VERSION_corei7-64-intel-common = "3.10.35"
14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
15SRCREV_meta_corei7-64-intel-common = "df3aa753c8826127fb5ad811d56d57168551d6e4" 15SRCREV_meta_corei7-64-intel-common = "b6e58b33dd427fe471f8827c83e311acdf4558a4"
16SRCREV_machine_corei7-64-intel-common = "c7739be126930006e3bfbdb2fb070a967abc5e09" 16SRCREV_machine_corei7-64-intel-common = "cee957655fe67826b2e827e2db41f156fa8f0cc4"
17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" 17KMACHINE_corei7-64-intel-common = "intel-corei7-64"
18KBRANCH_intel-corei7-64-intel-common = "standard/base" 18KBRANCH_corei7-64-intel-common = "standard/base"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
new file mode 100644
index 00000000..9c1dd6af
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -0,0 +1,26 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3# For NUC
4KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
5
6LINUX_VERSION_core2-32-intel-common = "3.14.0"
7COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
8SRCREV_meta_core2-32-intel-common = "fc8c30398dbc3cdea787a1042242d4aab689d0ae"
9SRCREV_machine_core2-32-intel-common = "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
10KMACHINE_core2-32-intel-common = "intel-core2-32"
11KBRANCH_core2-32-intel-common = "standard/base"
12KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
13
14LINUX_VERSION_corei7-64-intel-common = "3.14.0"
15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
16SRCREV_meta_corei7-64-intel-common = "fc8c30398dbc3cdea787a1042242d4aab689d0ae"
17SRCREV_machine_corei7-64-intel-common = "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
18KMACHINE_corei7-64-intel-common = "intel-corei7-64"
19KBRANCH_corei7-64-intel-common = "standard/base"
20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
21
22# For Crystalforest and Romley
23module_autoload_uio = "uio"
24
25# For FRI2, NUC
26module_autoload_iwlwifi = "iwlwifi"