diff options
author | Nitin A Kamble <nitin.a.kamble@intel.com> | 2014-04-01 21:59:56 (GMT) |
---|---|---|
committer | Tom Zanussi <tom.zanussi@intel.com> | 2014-04-04 13:57:49 (GMT) |
commit | 46ac8a922c7165813c91b64ec0588d30b0887e2e (patch) | |
tree | 175b13fefccd9012faef3d477a79ae96d83bb07e /common/recipes-kernel/linux/linux-yocto_3.14.bbappend | |
parent | 2b717f47ba15c4baadc173522897c20752ed7a51 (diff) | |
download | meta-intel-46ac8a922c7165813c91b64ec0588d30b0887e2e.tar.gz |
linux-yocto_3.14: common recipe for meta-intel BSPs
Extend the linux-yocto_3.14 recipe from poky layer to meta-intel layer.
This kernel recipe is shared by multiple BSPs from the meta-intel layer.
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'common/recipes-kernel/linux/linux-yocto_3.14.bbappend')
-rw-r--r-- | common/recipes-kernel/linux/linux-yocto_3.14.bbappend | 26 |
1 files changed, 26 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend new file mode 100644 index 0000000..0add080 --- /dev/null +++ b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend | |||
@@ -0,0 +1,26 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | # For NUC | ||
4 | KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" | ||
5 | |||
6 | LINUX_VERSION_core2-32-intel-common = "3.14.0" | ||
7 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | ||
8 | SRCREV_meta_core2-32-intel-common = "fc8c30398dbc3cdea787a1042242d4aab689d0ae" | ||
9 | SRCREV_machine_core2-32-intel-common = "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0" | ||
10 | KMACHINE_core2-32-intel-common = "intel-core2-32" | ||
11 | KBRANCH_core2-32-intel-common = "standard/base" | ||
12 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
13 | |||
14 | LINUX_VERSION_corei7-64-intel-common = "3.14.0" | ||
15 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | ||
16 | SRCREV_meta_corei7-64-intel-common = "fc8c30398dbc3cdea787a1042242d4aab689d0ae" | ||
17 | SRCREV_machine_corei7-64-intel-common = "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0" | ||
18 | KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" | ||
19 | KBRANCH_intel-corei7-64-intel-common = "standard/base" | ||
20 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
21 | |||
22 | # For Crystalforest and Romley | ||
23 | module_autoload_uio = "uio" | ||
24 | |||
25 | # For FRI2, NUC | ||
26 | module_autoload_iwlwifi = "iwlwifi" | ||