summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-intel_4.9.bb
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2017-05-10 14:59:04 -0700
committerSaul Wold <sgw@linux.intel.com>2017-05-11 09:17:11 +0800
commitf8e08ecdab7c16352fe2d1d1e12557be213889b1 (patch)
treeb8d1d226dc551e6b949e4dd7de55a22955b604c7 /common/recipes-kernel/linux/linux-intel_4.9.bb
parent4b83cea79a662d8061211b0db6d465cd474a974a (diff)
downloadmeta-intel-f8e08ecdab7c16352fe2d1d1e12557be213889b1.tar.gz
recipes-kernel/linux/*: Standardize use of KERNEL_FEATURES_INTEL_COMMON
Previously, some recipes hard set it to empty, and some recipes did not set it at all. So in some cases, it acted like a global variable you could modify, and in others you could only append to it. This behavior made it difficult to use (which I doubt anyone was doing). This patch changes the variable to be soft set to empty across all recipes. This way it can be used to globally change meta-intel kernels through a conf file, or individually in the different versioned recipes should the need arise. Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel/linux/linux-intel_4.9.bb')
-rw-r--r--common/recipes-kernel/linux/linux-intel_4.9.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/common/recipes-kernel/linux/linux-intel_4.9.bb b/common/recipes-kernel/linux/linux-intel_4.9.bb
index aebbedf1..46db6632 100644
--- a/common/recipes-kernel/linux/linux-intel_4.9.bb
+++ b/common/recipes-kernel/linux/linux-intel_4.9.bb
@@ -11,13 +11,12 @@ SRC_URI = "git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machin
11LINUX_VERSION ?= "4.9.20" 11LINUX_VERSION ?= "4.9.20"
12LINUX_VERSION_EXTENSION = "-intel-pk-${LINUX_KERNEL_TYPE}" 12LINUX_VERSION_EXTENSION = "-intel-pk-${LINUX_KERNEL_TYPE}"
13 13
14
15PV = "${LINUX_VERSION}+git${SRCPV}" 14PV = "${LINUX_VERSION}+git${SRCPV}"
16 15
17KMETA = "kernel-meta" 16KMETA = "kernel-meta"
18KCONF_BSP_AUDIT_LEVEL = "2" 17KCONF_BSP_AUDIT_LEVEL = "2"
19 18
20KERNEL_FEATURES_INTEL_COMMON = "" 19KERNEL_FEATURES_INTEL_COMMON ?= ""
21 20
22COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 21COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
23KMACHINE_core2-32-intel-common = "intel-core2-32" 22KMACHINE_core2-32-intel-common = "intel-core2-32"