summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-intel_4.9.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-07-25 13:52:47 -0700
committerSaul Wold <sgw@linux.intel.com>2017-07-31 09:00:58 -0700
commitd0ba6fc045dffda5aa1e6e015b926615febfbf9f (patch)
treeea566a26f5381fe426d9db452db6cc74134e85e2 /common/recipes-kernel/linux/linux-intel_4.9.bb
parent3dfbb5cd08acf4300a4336177e0a8f511a460b01 (diff)
downloadmeta-intel-d0ba6fc045dffda5aa1e6e015b926615febfbf9f.tar.gz
linux-intel: refactor and remove iwlwifi modules for out of tree enablement
Create a linux-intel.inc that is shared between standard and rt kernel for the common bits. By removing these modules here, we can then build and install the out of tree modules from the backport-iwlwifi tree. Move the Autoloading to the kernel module also Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel/linux/linux-intel_4.9.bb')
-rw-r--r--common/recipes-kernel/linux/linux-intel_4.9.bb33
1 files changed, 1 insertions, 32 deletions
diff --git a/common/recipes-kernel/linux/linux-intel_4.9.bb b/common/recipes-kernel/linux/linux-intel_4.9.bb
index 51506555..9e017aaa 100644
--- a/common/recipes-kernel/linux/linux-intel_4.9.bb
+++ b/common/recipes-kernel/linux/linux-intel_4.9.bb
@@ -1,44 +1,13 @@
1 1
2require recipes-kernel/linux/linux-yocto.inc 2require linux-intel.inc
3 3
4KBRANCH = "base" 4KBRANCH = "base"
5SRCREV_machine ?= "22a3e397584619839ec645c7378dc40bdd5ad2d1" 5SRCREV_machine ?= "22a3e397584619839ec645c7378dc40bdd5ad2d1"
6SRCREV_meta ?= "299f12a06ca1d6fd90b24450dae3b9f257a536be" 6SRCREV_meta ?= "299f12a06ca1d6fd90b24450dae3b9f257a536be"
7 7
8SRC_URI = "git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \
9 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"
10
11LINUX_VERSION ?= "4.9.30"
12LINUX_VERSION_EXTENSION = "-intel-pk-${LINUX_KERNEL_TYPE}"
13
14PV = "${LINUX_VERSION}+git${SRCPV}"
15
16KMETA = "kernel-meta"
17KCONF_BSP_AUDIT_LEVEL = "2"
18
19KERNEL_FEATURES_INTEL_COMMON ?= ""
20
21COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
22KMACHINE_core2-32-intel-common = "intel-core2-32"
23KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
24
25COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
26KMACHINE_corei7-64-intel-common = "intel-corei7-64"
27KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
28
29COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
30KMACHINE_i586-nlp-32-intel-common = "intel-quark"
31KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
32
33# For Crystalforest and Romley 8# For Crystalforest and Romley
34KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 9KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
35KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" 10KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
36 11
37# For FRI2, NUC
38KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
39KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
40
41# Functionality flags 12# Functionality flags
42KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc" 13KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
43KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
44KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"