summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-07-25 13:52:47 -0700
committerSaul Wold <sgw@linux.intel.com>2017-07-31 09:00:58 -0700
commitd0ba6fc045dffda5aa1e6e015b926615febfbf9f (patch)
treeea566a26f5381fe426d9db452db6cc74134e85e2 /common/recipes-kernel/linux/linux-intel-rt_4.9.bb
parent3dfbb5cd08acf4300a4336177e0a8f511a460b01 (diff)
downloadmeta-intel-d0ba6fc045dffda5aa1e6e015b926615febfbf9f.tar.gz
linux-intel: refactor and remove iwlwifi modules for out of tree enablement
Create a linux-intel.inc that is shared between standard and rt kernel for the common bits. By removing these modules here, we can then build and install the out of tree modules from the backport-iwlwifi tree. Move the Autoloading to the kernel module also Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel/linux/linux-intel-rt_4.9.bb')
-rw-r--r--common/recipes-kernel/linux/linux-intel-rt_4.9.bb27
1 files changed, 1 insertions, 26 deletions
diff --git a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
index 55015941..f34c6f54 100644
--- a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
+++ b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
@@ -1,5 +1,5 @@
1 1
2require recipes-kernel/linux/linux-yocto.inc 2require linux-intel.inc
3 3
4# Skip processing of this recipe if it is not explicitly specified as the 4# Skip processing of this recipe if it is not explicitly specified as the
5# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying 5# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
@@ -14,29 +14,4 @@ KBRANCH = "base-rt"
14SRCREV_machine ?= "cd65d037683c92be2c7dedc846f4bfd9ef84ecf4" 14SRCREV_machine ?= "cd65d037683c92be2c7dedc846f4bfd9ef84ecf4"
15SRCREV_meta ?= "299f12a06ca1d6fd90b24450dae3b9f257a536be" 15SRCREV_meta ?= "299f12a06ca1d6fd90b24450dae3b9f257a536be"
16 16
17SRC_URI = "git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"
19
20LINUX_VERSION ?= "4.9.30"
21LINUX_VERSION_EXTENSION ?= "-intel-pk-${LINUX_KERNEL_TYPE}"
22
23
24PV = "${LINUX_VERSION}+git${SRCPV}"
25
26KMETA = "kernel-meta"
27KCONF_BSP_AUDIT_LEVEL = "2"
28
29LINUX_KERNEL_TYPE = "preempt-rt" 17LINUX_KERNEL_TYPE = "preempt-rt"
30KERNEL_FEATURES_INTEL_COMMON ?= ""
31
32COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
33KMACHINE_core2-32-intel-common = "intel-core2-32"
34KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
35
36COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
37KMACHINE_corei7-64-intel-common = "intel-corei7-64"
38KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
39
40COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
41KMACHINE_i586-nlp-32-intel-common = "intel-quark"
42KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""