summaryrefslogtreecommitdiffstats
path: root/common/recipes-extended
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2017-06-28 10:27:22 -0700
committerSaul Wold <sgw@linux.intel.com>2017-06-29 14:22:17 -0700
commitd7cc11cba135ed5d9db82987744fefc137a8c8d4 (patch)
treef2e01c2ad3a0ea2e69e26e6911ab6f1279881178 /common/recipes-extended
parentcebe15d153ab982f80f3f86fea38a0978dfc1f28 (diff)
downloadmeta-intel-d7cc11cba135ed5d9db82987744fefc137a8c8d4.tar.gz
dpdk-dev-libibverbs: suppress gcc7 warnings
Ignore -Wformat-truncation in init.c. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-extended')
-rw-r--r--common/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb4
-rw-r--r--common/recipes-extended/dpdk-dev-libibverbs/files/init_c.patch23
2 files changed, 26 insertions, 1 deletions
diff --git a/common/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb b/common/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb
index 32363bbc..5636d8fa 100644
--- a/common/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb
+++ b/common/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb
@@ -3,7 +3,9 @@ HOMEPAGE = "https://github.com/Mellanox/dpdk-dev-libibverbs"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=7c557f27dd795ba77cc419dddc656b51" 4LIC_FILES_CHKSUM = "file://COPYING;md5=7c557f27dd795ba77cc419dddc656b51"
5 5
6SRC_URI = "https://github.com/Mellanox/dpdk-dev-libibverbs/archive/libibverbs-${PV}.tar.gz;name=${PN}" 6SRC_URI = "https://github.com/Mellanox/dpdk-dev-libibverbs/archive/libibverbs-${PV}.tar.gz;name=${PN} \
7 file://init_c.patch \
8 "
7 9
8SRC_URI[dpdk-dev-libibverbs.md5sum] = "65234ee278eb437a7069326f37cd4d86" 10SRC_URI[dpdk-dev-libibverbs.md5sum] = "65234ee278eb437a7069326f37cd4d86"
9SRC_URI[dpdk-dev-libibverbs.sha256sum] = "a6471515556cb8d10ad471bb7efb8cf760b248a28aceb57d4534d50d572f56cd" 11SRC_URI[dpdk-dev-libibverbs.sha256sum] = "a6471515556cb8d10ad471bb7efb8cf760b248a28aceb57d4534d50d572f56cd"
diff --git a/common/recipes-extended/dpdk-dev-libibverbs/files/init_c.patch b/common/recipes-extended/dpdk-dev-libibverbs/files/init_c.patch
new file mode 100644
index 00000000..a7708d7c
--- /dev/null
+++ b/common/recipes-extended/dpdk-dev-libibverbs/files/init_c.patch
@@ -0,0 +1,23 @@
1dpdk-dev-libibverbs: suppress gcc7 warnings
2
3We know that format-truncation in init.c is okay.
4
5Upstream-Status: Pending
6
7Signed-off-by: Joe Slater <joe.slater@windriver.com>
8
9
10--- a/src/init.c
11+++ b/src/init.c
12@@ -31,6 +31,11 @@
13 * SOFTWARE.
14 */
15
16+/* For this file we know we can ignore this warning. */
17+#if __GNUC__ > 6
18+#pragma GCC diagnostic ignored "-Wformat-truncation"
19+#endif
20+
21 #if HAVE_CONFIG_H
22 # include <config.h>
23 #endif /* HAVE_CONFIG_H */