summaryrefslogtreecommitdiffstats
path: root/common/recipes-extended/dpdk/dpdk
diff options
context:
space:
mode:
authorRahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>2016-11-16 16:02:40 +0800
committerSaul Wold <sgw@linux.intel.com>2016-11-28 12:45:06 -0800
commit5b74ee0138a28551292dc30c631344453e07c2cf (patch)
treebecdf07768a713febadef33e52c0c9181a4ea17d /common/recipes-extended/dpdk/dpdk
parentf8d24485e8fd8fb3671bb1f8b41a115a6316817a (diff)
downloadmeta-intel-5b74ee0138a28551292dc30c631344453e07c2cf.tar.gz
dpdk: Update v16.07 -> v16.11
Updated the DPDK recipe from v16.07 to v16.11. for dpdk v16.11 the rte_ivshmem feature has dropped and the default configuration file for packet_ordering example is replaced with the "native" x86 file. Rename and modified the patch: dpdk-16.11-dpdk-fix-installation-warning-and-issue.patch accordingly since this doesn't apply cleanly on top of dpdk v16.11 Removed the patches: dpdk-16.07-net-ixgbe-move-PCI-device-IDs-from-EAL.patch dpdk-16.07-net-igb-move-PCI-device-IDs-from-EAL.patch dpdk-16.07-kni-fix-build-with-kernel-4.8.patch from dpdk.inc since these changes/fix are now added in dpdk v16.11. Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-extended/dpdk/dpdk')
-rw-r--r--common/recipes-extended/dpdk/dpdk/dpdk-16.11-dpdk-fix-installation-warning-and-issue.patch (renamed from common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-installation-warning-and-issue.patch)18
1 files changed, 9 insertions, 9 deletions
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-installation-warning-and-issue.patch b/common/recipes-extended/dpdk/dpdk/dpdk-16.11-dpdk-fix-installation-warning-and-issue.patch
index 9fc30381..f1f625d8 100644
--- a/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-installation-warning-and-issue.patch
+++ b/common/recipes-extended/dpdk/dpdk/dpdk-16.11-dpdk-fix-installation-warning-and-issue.patch
@@ -1,6 +1,6 @@
1From 7af593cfca897a0f17d33aba95dd3e3d22a65444 Mon Sep 17 00:00:00 2001 1From 1dcd79d49b3ad987d6313a857a74fc9efbcd2667 Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Fri, 19 Aug 2016 11:50:46 +0800 3Date: Mon, 14 Nov 2016 10:35:51 +0800
4Subject: [PATCH] dpdk: fix installation warning and issue 4Subject: [PATCH] dpdk: fix installation warning and issue
5 5
6Upstream-Status: Inappropriate [configuration] 6Upstream-Status: Inappropriate [configuration]
@@ -17,10 +17,10 @@ Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
17 1 file changed, 10 insertions(+), 15 deletions(-) 17 1 file changed, 10 insertions(+), 15 deletions(-)
18 18
19diff --git a/mk/rte.sdkinstall.mk b/mk/rte.sdkinstall.mk 19diff --git a/mk/rte.sdkinstall.mk b/mk/rte.sdkinstall.mk
20index 5217063..7036a32 100644 20index 7b0d8b5..d27125c 100644
21--- a/mk/rte.sdkinstall.mk 21--- a/mk/rte.sdkinstall.mk
22+++ b/mk/rte.sdkinstall.mk 22+++ b/mk/rte.sdkinstall.mk
23@@ -114,16 +114,13 @@ endif 23@@ -115,16 +115,13 @@ endif
24 24
25 install-runtime: 25 install-runtime:
26 $(Q)$(call rte_mkdir, $(DESTDIR)$(libdir)) 26 $(Q)$(call rte_mkdir, $(DESTDIR)$(libdir))
@@ -32,7 +32,7 @@ index 5217063..7036a32 100644
32- --exclude 'app/cmdline*' --exclude app/test \ 32- --exclude 'app/cmdline*' --exclude app/test \
33- --exclude app/testacl --exclude app/testpipeline app | \ 33- --exclude app/testacl --exclude app/testpipeline app | \
34- tar -xf - -C $(DESTDIR)$(bindir) --strip-components=1 \ 34- tar -xf - -C $(DESTDIR)$(bindir) --strip-components=1 \
35- --keep-newer-files --warning=no-ignore-newer 35- --keep-newer-files
36+ $(Q)tar -cf - -C $O --exclude app/dpdk-pmdinfogen app | \ 36+ $(Q)tar -cf - -C $O --exclude app/dpdk-pmdinfogen app | \
37+ tar -xf - -C $(DESTDIR)$(bindir) --no-same-owner --no-same-permissions \ 37+ tar -xf - -C $(DESTDIR)$(bindir) --no-same-owner --no-same-permissions \
38+ --strip-components=1 --keep-newer-files --warning=no-ignore-newer 38+ --strip-components=1 --keep-newer-files --warning=no-ignore-newer
@@ -42,7 +42,7 @@ index 5217063..7036a32 100644
42 $(Q)$(call rte_symlink, $(DESTDIR)$(datadir)/tools/dpdk-setup.sh, \ 42 $(Q)$(call rte_symlink, $(DESTDIR)$(datadir)/tools/dpdk-setup.sh, \
43 $(DESTDIR)$(datadir)/tools/setup.sh) 43 $(DESTDIR)$(datadir)/tools/setup.sh)
44 $(Q)$(call rte_symlink, $(DESTDIR)$(datadir)/tools/dpdk-devbind.py, \ 44 $(Q)$(call rte_symlink, $(DESTDIR)$(datadir)/tools/dpdk-devbind.py, \
45@@ -137,7 +134,7 @@ install-runtime: 45@@ -146,7 +143,7 @@ endif
46 install-kmod: 46 install-kmod:
47 ifneq ($(wildcard $O/kmod/*),) 47 ifneq ($(wildcard $O/kmod/*),)
48 $(Q)$(call rte_mkdir, $(DESTDIR)$(kerneldir)) 48 $(Q)$(call rte_mkdir, $(DESTDIR)$(kerneldir))
@@ -51,9 +51,9 @@ index 5217063..7036a32 100644
51 endif 51 endif
52 52
53 install-sdk: 53 install-sdk:
54@@ -146,11 +143,9 @@ install-sdk: 54@@ -155,11 +152,9 @@ install-sdk:
55 tar -xf - -C $(DESTDIR)$(includedir) --strip-components=1 \ 55 tar -xf - -C $(DESTDIR)$(includedir) --strip-components=1 \
56 --keep-newer-files --warning=no-ignore-newer 56 --keep-newer-files
57 $(Q)$(call rte_mkdir, $(DESTDIR)$(sdkdir)) 57 $(Q)$(call rte_mkdir, $(DESTDIR)$(sdkdir))
58- $(Q)cp -a $(RTE_SDK)/mk $(DESTDIR)$(sdkdir) 58- $(Q)cp -a $(RTE_SDK)/mk $(DESTDIR)$(sdkdir)
59- $(Q)cp -a $(RTE_SDK)/scripts $(DESTDIR)$(sdkdir) 59- $(Q)cp -a $(RTE_SDK)/scripts $(DESTDIR)$(sdkdir)
@@ -66,7 +66,7 @@ index 5217063..7036a32 100644
66 $(Q)$(call rte_symlink, $(DESTDIR)$(includedir), $(DESTDIR)$(targetdir)/include) 66 $(Q)$(call rte_symlink, $(DESTDIR)$(includedir), $(DESTDIR)$(targetdir)/include)
67 $(Q)$(call rte_symlink, $(DESTDIR)$(libdir), $(DESTDIR)$(targetdir)/lib) 67 $(Q)$(call rte_symlink, $(DESTDIR)$(libdir), $(DESTDIR)$(targetdir)/lib)
68 68
69@@ -166,4 +161,4 @@ ifneq ($(wildcard $O/doc/*/*/*pdf),) 69@@ -175,4 +170,4 @@ ifneq ($(wildcard $O/doc/*/*/*pdf),)
70 $(Q)cp -a $O/doc/*/*/*pdf $(DESTDIR)$(docdir)/guides 70 $(Q)cp -a $O/doc/*/*/*pdf $(DESTDIR)$(docdir)/guides
71 endif 71 endif
72 $(Q)$(call rte_mkdir, $(DESTDIR)$(datadir)) 72 $(Q)$(call rte_mkdir, $(DESTDIR)$(datadir))