summaryrefslogtreecommitdiffstats
path: root/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2017-09-25 12:38:20 -0500
committerSaul Wold <sgw@linux.intel.com>2017-09-25 15:53:57 -0700
commita20d06d7e4b07c8ba12364a5262eeab8455235af (patch)
tree6e44e0b398476a5bf1662426864d9400c3ba7ca2 /common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
parent9bf043497c48c45c425081989d142c68968a1385 (diff)
downloadmeta-intel-a20d06d7e4b07c8ba12364a5262eeab8455235af.tar.gz
Move dpdk and qat components to meta-dpdk and meta-qat
meta-dpdk / meta-qat: * Move content from meta-intel/common * Create new basic README/LICENSE files from meta-intel * Create new layer.conf files * Fill out the maintainers files meta-intel: * update the maintainers files * bump the meta-intel layer version * add layer recommend No other content changes made in this commit. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch')
-rw-r--r--common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch42
1 files changed, 0 insertions, 42 deletions
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch b/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
deleted file mode 100644
index fc965fa4..00000000
--- a/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From 4cdcb5ea4af9677677a007c4f9b286948123be87 Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Fri, 2 Sep 2016 15:48:52 +0800
4Subject: [PATCH] dpdk: fix for parellel make issue
5
6To make sure that the path of libraries should be correct and
7libraries will be build before, And available at the time of
8linking example apps.
9
10Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
11---
12 examples/Makefile | 1 +
13 examples/ethtool/ethtool-app/Makefile | 1 +
14 2 files changed, 2 insertions(+)
15
16diff --git a/examples/Makefile b/examples/Makefile
17index 18b41b9..c7c2beb 100644
18--- a/examples/Makefile
19+++ b/examples/Makefile
20@@ -43,6 +43,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
21 DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond
22 DIRS-y += cmdline
23 DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
24+DEPDIRS-y += examples/ethtool/lib
25 DIRS-y += ethtool
26 DIRS-y += exception_path
27 DIRS-y += helloworld
28diff --git a/examples/ethtool/ethtool-app/Makefile b/examples/ethtool/ethtool-app/Makefile
29index 09c66ad..ec068e6 100644
30--- a/examples/ethtool/ethtool-app/Makefile
31+++ b/examples/ethtool/ethtool-app/Makefile
32@@ -47,6 +47,7 @@ SRCS-y := main.c ethapp.c
33 CFLAGS += -O3 -D_GNU_SOURCE -pthread -I$(SRCDIR)/../lib
34 CFLAGS += $(WERROR_FLAGS)
35
36+LDLIBS += -L$(ETHTOOL_LIB_PATH)/
37 LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib
38 LDLIBS += -lrte_ethtool
39
40--
411.9.1
42