summaryrefslogtreecommitdiffstats
path: root/common/recipes-extended/dpdk/dpdk/dpdk-1.7.0-examples-Add-config-variables-to-enable-disable-dpdk.patch
diff options
context:
space:
mode:
authorSreeju Selvaraj <sreeju.armughanx.selvaraj@intel.com>2014-09-29 18:39:33 +0800
committerTom Zanussi <tom.zanussi@linux.intel.com>2014-10-01 22:55:45 -0500
commita14718dfaee57827a0666b858cf192dc1cb00db5 (patch)
tree606bf658f63a18e23dcb27f55adaa94162b93f38 /common/recipes-extended/dpdk/dpdk/dpdk-1.7.0-examples-Add-config-variables-to-enable-disable-dpdk.patch
parent1c825a06095178c0c51f28d5867549feac8a47f4 (diff)
downloadmeta-intel-a14718dfaee57827a0666b858cf192dc1cb00db5.tar.gz
meta-intel/common: Upgrade DPDK to v1.7.0
Added support for DPDK v1.7.0. Added PACKAGECONFIG mechanism to explicitly disable the use of fuse and qat which are dependencies for example apps dpdk_qat and vhost. Added config variables CONFIG_EXAMPLE_DPDK_QAT and CONFIG_EXAMPLE_DPDK_VHOST to enable or disable the compilation of example apps dpdk_qat and vhost. Resolved the installation failure found in example app ip_pipeline by cherry-picking the patch from dpdk.org. Resolved the test failure found in example app ring_pmd_autotest by cherry-picking the patches from dpdk.org. Signed-off-by: Sreeju Selvaraj <sreeju.armughanx.selvaraj@intel.com> Acked-by: Ong Boon Leong <boon.leong.ong@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common/recipes-extended/dpdk/dpdk/dpdk-1.7.0-examples-Add-config-variables-to-enable-disable-dpdk.patch')
-rw-r--r--common/recipes-extended/dpdk/dpdk/dpdk-1.7.0-examples-Add-config-variables-to-enable-disable-dpdk.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-1.7.0-examples-Add-config-variables-to-enable-disable-dpdk.patch b/common/recipes-extended/dpdk/dpdk/dpdk-1.7.0-examples-Add-config-variables-to-enable-disable-dpdk.patch
new file mode 100644
index 00000000..d0721ca0
--- /dev/null
+++ b/common/recipes-extended/dpdk/dpdk/dpdk-1.7.0-examples-Add-config-variables-to-enable-disable-dpdk.patch
@@ -0,0 +1,42 @@
1From 63f8ccc5a305b193e219d288ef9e43b9a9fa6aa8 Mon Sep 17 00:00:00 2001
2From: Sreeju Selvaraj <sreeju.armughanx.selvaraj@intel.com>
3Date: Wed, 17 Sep 2014 19:10:01 +0800
4Subject: [PATCH] examples: Add config variables to enable/disable dpdk_qat and
5 vhost
6
7Upstream-Status: Inappropriate [configuration]
8
9This can be used to export CONFIG_EXAMPLE_DPDK_QAT=n if dpdk_qat is not
10in PACKAGECONFIG and also allow to export CONFIG_EXAMPLE_DPDK_VHOST=n
11if vhost is not in PACKAGECONFIG.
12
13Signed-off-by: Sreeju Selvaraj <sreeju.armughanx.selvaraj@intel.com>
14---
15 examples/Makefile | 4 ++--
16 1 file changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/examples/Makefile b/examples/Makefile
19index d0624f6..885c938 100644
20--- a/examples/Makefile
21+++ b/examples/Makefile
22@@ -39,7 +39,7 @@ include $(RTE_SDK)/mk/rte.vars.mk
23
24 DIRS-y += cmdline
25 ifneq ($(ICP_ROOT),)
26-DIRS-y += dpdk_qat
27+DIRS-$(CONFIG_EXAMPLE_DPDK_QAT) += dpdk_qat
28 endif
29 DIRS-y += exception_path
30 DIRS-y += helloworld
31@@ -61,7 +61,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_METER) += qos_meter
32 DIRS-$(CONFIG_RTE_LIBRTE_SCHED) += qos_sched
33 DIRS-y += quota_watermark
34 DIRS-y += timer
35-DIRS-y += vhost
36+DIRS-$(CONFIG_EXAMPLE_DPDK_VHOST) += vhost
37 DIRS-$(CONFIG_RTE_LIBRTE_XEN_DOM0) += vhost_xen
38 DIRS-y += vmdq
39 DIRS-y += vmdq_dcb
40--
411.9.1
42