diff options
author | Kishore Bodke <kishore.k.bodke@intel.com> | 2012-11-30 20:15:07 (GMT) |
---|---|---|
committer | Tom Zanussi <tom.zanussi@intel.com> | 2012-12-03 15:14:55 (GMT) |
commit | 303b525328010310eefdcd90e0ad54d3e5fd1df7 (patch) | |
tree | e7c1af95a9065bbd36172e199b4e2d05de58287b /common/recipes-corpus | |
parent | aa8828005843ae0ab796b0c0e84ac0a3ddf8264a (diff) | |
download | meta-intel-303b525328010310eefdcd90e0ad54d3e5fd1df7.tar.gz |
meta-intel/common: Add Corpus recipes to common
Moved corpus recipes to common as this will be
used by multiple BSPs.
Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com>
Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-corpus')
-rw-r--r-- | common/recipes-corpus/calgary-corpus/calgary-corpus.bb | 25 | ||||
-rw-r--r-- | common/recipes-corpus/canterbury-corpus/canterbury-corpus.bb | 35 |
2 files changed, 60 insertions, 0 deletions
diff --git a/common/recipes-corpus/calgary-corpus/calgary-corpus.bb b/common/recipes-corpus/calgary-corpus/calgary-corpus.bb new file mode 100644 index 0000000..5d2c66d --- /dev/null +++ b/common/recipes-corpus/calgary-corpus/calgary-corpus.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | SUMMARY = "Set of files for testing losless compression algorithms" | ||
2 | DESCRIPTION = "Set of files for testing losless compression algorithms" | ||
3 | HOMEPAGE = "http://corpus.canterbury.ac.nz" | ||
4 | SECTION = "misc" | ||
5 | LICENSE = "GPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | ||
7 | |||
8 | S = "${WORKDIR}/corpus" | ||
9 | |||
10 | SRC_URI = "http://corpus.canterbury.ac.nz/resources/calgary.tar.gz" | ||
11 | |||
12 | SRC_URI[md5sum] = "651d06b35d3d39522157cf8dc4a3d01c" | ||
13 | SRC_URI[sha256sum] = "e109eebdc19c5cee533c58bd6a49a4be3a77cc52f84ba234a089148a4f2093b7" | ||
14 | |||
15 | do_unpack () { | ||
16 | mkdir -p ${S} | ||
17 | tar -xf ${DL_DIR}/calgary.tar.gz -C ${WORKDIR}/corpus | ||
18 | } | ||
19 | |||
20 | FILES_${PN} = "/lib/firmware/*" | ||
21 | |||
22 | do_install () { | ||
23 | install -d ${D}/lib/firmware | ||
24 | install -m 664 ${S}/* ${D}/lib/firmware | ||
25 | } | ||
diff --git a/common/recipes-corpus/canterbury-corpus/canterbury-corpus.bb b/common/recipes-corpus/canterbury-corpus/canterbury-corpus.bb new file mode 100644 index 0000000..eb5afad --- /dev/null +++ b/common/recipes-corpus/canterbury-corpus/canterbury-corpus.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | SUMMARY = "Intel Quick Assist Driver - Canterbury Corpus" | ||
2 | DESCRIPTION = "Set of files for testing losless compression algorithms \ | ||
3 | for Intel Crystal Forest BSP Quick Assist Technology Software Package" | ||
4 | |||
5 | HOMEPAGE = "http://corpus.canterbury.ac.nz" | ||
6 | SECTION = "misc" | ||
7 | LICENSE = "GPLv2" | ||
8 | |||
9 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | ||
10 | |||
11 | PR = "r0" | ||
12 | |||
13 | S = "${WORKDIR}/canterbury-corpus" | ||
14 | |||
15 | SRC_URI = "http://corpus.canterbury.ac.nz/resources/cantrbry.tar.gz" | ||
16 | |||
17 | SRC_URI[md5sum] = "442e56cfffdf460d25b0b91650a55908" | ||
18 | SRC_URI[sha256sum] = "f140e8a5b73d3f53198555a63bfb827889394a42f20825df33c810c3d5e3f8fb" | ||
19 | |||
20 | WARN_QA += "arch" | ||
21 | ERROR_QA = "" | ||
22 | |||
23 | do_package_qa[noexec] = "1" | ||
24 | |||
25 | do_unpack () { | ||
26 | mkdir -p ${S} | ||
27 | tar -xf ${DL_DIR}/cantrbry.tar.gz -C ${S} | ||
28 | } | ||
29 | |||
30 | FILES_${PN} = "/lib/firmware/*" | ||
31 | |||
32 | do_install () { | ||
33 | install -d ${D}${base_libdir}/firmware | ||
34 | install -m 644 ${S}/* ${D}${base_libdir}/firmware | ||
35 | } | ||