summaryrefslogtreecommitdiffstats
path: root/common/recipes-core/microcode/intel-microcode_20160714.bb
diff options
context:
space:
mode:
authorChristopher Clark <christopher.clark6@baesystems.com>2016-07-21 10:05:23 -0700
committerTom Zanussi <tom.zanussi@linux.intel.com>2016-07-22 09:18:05 -0500
commit1dffa00b4614ec8a5a8e538c01b260c633cde6be (patch)
tree65368ae4c850e77f3053797f381e00d353abb65d /common/recipes-core/microcode/intel-microcode_20160714.bb
parentc6adc3ef0712ae4260ac7f5f7ee4c8c34e137ce0 (diff)
downloadmeta-intel-1dffa00b4614ec8a5a8e538c01b260c633cde6be.tar.gz
intel-microcode: Update to the 20160714 version
Dates changed in Licence file required CHKSUM update From the OpenXT Project ( http://openxt.org ) refs: OXT-668 Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common/recipes-core/microcode/intel-microcode_20160714.bb')
-rw-r--r--common/recipes-core/microcode/intel-microcode_20160714.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/common/recipes-core/microcode/intel-microcode_20160714.bb b/common/recipes-core/microcode/intel-microcode_20160714.bb
new file mode 100644
index 00000000..e5047ea3
--- /dev/null
+++ b/common/recipes-core/microcode/intel-microcode_20160714.bb
@@ -0,0 +1,66 @@
1SUMMARY = "Intel Processor Microcode Datafile for Linux"
2HOMEPAGE = "http://www.intel.com/"
3DESCRIPTION = "The microcode data file contains the latest microcode\
4 definitions for all Intel processors. Intel releases microcode updates\
5 to correct processor behavior as documented in the respective processor\
6 specification updates. While the regular approach to getting this microcode\
7 update is via a BIOS upgrade, Intel realizes that this can be an\
8 administrative hassle. The Linux operating system and VMware ESX\
9 products have a mechanism to update the microcode after booting.\
10 For example, this file will be used by the operating system mechanism\
11 if the file is placed in the /etc/firmware directory of the Linux system."
12
13LICENSE = "Intel-Microcode-License"
14LIC_FILES_CHKSUM = "file://microcode.dat;md5=d8c57b35388b4b9f970f5377fcdfc486"
15
16SRC_URI = "http://downloadmirror.intel.com/26156/eng/microcode-${PV}.tgz"
17SRC_URI[md5sum] = "84e4c0530dc38fd7b804daf894b1bdf9"
18SRC_URI[sha256sum] = "f3a9c6fc93275bf1febc26f7c397ac93ed5f109e47fb52932f6dbd5cfdbc840e"
19
20DEPENDS = "iucode-tool-native"
21S = "${WORKDIR}"
22
23COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25
26inherit deploy
27
28# Use any of the iucode_tool parameters to filter specific microcodes from the data file
29# For further information, check the iucode-tool's manpage : http://manned.org/iucode-tool
30UCODE_FILTER_PARAMETERS ?= ""
31
32do_compile() {
33 mkdir -p ${WORKDIR}/ucode/kernel/x86/microcode
34 ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
35 ${UCODE_FILTER_PARAMETERS} \
36 --overwrite \
37 --write-to=${WORKDIR}/microcode_${PV}.bin \
38 ${WORKDIR}/microcode.dat
39
40 ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
41 ${UCODE_FILTER_PARAMETERS} \
42 --overwrite \
43 --write-earlyfw=${WORKDIR}/microcode_${PV}.cpio \
44 ${WORKDIR}/microcode.dat
45}
46
47do_install() {
48 install -d ${D}${base_libdir}/firmware/intel-ucode/
49 install ${WORKDIR}/microcode_${PV}.bin ${D}${base_libdir}/firmware/intel-ucode/
50 cd ${D}${base_libdir}/firmware/intel-ucode/
51 ln -sf microcode_${PV}.bin microcode.bin
52}
53
54do_deploy() {
55 install -d ${DEPLOYDIR}
56 install ${S}/microcode_${PV}.cpio ${DEPLOYDIR}/
57 cd ${DEPLOYDIR}
58 rm -f microcode.cpio
59 ln -sf microcode_${PV}.cpio microcode.cpio
60}
61
62addtask deploy before do_build after do_compile
63
64PACKAGES = "${PN}"
65
66FILES_${PN} = "${base_libdir}"