summaryrefslogtreecommitdiffstats
path: root/common/recipes-core/microcode/intel-microcode_20140624.bb
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2015-09-01 08:23:45 -0500
committerSaul Wold <sgw@linux.intel.com>2015-09-01 09:24:13 -0700
commit92705cccb52472f119172557e67c1fd1e39e0d01 (patch)
treee6ce7c0e5c3067ba7368d110359769eaf9767ce2 /common/recipes-core/microcode/intel-microcode_20140624.bb
parenta9c38306c91e7cfb0171bc4e3d594bc638d813da (diff)
downloadmeta-intel-92705cccb52472f119172557e67c1fd1e39e0d01.tar.gz
intel-microcode: bump version to 20150121
Bumped version to 20150121. Dropped runtime dependency on iucode-tool which is used to generate the cpio or trim down the data file based on your CPU. While it can also be used to load the microcode that is not the recommended method for Linux 3.9 and newer instead you should use the kernel's built-in early microcode loading facilities. Signed-off-by: Doug Goldstein <cardoe@cardoe.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-core/microcode/intel-microcode_20140624.bb')
-rw-r--r--common/recipes-core/microcode/intel-microcode_20140624.bb67
1 files changed, 0 insertions, 67 deletions
diff --git a/common/recipes-core/microcode/intel-microcode_20140624.bb b/common/recipes-core/microcode/intel-microcode_20140624.bb
deleted file mode 100644
index b2022500..00000000
--- a/common/recipes-core/microcode/intel-microcode_20140624.bb
+++ /dev/null
@@ -1,67 +0,0 @@
1SUMMARY = "Intel Processor Microcode Datafile for Linux"
2HOMEPAGE = "http://www.intel.com/"
3DESCRIPTION = "The microcode data file contains the latest microcode\
4 definitions for all Intel processors. Intel releases microcode updates\
5 to correct processor behavior as documented in the respective processor\
6 specification updates. While the regular approach to getting this microcode\
7 update is via a BIOS upgrade, Intel realizes that this can be an\
8 administrative hassle. The Linux operating system and VMware ESX\
9 products have a mechanism to update the microcode after booting.\
10 For example, this file will be used by the operating system mechanism\
11 if the file is placed in the /etc/firmware directory of the Linux system."
12
13LICENSE = "Intel-Microcode-License"
14LIC_FILES_CHKSUM = "file://microcode.dat;md5=3c3b208607a00a3d70aad3af5629f7c7"
15
16SRC_URI = "http://downloadmirror.intel.com/23984/eng/microcode-20140624.tgz"
17SRC_URI[md5sum] = "eec20032e6bef99dc4282c0ca317e100"
18SRC_URI[sha256sum] = "b4662ac780438a7b2d87e6d26a7066feb807f37c6e5b6fa147089f4edb02ea37"
19
20RDEPENDS_${PN} = "iucode-tool"
21DEPENDS = "iucode-tool-native"
22S = "${WORKDIR}"
23
24COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
25PACKAGE_ARCH = "${MACHINE_ARCH}"
26
27inherit deploy
28
29# Use any of the iucode_tool parameters to filter specific microcodes from the data file
30# For further information, check the iucode-tool's manpage : http://manned.org/iucode-tool
31UCODE_FILTER_PARAMETERS ?= ""
32
33do_compile() {
34 mkdir -p ${WORKDIR}/ucode/kernel/x86/microcode
35 ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
36 ${UCODE_FILTER_PARAMETERS} \
37 --overwrite \
38 --write-to=${WORKDIR}/microcode_${PV}.bin \
39 ${WORKDIR}/microcode.dat
40
41 ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
42 ${UCODE_FILTER_PARAMETERS} \
43 --overwrite \
44 --write-earlyfw=${WORKDIR}/microcode_${PV}.cpio \
45 ${WORKDIR}/microcode.dat
46}
47
48do_install() {
49 install -d ${D}${base_libdir}/firmware/intel-ucode/
50 install ${WORKDIR}/microcode_${PV}.bin ${D}${base_libdir}/firmware/intel-ucode/
51 cd ${D}${base_libdir}/firmware/intel-ucode/
52 ln -sf microcode_${PV}.bin microcode.bin
53}
54
55do_deploy() {
56 install -d ${DEPLOYDIR}
57 install ${S}/microcode_${PV}.cpio ${DEPLOYDIR}/
58 cd ${DEPLOYDIR}
59 rm -f microcode.cpio
60 ln -sf microcode_${PV}.cpio microcode.cpio
61}
62
63addtask deploy before do_build after do_compile
64
65PACKAGES = "${PN}"
66
67FILES_${PN} = "${base_libdir}"