summaryrefslogtreecommitdiffstats
path: root/common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch
diff options
context:
space:
mode:
authorKishore Bodke <kishore.k.bodke@intel.com>2012-10-18 10:49:31 -0700
committerTom Zanussi <tom.zanussi@intel.com>2012-10-22 08:07:16 -0500
commitbfe4894bc37cda9339fdc510139d2a3d8242a0a3 (patch)
tree1bdbaba41d59a6bf70234ca842c81976f51f732b /common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch
parent60e70a60888f8f29066a4c92b69b66f16f38955e (diff)
downloadmeta-intel-bfe4894bc37cda9339fdc510139d2a3d8242a0a3.tar.gz
meta-intel/common: Add new recipe for libcrypto module.
This adds a new recipe to include the Intel Quick Assist Technology libcrypto Memory Management Module. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch')
-rw-r--r--common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch
new file mode 100644
index 00000000..dfed3c08
--- /dev/null
+++ b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch
@@ -0,0 +1,43 @@
1Index: openssl-qat-module-1.0.1-r0/openssl-1.0.1/engines/qat_engine/qat_mem/Makefile
2===================================================================
3--- openssl-qat-module-1.0.1-r0.orig/openssl-1.0.1/engines/qat_engine/qat_mem/Makefile 2012-10-17 13:31:27.932376960 -0700
4+++ openssl-qat-module-1.0.1-r0/openssl-1.0.1/engines/qat_engine/qat_mem/Makefile 2012-10-17 13:35:40.396389410 -0700
5@@ -9,13 +9,9 @@
6 MODULENAME := qat_mem
7 ### should not need to change stuff below ######################
8
9-
10-KDIR := /lib/modules/$(shell uname -r)/build
11-#KDIR := /exports/linux-2.6.12.2/
12+KDIR := $(KERNEL_SOURCE_ROOT)
13 PWD := $(shell pwd)
14-
15-CC := gcc -Wall -imacros /usr/src/kernels/$(shell uname -r)/include/linux/autoconf.h
16-
17+CC := $(KERNEL_CC) -Wall -imacros $(KERNEL_SOURCE_ROOT)/include/generated/autoconf.h
18 ifeq ($(KERNELRELEASE),)
19 all: $(MODULENAME)_test
20 all:
21@@ -23,20 +19,15 @@
22 else
23 obj-m := $(MODULENAME).o
24 endif
25-
26 $(MODULENAME)_test: $(MODULENAME)_test.c
27 $(CC) -g -o $(MODULENAME)_test $(MODULENAME)_test.c
28-
29-
30+modules_install:
31+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules_install
32 load:
33 insmod ./$(MODULENAME).ko
34-
35 unload:
36 rmmod $(MODULENAME)
37-
38 test: all
39 ./$(MODULENAME)_test.sh
40-
41 clean:
42 rm -f *.o *.ko Modules.symvers *.mod.c .*.cmd $(MODULENAME)_test
43-