summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-04-15 12:17:46 -0700
committerDarren Hart <dvhart@linux.intel.com>2015-04-15 15:07:52 -0700
commit4739f47e9358ec8cb82a72f3e185003c5ce40b2c (patch)
tree2593e3c33194acd377637ccf451a466944ce402b /common/recipes-bsp
parent8a76aa82e7dc32b64d5f47929a0f0af7c84f9f79 (diff)
downloadmeta-intel-4739f47e9358ec8cb82a72f3e185003c5ce40b2c.tar.gz
lms7: re-write do_unpack to fix warning
Since the primary tarball unpacks into a non-standard directory create a do_unpack that sets and resets to first unpack the primary tarball and then unpacks the actual src tarball into the correct directory. This is similar to lsof which has a dual tarball also. Fixes this WARNING: WARNING: /srv/hdd/intel/test/tmp/work/corei7-64-poky-linux/lms7/7.1.20-r0/lms-7.1.20 ('S') doesn't exist, please set 'S' to a proper value [YOCTO #7551] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'common/recipes-bsp')
-rw-r--r--common/recipes-bsp/amt/lms7_7.1.20.bb16
1 files changed, 12 insertions, 4 deletions
diff --git a/common/recipes-bsp/amt/lms7_7.1.20.bb b/common/recipes-bsp/amt/lms7_7.1.20.bb
index acc08c1e..1e8376e5 100644
--- a/common/recipes-bsp/amt/lms7_7.1.20.bb
+++ b/common/recipes-bsp/amt/lms7_7.1.20.bb
@@ -12,6 +12,8 @@ SRC_URI = "http://software.intel.com/sites/default/files/m/4/e/a/9/b/37962-${BPN
12 file://atnetworktool-printf-fix.patch \ 12 file://atnetworktool-printf-fix.patch \
13 file://readlink-declaration.patch" 13 file://readlink-declaration.patch"
14 14
15LOCALSRC = "file://${WORKDIR}/outputdir/${BPN}-${PV}-${PV_SUB}.tar.gz"
16
15COMPATIBLE_HOST = '(i.86|x86_64).*-linux' 17COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
16 18
17LIC_FILES_CHKSUM = "file://COPYING;md5=7264184cf88d9f27b719a9656255b47b" 19LIC_FILES_CHKSUM = "file://COPYING;md5=7264184cf88d9f27b719a9656255b47b"
@@ -24,12 +26,18 @@ inherit autotools update-rc.d
24INITSCRIPT_NAME = "lms7" 26INITSCRIPT_NAME = "lms7"
25INITSCRIPT_PARAMS = "defaults" 27INITSCRIPT_PARAMS = "defaults"
26 28
27do_unpack2() { 29python do_unpack() {
28 cd ${WORKDIR} 30 s = d.getVar('S', True)
29 tar -xvzf ${WORKDIR}/outputdir/${BPN}-${PV}-${PV_SUB}.tar.gz 31 d.setVar('S', '${WORKDIR}/outputdir')
32 bb.build.exec_func('base_do_unpack', d)
33 # temorarily change SRC_URI for unpack
34 src_uri = d.getVar('SRC_URI')
35 d.setVar('SRC_URI', '${LOCALSRC}')
36 d.setVar('S', s)
37 bb.build.exec_func('base_do_unpack', d)
38 d.setVar('SRC_URI', src_uri)
30} 39}
31 40
32addtask unpack2 after do_unpack before do_patch
33 41
34do_install_append () { 42do_install_append () {
35 mv ${D}/${sbindir}/lms ${D}/${sbindir}/lms7 43 mv ${D}/${sbindir}/lms ${D}/${sbindir}/lms7