summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-12-13 11:17:11 +0000
committerCalifornia Sullivan <california.l.sullivan@intel.com>2016-12-15 10:27:18 -0800
commit04899c330de0560f128e259acf10ace42f1c1c1e (patch)
tree226c4cd566d18a0825ec67498f4f47123ee00b5f /common/recipes-bsp
parent48c335a46e03b46540a83a365fea76b92940927b (diff)
downloadmeta-intel-04899c330de0560f128e259acf10ace42f1c1c1e.tar.gz
rmc: don't hardcode install paths
Instead of hardcoding /usr in the recipe, and hardcoding $prefix/lib in the Makefile, override all of the paths with the distro configuration. [ YOCTO #10800 ] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'common/recipes-bsp')
-rw-r--r--common/recipes-bsp/rmc/rmc.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/common/recipes-bsp/rmc/rmc.bb b/common/recipes-bsp/rmc/rmc.bb
index 8c89a99c..f5c648d8 100644
--- a/common/recipes-bsp/rmc/rmc.bb
+++ b/common/recipes-bsp/rmc/rmc.bb
@@ -22,6 +22,11 @@ COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux*"
22 22
23TARGET_CFLAGS +="-Wl,--hash-style=both" 23TARGET_CFLAGS +="-Wl,--hash-style=both"
24 24
25EXTRA_OEMAKE = "RMC_INSTALL_PREFIX=${D}/${prefix} \
26 RMC_INSTALL_BIN_PATH=${D}${bindir} \
27 RMC_INSTALL_LIB_PATH=${D}${libdir} \
28 RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc"
29
25SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong" 30SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong"
26do_compile_class-target() { 31do_compile_class-target() {
27 oe_runmake 32 oe_runmake
@@ -29,8 +34,8 @@ do_compile_class-target() {
29} 34}
30 35
31do_install() { 36do_install() {
32 oe_runmake RMC_INSTALL_PREFIX=${D}/usr install 37 oe_runmake install
33 oe_runmake RMC_INSTALL_PREFIX=${D}/usr -f Makefile.efi install 38 oe_runmake -f Makefile.efi install
34} 39}
35 40
36do_install_class-native() { 41do_install_class-native() {