summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/systemd-boot/systemd-boot/0003-sd-boot-Support-global-kernel-command-line-fragment.patch
diff options
context:
space:
mode:
authorJianxun Zhang <jianxun.zhang@linux.intel.com>2016-11-28 14:00:45 -0800
committerSaul Wold <sgw@linux.intel.com>2016-12-05 18:11:14 -0800
commit58e5069ee34edd585ca11dfa387bd122d45995aa (patch)
tree682e3c2051dc60d678e2f1fe9ee80fab0b336d23 /common/recipes-bsp/systemd-boot/systemd-boot/0003-sd-boot-Support-global-kernel-command-line-fragment.patch
parent5bd26ee16c65d0bb8fb907a14f008d9d40bcfa53 (diff)
downloadmeta-intel-58e5069ee34edd585ca11dfa387bd122d45995aa.tar.gz
rmc: integration update
This is a whole package of rmc work in meta-intel to reflect some major changes in the upstream project: In rmc.bb recipe, EFI_ARCH, path of EFI header files, and dependency on gnu-efi are removed with the updated revision. In systemd-boot, patches to integrate with rmc are re-worked mainly because of new APIs. Size of patches are smaller than the previous implementation. Notice we still use multiple APIs instead of calling an one-step interface multiple times, to get some potential runtime performance benefit. (rmc tool in user space is changed to use single API in the upstream project.) Fixes [YOCTO #10086] Fixes [YOCTO #10671] Signed-off-by: Jianxun Zhang <jianxun.zhang@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-bsp/systemd-boot/systemd-boot/0003-sd-boot-Support-global-kernel-command-line-fragment.patch')
-rw-r--r--common/recipes-bsp/systemd-boot/systemd-boot/0003-sd-boot-Support-global-kernel-command-line-fragment.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/common/recipes-bsp/systemd-boot/systemd-boot/0003-sd-boot-Support-global-kernel-command-line-fragment.patch b/common/recipes-bsp/systemd-boot/systemd-boot/0003-sd-boot-Support-global-kernel-command-line-fragment.patch
index 6d077f19..a4b63557 100644
--- a/common/recipes-bsp/systemd-boot/systemd-boot/0003-sd-boot-Support-global-kernel-command-line-fragment.patch
+++ b/common/recipes-bsp/systemd-boot/systemd-boot/0003-sd-boot-Support-global-kernel-command-line-fragment.patch
@@ -1,4 +1,4 @@
1From a38be4fe8ffed142abbba92f7ad91a8f7b8f1ace Mon Sep 17 00:00:00 2001 1From 1e33f99e13a70c19c1f63f6ef1c5522a09adece6 Mon Sep 17 00:00:00 2001
2From: Jianxun Zhang <jianxun.zhang@linux.intel.com> 2From: Jianxun Zhang <jianxun.zhang@linux.intel.com>
3Date: Mon, 20 Jun 2016 13:08:20 -0700 3Date: Mon, 20 Jun 2016 13:08:20 -0700
4Subject: [PATCH 3/3] sd-boot: Support global kernel command line fragment 4Subject: [PATCH 3/3] sd-boot: Support global kernel command line fragment
@@ -17,10 +17,10 @@ Signed-off-by: Jianxun Zhang <jianxun.zhang@linux.intel.com>
17 1 file changed, 34 insertions(+) 17 1 file changed, 34 insertions(+)
18 18
19diff --git a/src/boot/efi/boot.c b/src/boot/efi/boot.c 19diff --git a/src/boot/efi/boot.c b/src/boot/efi/boot.c
20index 43b0793..3dcd9a5 100644 20index d1b029b..8dffc48 100644
21--- a/src/boot/efi/boot.c 21--- a/src/boot/efi/boot.c
22+++ b/src/boot/efi/boot.c 22+++ b/src/boot/efi/boot.c
23@@ -847,6 +847,40 @@ static VOID config_add_entry(Config *config, ConfigEntry *entry) { 23@@ -846,6 +846,40 @@ static VOID config_add_entry(Config *config, ConfigEntry *entry) {
24 config->entries = ReallocatePool(config->entries, 24 config->entries = ReallocatePool(config->entries,
25 sizeof(VOID *) * config->entry_count, sizeof(VOID *) * i); 25 sizeof(VOID *) * config->entry_count, sizeof(VOID *) * i);
26 } 26 }
@@ -29,9 +29,9 @@ index 43b0793..3dcd9a5 100644
29+ * we put appending global command line here to cover both of two cases. 29+ * we put appending global command line here to cover both of two cases.
30+ */ 30+ */
31+ if (entry->type == LOADER_LINUX && rmc_db && rmc_fp) { 31+ if (entry->type == LOADER_LINUX && rmc_db && rmc_fp) {
32+ rmc_policy_file_t rmc_kp; 32+ rmc_file_t rmc_kp;
33+ 33+
34+ if (!query_policy_from_db(rmc_fp, rmc_db, RMC_POLICY_BLOB, "KBOOTPARAM", &rmc_kp)) { 34+ if (!rmc_query_file_by_fp(rmc_fp, rmc_db, "KBOOTPARAM", &rmc_kp)) {
35+ CHAR8 *cmdline; 35+ CHAR8 *cmdline;
36+ CHAR16 *s; 36+ CHAR16 *s;
37+ CHAR16 *t; 37+ CHAR16 *t;