summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/rmc/rmc.bb
diff options
context:
space:
mode:
authorTodor Minchev <todor.minchev@linux.intel.com>2017-07-06 15:41:21 -0700
committerSaul Wold <sgw@linux.intel.com>2017-07-06 16:03:29 -0700
commitb767b5cb2f374630136b1903dba7d86dddff362d (patch)
tree0713fb62d22244396648b5ec460e31f5b926d72e /common/recipes-bsp/rmc/rmc.bb
parent0f395e9fe94bf150ba050bd9d7ccf60ee20f8c04 (diff)
downloadmeta-intel-b767b5cb2f374630136b1903dba7d86dddff362d.tar.gz
rmc: split rmc.bb and rmc-efi.bb into separate recipes
X32 builds require that the bootloader is built as x86_64 binary. This patch splits the build definitions of the RMC userspace application and the RMC EFI library into separate recipes and builds an x86_64 EFI library when DEFAULTTUNE is x32. Signed-off-by: Todor Minchev <todor.minchev@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-bsp/rmc/rmc.bb')
-rw-r--r--common/recipes-bsp/rmc/rmc.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/common/recipes-bsp/rmc/rmc.bb b/common/recipes-bsp/rmc/rmc.bb
index 93fdd3aa..fb0d1737 100644
--- a/common/recipes-bsp/rmc/rmc.bb
+++ b/common/recipes-bsp/rmc/rmc.bb
@@ -28,14 +28,13 @@ EXTRA_OEMAKE = "RMC_INSTALL_PREFIX=${D}/${prefix} \
28 RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc" 28 RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc"
29 29
30SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong" 30SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong"
31
31do_compile_class-target() { 32do_compile_class-target() {
32 oe_runmake 33 oe_runmake
33 oe_runmake -f Makefile.efi
34} 34}
35 35
36do_install() { 36do_install() {
37 oe_runmake install 37 oe_runmake install
38 oe_runmake -f Makefile.efi install
39} 38}
40 39
41do_install_class-native() { 40do_install_class-native() {