summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/rmc/rmc-db.bb
diff options
context:
space:
mode:
authorJianxun Zhang <jianxun.zhang@linux.intel.com>2017-01-05 16:15:35 -0800
committerCalifornia Sullivan <california.l.sullivan@intel.com>2017-01-09 12:53:33 -0800
commit368673eab1344fee79932e2dd96289fa6748d8be (patch)
treecb0a2830796ca8fc37e5e7fa104af2a0c6a8fae0 /common/recipes-bsp/rmc/rmc-db.bb
parent499b251ce6b52fbc81cfb97b4aee73329bcc1255 (diff)
downloadmeta-intel-368673eab1344fee79932e2dd96289fa6748d8be.tar.gz
rmc: Extend usages of RMC_BOARD_DATA_DIRS to specify board data
Use the variable RMC_BOARD_DATA_DIRS, to disable, append to, or override the default board data in meta-intel with boards' data provided by users. Ideally, users should get the updated database in the new built image after an incremental build. Examples of RMC database output (db): RMC_BOARD_DATA_DIRS = "" (disable db generation) RMC_BOARD_DATA_DIRS_append = " top_dir" (db of defaults & user's) RMC_BOARD_DATA_DIRS = "top_dir" (db for user's , no defaults) RMC_BOARD_DATA_DIRS = " " (same as "") Signed-off-by: Jianxun Zhang <jianxun.zhang@linux.intel.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'common/recipes-bsp/rmc/rmc-db.bb')
-rw-r--r--common/recipes-bsp/rmc/rmc-db.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/common/recipes-bsp/rmc/rmc-db.bb b/common/recipes-bsp/rmc/rmc-db.bb
index 14553af0..99565fdd 100644
--- a/common/recipes-bsp/rmc/rmc-db.bb
+++ b/common/recipes-bsp/rmc/rmc-db.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}"
14 14
15inherit rmc-db 15inherit rmc-db
16 16
17RMC_BOARD_DATA_DIRS_append := " ${THISDIR}/boards/" 17RMC_BOARD_DATA_DIRS ?= "${THISDIR}/boards/"
18RMC_DB_DIR = "${WORKDIR}/db" 18RMC_DB_DIR = "${WORKDIR}/db"
19 19
20# Let sstate be aware of change in any added board directories 20# Let sstate be aware of change in any added board directories
@@ -41,6 +41,7 @@ do_deploy () {
41 if [ -f ${RMC_DB_DIR}/rmc.db ]; then 41 if [ -f ${RMC_DB_DIR}/rmc.db ]; then
42 install -m 0400 ${RMC_DB_DIR}/rmc.db ${DEPLOYDIR} 42 install -m 0400 ${RMC_DB_DIR}/rmc.db ${DEPLOYDIR}
43 else 43 else
44 rm -f ${DEPLOYDIR}/rmc.db
44 echo "Warning: no RMC central database found, skip deployment." 45 echo "Warning: no RMC central database found, skip deployment."
45 fi 46 fi
46} 47}