summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/efilinux/efilinux_1.1.bb
diff options
context:
space:
mode:
authorJianxun Zhang <jianxun.zhang@linux.intel.com>2016-01-27 13:26:09 -0800
committerSaul Wold <sgw@linux.intel.com>2016-02-02 05:48:01 -0800
commit1fe0e40d40ff003ac9464abb5b0df866a63d1c15 (patch)
treec5e321e042a549b1a0826d53d989e527cffb2990 /common/recipes-bsp/efilinux/efilinux_1.1.bb
parent57211af47b2f6f98f4e0e5616f2e7a6ea2d05ebc (diff)
downloadmeta-intel-1fe0e40d40ff003ac9464abb5b0df866a63d1c15.tar.gz
efilinux: update 1.0 -> 1.1
This change updates efilinux to release 1.1. 1.1 release changed license from 3-clause BSD to 2-clause BSD. License checking in new recipe is updated accordingly. Signed-off-by: Jianxun Zhang <jianxun.zhang@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-bsp/efilinux/efilinux_1.1.bb')
-rw-r--r--common/recipes-bsp/efilinux/efilinux_1.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/common/recipes-bsp/efilinux/efilinux_1.1.bb b/common/recipes-bsp/efilinux/efilinux_1.1.bb
new file mode 100644
index 00000000..2f6e79d0
--- /dev/null
+++ b/common/recipes-bsp/efilinux/efilinux_1.1.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "A UEFI OS loader"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://efilinux.h;beginline=5;endline=27;md5=f8d56e644672ac63fd81b55c205283ad"
4
5DEPENDS = "gnu-efi"
6
7inherit deploy
8
9SRCREV = "a995826f9e43f1134baea61610eafd8c173bb776"
10PV = "1.1+git${SRCPV}"
11
12SRC_URI = "git://git.kernel.org/pub/scm/boot/efilinux/efilinux.git"
13
14S = "${WORKDIR}/git"
15
16COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
17
18EXTRA_OEMAKE = "INCDIR=${STAGING_INCDIR} LIBDIR=${STAGING_LIBDIR}"
19
20# syslinux uses $LD for linking, strip `-Wl,' so it can work
21export LDFLAGS = "`echo $LDFLAGS | sed 's/-Wl,//g'`"
22
23do_deploy () {
24 install ${S}/efilinux.efi ${DEPLOYDIR}/efilinux.efi
25}
26addtask deploy before do_build after do_compile
27