summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-04-01 09:49:38 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-04-01 10:03:45 +0800
commitfa5566a9fd8a282e79d8f2f59314fd8ef0bae4c1 (patch)
tree74f17ad6f0e844638a4a0adae925245fecb818fa
parentf5c204c99b669d6dea12abbc19e8f7462379095c (diff)
downloadmeta-intel-fa5566a9fd8a282e79d8f2f59314fd8ef0bae4c1.tar.gz
ipmctl: add recipe
ipmctl is a utility for configuring and managing IntelĀ® Optaneā„¢ Persistent Memory modules (PMem). It supports functionality to: * Discover PMems on the platform. * Provision the platform memory configuration. * View and update the firmware on PMems. * Configure data-at-rest security on PMems. * Track health and performance of PMems. * Debug and troubleshoot PMems. * ipmctl refers to the following interface components: libipmctl: An Application Programming Interface (API) library for managing PMems. ipmctl: A Command Line Interface (CLI) application for configuring and managing PMems from the command line. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_02.00.00.3869.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_02.00.00.3869.bb b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_02.00.00.3869.bb
new file mode 100644
index 00000000..e424a390
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_02.00.00.3869.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Utility for managing Intel Optane DC persistent memory modules"
2DESCRIPTION = "Utility for configuring and managing Intel Optane Persistent \
3Memory modules (PMem). It supports functionality to: \
4Discover DCPMMs on the platform. \
5Provision the platform memory configuration. \
6View and update the firmware on DCPMMs. \
7Configure data-at-rest security on DCPMMs. \
8Track health and performance of DCPMMs. \
9Debug and troubleshoot DCPMMs."
10
11HOMEPAGE = "https://github.com/intel/ipmctl"
12BUGTRACKER = "https://github.com/intel/ipmctl/issues"
13
14LICENSE = "BSD-3-Clause"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=a3eb8e660b3e1c7257002b6fe4141d4f \
16 file://thirdpartynotice.txt;md5=cba483cb16e3fc688a1e366c75800e91"
17
18SRC_URI = "git://github.com/intel/ipmctl.git;branch=master_2_0;protocol=https"
19
20SRCREV = "001596fa2c6a3b16dae0a74c004443edd0d01095"
21S = "${WORKDIR}/git"
22
23inherit cmake
24
25DEPENDS = "ndctl"
26
27EXTRA_OECMAKE = "-DRELEASE=ON"