summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYongxin Liu <yongxin.liu@windriver.com>2023-04-03 15:06:02 +0800
committerNaveen Saini <naveen.kumar.saini@intel.com>2023-04-05 17:04:26 +0800
commitec3147abdd0727fedc707330d58593097357f944 (patch)
treea791f86fbf8f1ef62dfe954fa033cca8933344de
parentb81ad5eb6433671d6d40f7e624a81c3ef40a18d1 (diff)
downloadmeta-intel-ec3147abdd0727fedc707330d58593097357f944.tar.gz
intel-cmt-cat: add recipe
This software package provides basic support for Intel(R) Resource Director Technology (Intel(R) RDT) including: Cache Monitoring Technology (CMT) Memory Bandwidth Monitoring (MBM) Cache Allocation Technology (CAT) Code and Data Prioritization (CDP) Memory Bandwidth Allocation (MBA) Signed-off-by: Yongxin Liu <yongxin.liu@windriver.com> Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
-rw-r--r--recipes-bsp/intel-cmt-cat/intel-cmt-cat_4.5.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/intel-cmt-cat/intel-cmt-cat_4.5.0.bb b/recipes-bsp/intel-cmt-cat/intel-cmt-cat_4.5.0.bb
new file mode 100644
index 00000000..ed4886ff
--- /dev/null
+++ b/recipes-bsp/intel-cmt-cat/intel-cmt-cat_4.5.0.bb
@@ -0,0 +1,29 @@
1SUMMARY = "intel-cmt-cat"
2DESCRIPTION = "Software package which provides basic support for Intel(R) \
3Resource Director Technology (Intel(R) RDT)"
4HOMEPAGE = "https://github.com/intel/intel-cmt-cat"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=4b63c65942e1c16fd897f8cd20abebf8"
8
9SRC_URI = "git://github.com/intel/intel-cmt-cat;protocol=https;branch=master"
10SRCREV = "ba42217699ecfdf6a335285039a44ac4140fa8c4"
11
12S = "${WORKDIR}/git"
13
14COMPATIBLE_HOST = '(x86_64).*-linux'
15COMPATIBLE_HOST:libc-musl = "null"
16
17do_install() {
18 oe_runmake install PREFIX=${D}${prefix} NOLDCONFIG=y
19}
20
21FILES:${PN} += "${nonarch_libdir}/libpqos*"
22FILES:${PN}-doc = "/usr/man*"
23
24INSANE_SKIP:${PN} += "ldflags"
25INSANE_SKIP:${PN} += "dev-so"
26INSANE_SKIP:${PN} += "libdir"
27INSANE_SKIP:${PN} += "already-stripped"
28
29INHIBIT_PACKAGE_DEBUG_SPLIT = "1"