summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>2016-11-11 17:38:04 +0800
committerSaul Wold <sgw@linux.intel.com>2016-11-28 12:45:06 -0800
commitcf8fe21bae27b464658e96d101841b482051517e (patch)
tree09a8a431d04315f3ba93a681e6e849447a26413a
parent2c0811eab3994bae539be25d1b5c74bd6313b148 (diff)
downloadmeta-intel-cf8fe21bae27b464658e96d101841b482051517e.tar.gz
meta-isg/meta-mohonpeak: remove BSP layer
The meta-mohonpeak BSP layer has removed. The plan is to consolidate all Intel SoC BSP into intel common BSP. Now Intel Common BSP can support all features provided by meta-mohonpeak with default kernel version, So this layer can be removed from meta-intel. It will use rmc-systemd-boot for it's custom features. Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta-isg/meta-mohonpeak/COPYING.MIT17
-rw-r--r--meta-isg/meta-mohonpeak/README164
-rw-r--r--meta-isg/meta-mohonpeak/README.sources18
-rw-r--r--meta-isg/meta-mohonpeak/conf/layer.conf12
-rw-r--r--meta-isg/meta-mohonpeak/conf/machine/mohonpeak32.conf22
-rw-r--r--meta-isg/meta-mohonpeak/conf/machine/mohonpeak64.conf22
-rw-r--r--meta-isg/meta-mohonpeak/recipes-bsp/formfactor/formfactor/mohonpeak32/machconfig3
-rw-r--r--meta-isg/meta-mohonpeak/recipes-bsp/formfactor/formfactor/mohonpeak64/machconfig3
-rw-r--r--meta-isg/meta-mohonpeak/recipes-bsp/formfactor/formfactor_0.0.bbappend1
9 files changed, 0 insertions, 262 deletions
diff --git a/meta-isg/meta-mohonpeak/COPYING.MIT b/meta-isg/meta-mohonpeak/COPYING.MIT
deleted file mode 100644
index 89de3547..00000000
--- a/meta-isg/meta-mohonpeak/COPYING.MIT
+++ /dev/null
@@ -1,17 +0,0 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-isg/meta-mohonpeak/README b/meta-isg/meta-mohonpeak/README
deleted file mode 100644
index cd948dea..00000000
--- a/meta-isg/meta-mohonpeak/README
+++ /dev/null
@@ -1,164 +0,0 @@
1This README file contains information on building the meta-mohonpeak
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5The mohonpeak platform consists of two versions:
61. 32-bit Mohon Peak
72. 64-bit Mohon Peak
8
9The Mohon Peak platform consists of the Intel Atom Processor C2000
10Product Family (Formerly Rangeley)
11
12This BSP assumes ASPEED Technology graphics card is being used.
13
14Further information about the platforms supported by this BSP can be
15found here:
16
17 http://www.intel.com/content/www/us/en/intelligent-systems/rangeley/
18 atom-c2000-product-family-based-platforms-overview.html
19
20Information on all IntelĀ® embedded platforms can be found here:
21
22 http://www.intel.com/p/en_US/embedded/hwsw/hardware
23
24
25Yocto Project Compatible
26========================
27
28This BSP is compatible with the Yocto Project as per the requirements
29listed here:
30
31 https://www.yoctoproject.org/webform/yocto-project-compatible-registration
32
33
34Dependencies
35============
36
37This layer depends on:
38
39 URI: git://git.openembedded.org/bitbake
40 branch: master
41
42 URI: git://git.openembedded.org/openembedded-core
43 layers: meta
44 branch: master
45
46 URI: git://git.yoctoproject.org/meta-intel
47 layers: intel
48 branch: master
49
50
51Patches
52=======
53
54Please submit any patches against this BSP to the Yocto mailing list
55(meta-intel@yoctoproject.org) and cc: the maintainer:
56
57Maintainer: Ong Boon Leong <boon.leong.ong@intel.com>
58
59Please see the meta-intel/MAINTAINERS file for more details.
60
61
62Table of Contents
63=================
64
65 I. Building the meta-mohonpeak BSP layer
66 II. Booting the images in /binary
67III. Device Notes
68 a. Boot Loader
69 b. I/O drivers
70
71
72I. Building the meta-mohonpeak BSP layer
73=======================================
74
75In order to build an image with BSP support for a given release, you
76need to download the corresponding BSP tarball from the 'Board Support
77Package (BSP) Downloads' page of the Yocto Project website.
78
79Having done that, and assuming you extracted the BSP tarball contents
80at the top-level of your yocto build tree, you can build a mohonpeak
81image by adding the location of the meta-mohonpeak layer to
82bblayers.conf, along with the meta-intel layer itself (to access
83common metadata shared between BSPs) e.g.:
84
85 yocto/meta-intel \
86 yocto/meta-intel/meta-isg/meta-mohonpeak \
87
88To enable the 32-bit Mohon Peak layer, add the mohonpeak-32 MACHINE to local.conf:
89
90 MACHINE ?= "mohonpeak-32"
91
92To enable the 64-bit Mohon Peak layer, add the mohonpeak-64 MACHINE to local.conf:
93
94 MACHINE ?= "mohonpeak-64"
95
96You should then be able to build a mohonpeak image as such:
97
98 $ source oe-init-build-env
99 $ bitbake core-image-sato
100
101At the end of a successful build, you should have a live image that
102you can boot from a USB flash drive (see instructions on how to do
103that below, in the section 'Booting the images from /binary').
104
105As an alternative to downloading the BSP tarball, you can also work
106directly from the meta-intel git repository. For each BSP in the
107'meta-intel' repository, there are multiple branches, one
108corresponding to each major release starting with 'laverne' (0.90), in
109addition to the latest code which tracks the current master (note that
110not all BSPs are present in every release). Instead of extracting a
111BSP tarball at the top level of your yocto build tree, you can
112equivalently check out the appropriate branch from the meta-intel
113repository at the same location.
114
115
116II. Booting the images in /binary
117=================================
118
119This BSP contains bootable live images, which can be used to directly
120boot Yocto off of a USB flash drive.
121
122Under Linux, insert a USB flash drive. Assuming the USB flash drive
123takes device /dev/sdf, use dd to copy the live image to it. For
124example:
125
126# dd if=core-image-sato-mohonpeak-64.hddimg of=/dev/sdf
127# sync
128# eject /dev/sdf
129
130This should give you a bootable USB flash device. Insert the device
131into a bootable USB socket on the target, and power on. This should
132result in a system booted to the Sato graphical desktop.
133
134If you want a terminal, use the arrows at the top of the UI to move to
135different pages of available applications, one of which is named
136'Terminal'. Clicking that should give you a root terminal.
137
138If you want to ssh into the system, you can use the root terminal to
139ifconfig the IP address and use that to ssh in. The root password is
140empty, so to log in type 'root' for the user name and hit 'Enter' at
141the Password prompt: and you should be in.
142
143----
144
145If you find you're getting corrupt images on the USB (it doesn't show
146the syslinux boot: prompt, or the boot: prompt contains strange
147characters), try doing this first:
148
149# dd if=/dev/zero of=/dev/sdf bs=1M count=512
150
151
152III. Device Notes
153=================
154
155a. Boot Loader
156--------------
157BIOS : EDVLCRB1.86B.0024.R00.1308061601
158
159b. I/O drivers
160--------------
161Support Intel Legacy Block Drivers (APIC, RTC HPET, UART, LPC, WDT,
162SMBus i801, SMBus iSMT, USB Host v2.0, SATA)
163
164Support Aspeed Technology Graphic Card
diff --git a/meta-isg/meta-mohonpeak/README.sources b/meta-isg/meta-mohonpeak/README.sources
deleted file mode 100644
index b6f7c9f8..00000000
--- a/meta-isg/meta-mohonpeak/README.sources
+++ /dev/null
@@ -1,18 +0,0 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://www.yoctoproject.org/downloads/yocto-1.5.0/poky-dora-10.0.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17
18git://git.yoctoproject.org/meta-intel.git
diff --git a/meta-isg/meta-mohonpeak/conf/layer.conf b/meta-isg/meta-mohonpeak/conf/layer.conf
deleted file mode 100644
index 93ec112d..00000000
--- a/meta-isg/meta-mohonpeak/conf/layer.conf
+++ /dev/null
@@ -1,12 +0,0 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "mohonpeak"
9BBFILE_PATTERN_mohonpeak := "^${LAYERDIR}/"
10BBFILE_PRIORITY_mohonpeak = "6"
11
12LAYERDEPENDS_mohonpeak = "intel"
diff --git a/meta-isg/meta-mohonpeak/conf/machine/mohonpeak32.conf b/meta-isg/meta-mohonpeak/conf/machine/mohonpeak32.conf
deleted file mode 100644
index afc933a1..00000000
--- a/meta-isg/meta-mohonpeak/conf/machine/mohonpeak32.conf
+++ /dev/null
@@ -1,22 +0,0 @@
1#@TYPE: Machine
2#@NAME: mohonpeak 32bit
3
4#@DESCRIPTION: Machine configuration for Mohon Peak systems
5
6PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
7PREFERRED_VERSION_linux-yocto ?= "4.1%"
8
9require conf/machine/include/intel-core2-32-common.inc
10require conf/machine/include/intel-common-pkgarch.inc
11require conf/machine/include/meta-intel.inc
12
13XSERVER ?= "${XSERVER_X86_BASE} \
14 ${XSERVER_X86_EXT} \
15 ${XSERVER_X86_ASPEED_AST} \
16 "
17
18MACHINE_FEATURES += "pcbios efi"
19
20SYSLINUX_OPTS = "serial 1 115200"
21SERIAL_CONSOLE = "115200 ttyS1"
22APPEND += "console=ttyS1,115200 console=tty1"
diff --git a/meta-isg/meta-mohonpeak/conf/machine/mohonpeak64.conf b/meta-isg/meta-mohonpeak/conf/machine/mohonpeak64.conf
deleted file mode 100644
index 4beab814..00000000
--- a/meta-isg/meta-mohonpeak/conf/machine/mohonpeak64.conf
+++ /dev/null
@@ -1,22 +0,0 @@
1#@TYPE: Machine
2#@NAME: mohonpeak 64 bit
3
4#@DESCRIPTION: Machine configuration for Mohon Peak systems
5
6PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
7PREFERRED_VERSION_linux-yocto ?= "4.1%"
8
9require conf/machine/include/intel-corei7-64-common.inc
10require conf/machine/include/intel-common-pkgarch.inc
11require conf/machine/include/meta-intel.inc
12
13XSERVER ?= "${XSERVER_X86_BASE} \
14 ${XSERVER_X86_EXT} \
15 ${XSERVER_X86_ASPEED_AST} \
16 "
17
18MACHINE_FEATURES += "pcbios efi"
19
20SYSLINUX_OPTS = "serial 1 115200"
21SERIAL_CONSOLE = "115200 ttyS1"
22APPEND += "console=ttyS1,115200 console=tty1"
diff --git a/meta-isg/meta-mohonpeak/recipes-bsp/formfactor/formfactor/mohonpeak32/machconfig b/meta-isg/meta-mohonpeak/recipes-bsp/formfactor/formfactor/mohonpeak32/machconfig
deleted file mode 100644
index ffce0122..00000000
--- a/meta-isg/meta-mohonpeak/recipes-bsp/formfactor/formfactor/mohonpeak32/machconfig
+++ /dev/null
@@ -1,3 +0,0 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-isg/meta-mohonpeak/recipes-bsp/formfactor/formfactor/mohonpeak64/machconfig b/meta-isg/meta-mohonpeak/recipes-bsp/formfactor/formfactor/mohonpeak64/machconfig
deleted file mode 100644
index ffce0122..00000000
--- a/meta-isg/meta-mohonpeak/recipes-bsp/formfactor/formfactor/mohonpeak64/machconfig
+++ /dev/null
@@ -1,3 +0,0 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-isg/meta-mohonpeak/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-isg/meta-mohonpeak/recipes-bsp/formfactor/formfactor_0.0.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-isg/meta-mohonpeak/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"