summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2023-12-01 08:48:36 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2023-12-01 11:43:15 +0800
commitc93900c6ed774496dd7a4974e76e9767e87591d3 (patch)
treeef3cb758f8bf1de87b75dac56796531d7b21f8a4
parentb3fca0034e9783eafa86d1ae824ec396ede14d6c (diff)
downloadmeta-intel-c93900c6ed774496dd7a4974e76e9767e87591d3.tar.gz
openvino-inference-engine: upgrade 2023.1.0 -> 2023.2.0
* Release notes: https://github.com/openvinotoolkit/openvino/releases/tag/2023.2.0 * Drop the patches which included header cstdint to fix build issues with gcc13 as these changes are already incorporated in the upstream code. * gflags and zlib are now used as bundled dependencies https://github.com/openvinotoolkit/openvino/pull/20762 * Refresh the patches Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch (renamed from dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch)65
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Change-the-working-directory-to-source-to-workaround.patch (renamed from dynamic-layers/openembedded-layer/recipes-support/opencv/files/cython-cmake.patch)18
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-cmake-Fix-overloaded-virtual-error.patch33
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0004-protobuf-allow-target-protoc-to-be-built.patch (renamed from dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-protobuf-allow-target-protoc-to-be-built.patch)26
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/7cecc9138b89e1946e3e515727bb69b2ab119806.patch32
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch69
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/onednn-fix-build-with-gcc13.patch17
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.2.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.1.0.bb)32
8 files changed, 98 insertions, 194 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch
index 292c534a..7ab31309 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch
@@ -1,10 +1,9 @@
1From a704afcc9e238dceafb3b1bc91b0b8abed3593eb Mon Sep 17 00:00:00 2001 1From bfcf5ae581ca4e7266cf7dc65b1c71754cd78cc0 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 21 Sep 2023 14:07:28 +0800 3Date: Wed, 29 Nov 2023 12:42:57 +0530
4Subject: [PATCH] cmake: yocto specific tweaks to the build process 4Subject: [PATCH 1/4] cmake: yocto specific tweaks to the build process
5 5
6* Dont try to detect glibc version as that doesn't work when cross compiling. 6* Dont try to detect glibc version as that doesn't work when cross compiling.
7* Use shared gflags libs.
8* Install sample binaries as well. 7* Install sample binaries as well.
9* Dont strip binaries. 8* Dont strip binaries.
10* Dont try to write triggers for CPack. We package ourselves. 9* Dont try to write triggers for CPack. We package ourselves.
@@ -14,19 +13,18 @@ Upstream-Status: Inappropriate
14 13
15Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 14Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
16--- 15---
17 cmake/developer_package/packaging/rpm/rpm.cmake | 2 +- 16 cmake/developer_package/packaging/rpm/rpm.cmake | 2 +-
18 cmake/developer_package/target_flags.cmake | 2 +- 17 cmake/developer_package/target_flags.cmake | 2 +-
19 samples/cpp/CMakeLists.txt | 6 +++--- 18 samples/cpp/CMakeLists.txt | 6 +++---
20 src/bindings/python/CMakeLists.txt | 2 +- 19 src/bindings/python/CMakeLists.txt | 2 +-
21 src/bindings/python/wheel/setup.py | 1 - 20 src/bindings/python/wheel/setup.py | 1 -
22 thirdparty/dependencies.cmake | 10 +++++----- 21 5 files changed, 6 insertions(+), 7 deletions(-)
23 6 files changed, 11 insertions(+), 12 deletions(-)
24 22
25diff --git a/cmake/developer_package/packaging/rpm/rpm.cmake b/cmake/developer_package/packaging/rpm/rpm.cmake 23diff --git a/cmake/developer_package/packaging/rpm/rpm.cmake b/cmake/developer_package/packaging/rpm/rpm.cmake
26index 0609750054f..0f5c7765197 100644 24index a7c0ec2cf61..40448e8a962 100644
27--- a/cmake/developer_package/packaging/rpm/rpm.cmake 25--- a/cmake/developer_package/packaging/rpm/rpm.cmake
28+++ b/cmake/developer_package/packaging/rpm/rpm.cmake 26+++ b/cmake/developer_package/packaging/rpm/rpm.cmake
29@@ -161,7 +161,7 @@ ov_rpm_specific_settings() 27@@ -154,7 +154,7 @@ ov_rpm_specific_settings()
30 # needed to add triggers for packages with libraries 28 # needed to add triggers for packages with libraries
31 set(def_triggers "${OpenVINO_BINARY_DIR}/_CPack_Packages/triggers") 29 set(def_triggers "${OpenVINO_BINARY_DIR}/_CPack_Packages/triggers")
32 set(triggers_content "# /bin/sh -p\n/sbin/ldconfig\n") 30 set(triggers_content "# /bin/sh -p\n/sbin/ldconfig\n")
@@ -46,13 +44,13 @@ index 29f23e713e1..942dd445b19 100644
46-ov_glibc_version() 44-ov_glibc_version()
47+#ov_glibc_version() 45+#ov_glibc_version()
48diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt 46diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
49index 8849aaf47d1..450b57c18d6 100644 47index c814cc37e2c..431e7bd2ed3 100644
50--- a/samples/cpp/CMakeLists.txt 48--- a/samples/cpp/CMakeLists.txt
51+++ b/samples/cpp/CMakeLists.txt 49+++ b/samples/cpp/CMakeLists.txt
52@@ -223,9 +223,9 @@ macro(ie_add_sample) 50@@ -206,9 +206,9 @@ macro(ov_add_sample)
53 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES}) 51 target_link_libraries(${SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${SAMPLE_DEPENDENCIES})
54 52
55 install(TARGETS ${IE_SAMPLE_NAME} 53 install(TARGETS ${SAMPLE_NAME}
56- RUNTIME DESTINATION samples_bin/ 54- RUNTIME DESTINATION samples_bin/
57- COMPONENT samples_bin 55- COMPONENT samples_bin
58- EXCLUDE_FROM_ALL) 56- EXCLUDE_FROM_ALL)
@@ -61,12 +59,12 @@ index 8849aaf47d1..450b57c18d6 100644
61+ 59+
62 60
63 # create global target with all samples / demo apps 61 # create global target with all samples / demo apps
64 if(NOT TARGET ie_samples) 62 if(NOT TARGET ov_samples)
65diff --git a/src/bindings/python/CMakeLists.txt b/src/bindings/python/CMakeLists.txt 63diff --git a/src/bindings/python/CMakeLists.txt b/src/bindings/python/CMakeLists.txt
66index f337f403189..21012162093 100644 64index 58ff9b74302..4763994ba56 100644
67--- a/src/bindings/python/CMakeLists.txt 65--- a/src/bindings/python/CMakeLists.txt
68+++ b/src/bindings/python/CMakeLists.txt 66+++ b/src/bindings/python/CMakeLists.txt
69@@ -314,7 +314,7 @@ if(ENABLE_PYTHON_PACKAGING) 67@@ -356,7 +356,7 @@ if(ENABLE_PYTHON_PACKAGING)
70 endif() 68 endif()
71 69
72 set(python_package_prefix "${CMAKE_CURRENT_BINARY_DIR}/install_${pyversion}") 70 set(python_package_prefix "${CMAKE_CURRENT_BINARY_DIR}/install_${pyversion}")
@@ -76,38 +74,17 @@ index f337f403189..21012162093 100644
76 set(meta_info_file "${install_lib}/${meta_info_subdir}/PKG-INFO") 74 set(meta_info_file "${install_lib}/${meta_info_subdir}/PKG-INFO")
77 75
78diff --git a/src/bindings/python/wheel/setup.py b/src/bindings/python/wheel/setup.py 76diff --git a/src/bindings/python/wheel/setup.py b/src/bindings/python/wheel/setup.py
79index 04323a8ba49..0498dcdc126 100644 77index 4b056912212..5f05d891310 100644
80--- a/src/bindings/python/wheel/setup.py 78--- a/src/bindings/python/wheel/setup.py
81+++ b/src/bindings/python/wheel/setup.py 79+++ b/src/bindings/python/wheel/setup.py
82@@ -270,7 +270,6 @@ class CustomBuild(build): 80@@ -270,7 +270,6 @@ class CustomBuild(build):
83 self.spawn(["cmake", "--install", binary_dir, 81 self.spawn(["cmake", "--install", binary_dir,
84 "--prefix", prefix, 82 "--prefix", prefix,
85 "--config", "Release", 83 "--config", CONFIG,
86- "--strip", 84- "--strip",
87 "--component", cpack_comp_name]) 85 "--component", cpack_comp_name])
88 86
89 def run(self): 87 def run(self):
90diff --git a/thirdparty/dependencies.cmake b/thirdparty/dependencies.cmake
91index 43e0ed671a9..b39479fdd6b 100644
92--- a/thirdparty/dependencies.cmake
93+++ b/thirdparty/dependencies.cmake
94@@ -338,11 +338,11 @@ if(ENABLE_SAMPLES OR ENABLE_TESTS)
95 elseif(APPLE OR WIN32)
96 # on Windows and macOS we don't use gflags, because will be dynamically linked
97 elseif(CMAKE_HOST_LINUX AND LINUX)
98- if(OV_OS_RHEL)
99- set(gflag_component nothreads_shared)
100- elseif(OV_OS_DEBIAN)
101- set(gflag_component nothreads_static)
102- endif()
103+ #if(OV_OS_RHEL)
104+ set(gflag_component nothreads_shared)
105+ #elseif(OV_OS_DEBIAN)
106+ # set(gflag_component nothreads_static)
107+ #endif()
108 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component})
109 endif()
110
111-- 88--
1122.37.3 892.34.1
113 90
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/cython-cmake.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Change-the-working-directory-to-source-to-workaround.patch
index 45ed0d27..e6fe3271 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/cython-cmake.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Change-the-working-directory-to-source-to-workaround.patch
@@ -1,14 +1,21 @@
1Change the working directory to source to workaround cython 1From a0ea332df477480f90d9dc841faf71f4b5be892e Mon Sep 17 00:00:00 2001
2embedding absolute path to the pyx file in output. 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 29 Nov 2023 12:45:59 +0530
4Subject: [PATCH 2/4] Change the working directory to source to workaround
5 cython embedding absolute path to the pyx file in output.
3 6
4Upstream-Status: Inappropriate [OE build specific] 7Upstream-Status: Inappropriate [OE build specific]
8
5Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 9Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
10---
11 .../python/src/compatibility/openvino/cmake/UseCython.cmake | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
6 13
7diff --git a/src/bindings/python/src/compatibility/openvino/cmake/UseCython.cmake b/src/bindings/python/src/compatibility/openvino/cmake/UseCython.cmake 14diff --git a/src/bindings/python/src/compatibility/openvino/cmake/UseCython.cmake b/src/bindings/python/src/compatibility/openvino/cmake/UseCython.cmake
8index f14662ad50..8d199fe328 100644 15index 03a208f03c2..be9af591b34 100644
9--- a/src/bindings/python/src/compatibility/openvino/cmake/UseCython.cmake 16--- a/src/bindings/python/src/compatibility/openvino/cmake/UseCython.cmake
10+++ b/src/bindings/python/src/compatibility/openvino/cmake/UseCython.cmake 17+++ b/src/bindings/python/src/compatibility/openvino/cmake/UseCython.cmake
11@@ -259,7 +259,7 @@ function( compile_pyx _name generated_file ) 18@@ -258,7 +258,7 @@ function( compile_pyx _name generated_file )
12 add_custom_command( OUTPUT ${_generated_file} 19 add_custom_command( OUTPUT ${_generated_file}
13 COMMAND ${CYTHON_EXECUTABLE} 20 COMMAND ${CYTHON_EXECUTABLE}
14 ARGS ${cxx_arg} ${include_directory_arg} ${version_arg} 21 ARGS ${cxx_arg} ${include_directory_arg} ${version_arg}
@@ -17,3 +24,6 @@ index f14662ad50..8d199fe328 100644
17 --output-file ${_generated_file} ${pyx_locations} 24 --output-file ${_generated_file} ${pyx_locations}
18 DEPENDS ${pyx_locations} ${pxd_dependencies} ${pxi_dependencies} 25 DEPENDS ${pyx_locations} ${pxd_dependencies} ${pxi_dependencies}
19 IMPLICIT_DEPENDS ${pyx_lang} ${c_header_dependencies} 26 IMPLICIT_DEPENDS ${pyx_lang} ${c_header_dependencies}
27--
282.34.1
29
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-cmake-Fix-overloaded-virtual-error.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-cmake-Fix-overloaded-virtual-error.patch
new file mode 100644
index 00000000..e0967d55
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-cmake-Fix-overloaded-virtual-error.patch
@@ -0,0 +1,33 @@
1From 900eeeb2953095e651270c0f42ccd8b26fd7885c Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 29 Nov 2023 12:49:35 +0530
4Subject: [PATCH 3/4] cmake: Fix overloaded-virtual error
5
6* Remove -Werror for:
7|git/src/plugins/intel_gpu/src/kernel_selector/jitter.h:129:28: error: 'virtual kernel_selector::JitDefinitions kernel_selector::JitConstant::GetDefinitions() const' was hidden [-Werror=overloaded-virtual=]
8| 129 | virtual JitDefinitions GetDefinitions() const = 0;
9| |
10
11Upstream-Status: Pending
12
13Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
14---
15 src/plugins/intel_gpu/CMakeLists.txt | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/src/plugins/intel_gpu/CMakeLists.txt b/src/plugins/intel_gpu/CMakeLists.txt
19index b0c66a435d6..a3037147cc2 100644
20--- a/src/plugins/intel_gpu/CMakeLists.txt
21+++ b/src/plugins/intel_gpu/CMakeLists.txt
22@@ -38,7 +38,7 @@ add_subdirectory(thirdparty)
23 include(thirdparty/cmake/rapidjson.cmake)
24
25 if(CMAKE_COMPILER_IS_GNUCXX)
26- ov_add_compiler_flags(-Werror)
27+ #ov_add_compiler_flags(-Werror)
28 endif()
29
30 add_subdirectory(src/runtime)
31--
322.34.1
33
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-protobuf-allow-target-protoc-to-be-built.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0004-protobuf-allow-target-protoc-to-be-built.patch
index 6bc54335..59095133 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-protobuf-allow-target-protoc-to-be-built.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0004-protobuf-allow-target-protoc-to-be-built.patch
@@ -1,7 +1,7 @@
1From 450a1ba74eb5a6cf3946d8ae84b7de5bc97ccb35 Mon Sep 17 00:00:00 2001 1From 3e288ed876c6bcb6aa3174e52446b479255ddf22 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 13 Jun 2023 12:34:08 +0800 3Date: Wed, 29 Nov 2023 12:55:19 +0530
4Subject: [PATCH] protobuf: allow target protoc to be built 4Subject: [PATCH 4/4] protobuf: allow target protoc to be built
5 5
6We can run target binaries using a qemu wrapper so allow these to be 6We can run target binaries using a qemu wrapper so allow these to be
7built and run. 7built and run.
@@ -15,23 +15,23 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
15 2 files changed, 2 insertions(+), 2 deletions(-) 15 2 files changed, 2 insertions(+), 2 deletions(-)
16 16
17diff --git a/cmake/developer_package/frontends/frontends.cmake b/cmake/developer_package/frontends/frontends.cmake 17diff --git a/cmake/developer_package/frontends/frontends.cmake b/cmake/developer_package/frontends/frontends.cmake
18index 897e6f8e3a6..32b136fcea9 100644 18index 49c5b881030..2a1ea8562bc 100644
19--- a/cmake/developer_package/frontends/frontends.cmake 19--- a/cmake/developer_package/frontends/frontends.cmake
20+++ b/cmake/developer_package/frontends/frontends.cmake 20+++ b/cmake/developer_package/frontends/frontends.cmake
21@@ -146,7 +146,7 @@ macro(ov_add_frontend) 21@@ -143,7 +143,7 @@ macro(ov_add_frontend)
22 set(GENERATED_PROTO ${INFILE}) 22 set(OUTPUT_PB_HEADER ${CMAKE_CURRENT_BINARY_DIR}/${relative_path}/${FILE_WE}.pb.h)
23 add_custom_command( 23 add_custom_command(
24 OUTPUT "${OUTPUT_PB_SRC}" "${OUTPUT_PB_HEADER}" 24 OUTPUT "${OUTPUT_PB_SRC}" "${OUTPUT_PB_HEADER}"
25- COMMAND ${PROTOC_EXECUTABLE} ARGS --cpp_out ${CMAKE_CURRENT_BINARY_DIR} -I ${FILE_DIR} ${FILE_WE}.proto 25- COMMAND ${PROTOC_EXECUTABLE} ARGS --cpp_out ${CMAKE_CURRENT_BINARY_DIR} -I ${protofiles_root_dir} ${proto_file}
26+ COMMAND protoc ARGS --cpp_out ${CMAKE_CURRENT_BINARY_DIR} -I ${FILE_DIR} ${FILE_WE}.proto 26+ COMMAND protoc ARGS --cpp_out ${CMAKE_CURRENT_BINARY_DIR} -I ${protofiles_root_dir} ${proto_file}
27 DEPENDS ${PROTOC_DEPENDENCY} ${GENERATED_PROTO} 27 DEPENDS ${PROTOC_DEPENDENCY} ${proto_file}
28 COMMENT "Running C++ protocol buffer compiler (${PROTOC_EXECUTABLE}) on ${GENERATED_PROTO}" 28 COMMENT "Running C++ protocol buffer compiler (${PROTOC_EXECUTABLE}) on ${proto_file_relative}"
29 VERBATIM 29 VERBATIM
30diff --git a/thirdparty/protobuf/CMakeLists.txt b/thirdparty/protobuf/CMakeLists.txt 30diff --git a/thirdparty/protobuf/CMakeLists.txt b/thirdparty/protobuf/CMakeLists.txt
31index 79e69a47b09..087f9e838c2 100644 31index 4b6d6da87f3..409e492a5b3 100644
32--- a/thirdparty/protobuf/CMakeLists.txt 32--- a/thirdparty/protobuf/CMakeLists.txt
33+++ b/thirdparty/protobuf/CMakeLists.txt 33+++ b/thirdparty/protobuf/CMakeLists.txt
34@@ -27,7 +27,7 @@ set(protobuf_WITH_ZLIB OFF CACHE BOOL "Build with zlib support" FORCE) 34@@ -28,7 +28,7 @@ set(ABSL_PROPAGATE_CXX_STD ON CACHE BOOL "Abseil protogate CXX standard to depen
35 if(CMAKE_CROSSCOMPILING OR 35 if(CMAKE_CROSSCOMPILING OR
36 (APPLE AND (HOST_X86_64 AND AARCH64)) OR 36 (APPLE AND (HOST_X86_64 AND AARCH64)) OR
37 (MSVC AND (HOST_X86_64 AND (AARCH64 OR ARM)))) 37 (MSVC AND (HOST_X86_64 AND (AARCH64 OR ARM))))
@@ -41,5 +41,5 @@ index 79e69a47b09..087f9e838c2 100644
41 set(protobuf_BUILD_PROTOC_BINARIES ON CACHE BOOL "Build protoc binaries" FORCE) 41 set(protobuf_BUILD_PROTOC_BINARIES ON CACHE BOOL "Build protoc binaries" FORCE)
42 endif() 42 endif()
43-- 43--
442.37.3 442.34.1
45 45
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/7cecc9138b89e1946e3e515727bb69b2ab119806.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/7cecc9138b89e1946e3e515727bb69b2ab119806.patch
deleted file mode 100644
index f744bd19..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/7cecc9138b89e1946e3e515727bb69b2ab119806.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 7cecc9138b89e1946e3e515727bb69b2ab119806 Mon Sep 17 00:00:00 2001
2From: Sergei Trofimovich <slyich@gmail.com>
3Date: Thu, 26 May 2022 07:11:37 +0100
4Subject: [PATCH] add missing <cstdint> header inclusion (gcc-13 support)
5
6Without the change ade build fails on this week's gcc-13 snapshot as:
7
8 [ 77%] Building CXX object sources/ade/CMakeFiles/ade.dir/source/topological_sort.cpp.o
9 In file included from ade/sources/ade/include/ade/passes/topological_sort.hpp:17,
10 from ade/sources/ade/source/topological_sort.cpp:7:
11 ade/sources/ade/include/ade/typed_graph.hpp:101:10: error: 'uintptr_t' in namespace 'std' does not name a type
12 101 | std::uintptr_t m_srcGraph;
13 | ^~~~~~~~~
14
15Upstream-Status: Backport
16Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
17---
18 sources/ade/include/ade/typed_graph.hpp | 1 +
19 1 file changed, 1 insertion(+)
20
21diff --git a/sources/ade/include/ade/typed_graph.hpp b/sources/ade/include/ade/typed_graph.hpp
22index d9676e6..8a27578 100644
23--- a/sources/ade/include/ade/typed_graph.hpp
24+++ b/sources/ade/include/ade/typed_graph.hpp
25@@ -9,6 +9,7 @@
26 #ifndef ADE_TYPED_GRAPH_HPP
27 #define ADE_TYPED_GRAPH_HPP
28
29+#include <cstdint>
30 #include <unordered_set>
31 #include <string>
32
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
deleted file mode 100644
index 9e1aa93c..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
+++ /dev/null
@@ -1,69 +0,0 @@
1From f8ad3f859aadc6c81ccc667eee1439cc2e6113cf Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 30 May 2023 09:31:09 +0800
4Subject: [PATCH] fix build with gcc13
5
6* Include the headers as per:
7https://gcc.gnu.org/gcc-13/porting_to.html
8
9* Remove -Werror for:
10|git/src/plugins/intel_gpu/src/kernel_selector/jitter.h:129:28: error: 'virtual kernel_selector::JitDefinitions kernel_selector::JitConstant::GetDefinitions() const' was hidden [-Werror=overloaded-virtual=]
11| 129 | virtual JitDefinitions GetDefinitions() const = 0;
12| | ^~~~~~~~~~~~~~
13
14* Fix:
15| /data/poky/build/tmp/work/x86-64-v3-poky-linux/openvino-inference-engine/2022.3.0-r0/git/src/inference/include/ie/ie_precision.hpp: In member function 'bool InferenceEngine::Precision::operator==(const InferenceEngine::Precision&) const':
16| /data/poky/build/tmp/work/x86-64-v3-poky-linux/openvino-inference-engine/2022.3.0-r0/git/src/inference/include/ie/ie_precision.hpp:153:36: error: ambiguous overload for 'operator==' (operand types are 'const InferenceEngine::Precision::ePrecision' and 'const InferenceEngine::Precision')
17| 153 | return precisionInfo.value == p && precisionInfo.bitsSize == p.precisionInfo.bitsSize &&
18| | ~~~~~~~~~~~~~~~~~~~ ^~ ~
19| | | |
20| | | const InferenceEngine::Precision
21| | const InferenceEngine::Precision::ePrecision
22| /data/poky/build/tmp/work/x86-64-v3-poky-linux/openvino-inference-engine/2022.3.0-r0/git/src/inference/include/ie/ie_precision.hpp:152:10: note: candidate: 'bool InferenceEngine::Precision::operator==(const InferenceEngine::Precision&) const' (reversed)
23| 152 | bool operator==(const Precision& p) const noexcept {
24| | ^~~~~~~~
25| /data/poky/build/tmp/work/x86-64-v3-poky-linux/openvino-inference-engine/2022.3.0-r0/git/src/inference/include/ie/ie_precision.hpp:153:36: note: candidate: 'operator==(InferenceEngine::Precision::ePrecision, InferenceEngine::Precision::ePrecision)' (built-in)
26| 153 | return precisionInfo.value == p && precisionInfo.bitsSize == p.precisionInfo.bitsSize &&
27| | ~~~~~~~~~~~~~~~~~~~~^~~~
28
29Upstream-Status: Pending
30Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
31
32---
33 src/inference/include/ie/ie_precision.hpp | 2 +-
34 src/plugins/intel_gpu/CMakeLists.txt | 6 +++---
35 2 files changed, 4 insertions(+), 4 deletions(-)
36
37diff --git a/src/inference/include/ie/ie_precision.hpp b/src/inference/include/ie/ie_precision.hpp
38index 48bdd945b13..96c29b73159 100644
39--- a/src/inference/include/ie/ie_precision.hpp
40+++ b/src/inference/include/ie/ie_precision.hpp
41@@ -149,7 +149,7 @@ public:
42 * @return `true` if values represent the same precisions, `false` otherwise
43 */
44 bool operator==(const Precision& p) const noexcept {
45- return precisionInfo.value == p && precisionInfo.bitsSize == p.precisionInfo.bitsSize &&
46+ return precisionInfo.value == p.precisionInfo.value && precisionInfo.bitsSize == p.precisionInfo.bitsSize &&
47 areSameStrings(precisionInfo.name, p.precisionInfo.name);
48 }
49
50diff --git a/src/plugins/intel_gpu/CMakeLists.txt b/src/plugins/intel_gpu/CMakeLists.txt
51index 948aecfcfec..a1b9783068b 100644
52--- a/src/plugins/intel_gpu/CMakeLists.txt
53+++ b/src/plugins/intel_gpu/CMakeLists.txt
54@@ -36,9 +36,9 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
55
56 add_subdirectory(thirdparty)
57
58-if(CMAKE_COMPILER_IS_GNUCXX)
59- ie_add_compiler_flags(-Werror)
60-endif()
61+#if(CMAKE_COMPILER_IS_GNUCXX)
62+# ie_add_compiler_flags(-Werror)
63+#endif()
64
65 add_subdirectory(src/runtime)
66 add_subdirectory(src/kernel_selector)
67--
682.34.1
69
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/onednn-fix-build-with-gcc13.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/onednn-fix-build-with-gcc13.patch
deleted file mode 100644
index 3063dc93..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/onednn-fix-build-with-gcc13.patch
+++ /dev/null
@@ -1,17 +0,0 @@
1include cstdint header for gcc13
2
3Upstream-Status: Pending
4Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
5
6diff --git a/src/gpu/jit/gemm/kernel_catalog.hpp b/src/gpu/jit/gemm/kernel_catalog.hpp
7index 8e6e1f3b6..3c8e29981 100644
8--- a/src/gpu/jit/gemm/kernel_catalog.hpp
9+++ b/src/gpu/jit/gemm/kernel_catalog.hpp
10@@ -20,6 +20,7 @@
11 #include <string>
12 #include <tuple>
13 #include <vector>
14+#include <cstdint>
15
16 #include "gen_gemm_kernel_common.hpp"
17
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.1.0.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.2.0.bb
index 1b93b0ce..7df511f0 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.1.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.2.0.bb
@@ -4,36 +4,40 @@ DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
4deep learning models through a high-level C++ Inference Engine API \ 4deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic." 5integrated with application logic."
6 6
7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;name=openvino;branch=releases/2023/1;lfs=0 \ 7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;name=openvino;branch=releases/2023/2;lfs=0 \
8 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \ 8 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \
9 git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \ 9 git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \
10 git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \ 10 git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \
11 git://github.com/nlohmann/json.git;protocol=https;destsuffix=git/thirdparty/json/nlohmann_json;name=json;branch=develop \ 11 git://github.com/nlohmann/json.git;protocol=https;destsuffix=git/thirdparty/json/nlohmann_json;name=json;branch=develop \
12 git://github.com/opencv/ade.git;protocol=https;destsuffix=git/thirdparty/ade;name=ade;nobranch=1 \ 12 git://github.com/opencv/ade.git;protocol=https;destsuffix=git/thirdparty/ade;name=ade;nobranch=1 \
13 git://github.com/protocolbuffers/protobuf.git;protocol=https;destsuffix=git/thirdparty/protobuf/protobuf;name=protobuf;branch=3.20.x \ 13 git://github.com/protocolbuffers/protobuf.git;protocol=https;destsuffix=git/thirdparty/protobuf/protobuf;name=protobuf;branch=3.20.x \
14 file://fix-build.patch \ 14 git://github.com/gflags/gflags.git;protocol=https;destsuffix=git/thirdparty/gflags/gflags;name=gflags;nobranch=1 \
15 file://cython-cmake.patch \ 15 git://github.com/madler/zlib.git;protocol=https;destsuffix=git/thirdparty/zlib/zlib;name=zlib;nobranch=1 \
16 file://7cecc9138b89e1946e3e515727bb69b2ab119806.patch;patchdir=thirdparty/ade \ 16 file://0001-cmake-yocto-specific-tweaks-to-the-build-process.patch \
17 file://fix-build-with-gcc13.patch \ 17 file://0002-Change-the-working-directory-to-source-to-workaround.patch \
18 file://onednn-fix-build-with-gcc13.patch;patchdir=src/plugins/intel_gpu/thirdparty/onednn_gpu \ 18 file://0003-cmake-Fix-overloaded-virtual-error.patch \
19 file://0001-protobuf-allow-target-protoc-to-be-built.patch \ 19 file://0004-protobuf-allow-target-protoc-to-be-built.patch \
20 " 20 "
21 21
22SRCREV_openvino = "47b736f63edda256d66e2bbb572f42a9d6549f6e" 22SRCREV_openvino = "7e18bd074a2487a7a98adcd313abd09c58d88072"
23SRCREV_mkl = "ae825539bd850d1ad5c83d4bb0d56c65d46d5842" 23SRCREV_mkl = "2ead5d4fe5993a797d9a7a4b8b5557b96f6ec90e"
24SRCREV_onednn = "4b82a66ed38ecaa993352e5cc6ed7753656b8a26" 24SRCREV_onednn = "284ad4574939fa784e4ddaa1f4aa577b8eb7a017"
25SRCREV_xbyak = "740dff2e866f3ae1a70dd42d6e8836847ed95cc2" 25SRCREV_xbyak = "740dff2e866f3ae1a70dd42d6e8836847ed95cc2"
26SRCREV_json = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d" 26SRCREV_json = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d"
27SRCREV_ade = "58b2595a1a95cc807be8bf6222f266a9a1f393a9" 27SRCREV_ade = "0e8a2ccdd34f29dba55894f5f3c5179809888b9e"
28SRCREV_protobuf = "fe271ab76f2ad2b2b28c10443865d2af21e27e0e" 28SRCREV_protobuf = "fe271ab76f2ad2b2b28c10443865d2af21e27e0e"
29SRCREV_FORMAT = "openvino_mkl_onednn_xbyak_json_ade_protobuf" 29SRCREV_gflags = "e171aa2d15ed9eb17054558e0b3a6a413bb01067"
30SRCREV_zlib = "04f42ceca40f73e2978b50e93806c2a18c1281fc"
31SRCREV_FORMAT = "openvino_mkl_onednn_xbyak_json_ade_protobuf_gflags_zlib"
30 32
31LICENSE = "Apache-2.0 & MIT & BSD-3-Clause" 33LICENSE = "Apache-2.0 & MIT & BSD-3-Clause & Zlib"
32LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \ 34LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
33 file://thirdparty/xbyak/COPYRIGHT;md5=3c98edfaa50a86eeaef4c6109e803f16 \ 35 file://thirdparty/xbyak/COPYRIGHT;md5=3c98edfaa50a86eeaef4c6109e803f16 \
34 file://thirdparty/cnpy/LICENSE;md5=689f10b06d1ca2d4b1057e67b16cd580 \ 36 file://thirdparty/cnpy/LICENSE;md5=689f10b06d1ca2d4b1057e67b16cd580 \
35 file://thirdparty/json/nlohmann_json/LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588 \ 37 file://thirdparty/json/nlohmann_json/LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588 \
36 file://thirdparty/ade/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \ 38 file://thirdparty/ade/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
39 file://thirdparty/gflags/gflags/COPYING.txt;md5=c80d1a3b623f72bb85a4c75b556551df \
40 file://thirdparty/zlib/zlib/LICENSE;md5=b51a40671bc46e961c0498897742c0b8 \
37 file://src/plugins/intel_cpu/thirdparty/onednn/LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \ 41 file://src/plugins/intel_cpu/thirdparty/onednn/LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \
38 file://src/plugins/intel_gpu/thirdparty/onednn_gpu/LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \ 42 file://src/plugins/intel_gpu/thirdparty/onednn_gpu/LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \
39" 43"
@@ -64,14 +68,12 @@ EXTRA_OECMAKE += " \
64 68
65DEPENDS += "\ 69DEPENDS += "\
66 flatbuffers-native \ 70 flatbuffers-native \
67 gflags \
68 pugixml \ 71 pugixml \
69 python3-pybind11 \ 72 python3-pybind11 \
70 python3-pybind11-native \ 73 python3-pybind11-native \
71 qemu-native \ 74 qemu-native \
72 snappy \ 75 snappy \
73 tbb \ 76 tbb \
74 zlib \
75 " 77 "
76 78
77COMPATIBLE_HOST = '(x86_64).*-linux' 79COMPATIBLE_HOST = '(x86_64).*-linux'