summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-05-08 19:05:29 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-05-18 11:38:24 +0800
commitbc9973a90d2edb52bb43c3640c980ceb520ca4a9 (patch)
treeab49af9bda6a2f2b6923c0b96fb015fd11212ac1
parentd00dfe0c0c8ae459ec09bf8570de142caa0bc594 (diff)
downloadmeta-intel-bc9973a90d2edb52bb43c3640c980ceb520ca4a9.tar.gz
libva-intel: drop recipe
libva in oe-core moved to latest release, so no need to carry in meta-intel anymore. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--conf/layer.conf4
-rw-r--r--conf/machine/include/meta-intel.inc4
-rw-r--r--recipes-multimedia/libva/libva-intel_2.7.0.bb51
3 files changed, 0 insertions, 59 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 1919c601..02581280 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -35,10 +35,6 @@ PREFERRED_PROVIDER_zlib ?= "zlib"
35PREFERRED_PROVIDER_zlib-native ?= "zlib-native" 35PREFERRED_PROVIDER_zlib-native ?= "zlib-native"
36PREFERRED_PROVIDER_nativesdk-zlib ?= "nativesdk-zlib" 36PREFERRED_PROVIDER_nativesdk-zlib ?= "nativesdk-zlib"
37 37
38PREFERRED_PROVIDER_libva ?= "libva"
39PREFERRED_PROVIDER_libva-native ?= "libva-native"
40PREFERRED_PROVIDER_nativesdk-libva ?= "nativesdk-libva"
41
42PREFERRED_PROVIDER_libva-utils ?= "libva-utils" 38PREFERRED_PROVIDER_libva-utils ?= "libva-utils"
43PREFERRED_PROVIDER_libva-native ?= "libva-utils-native" 39PREFERRED_PROVIDER_libva-native ?= "libva-utils-native"
44PREFERRED_PROVIDER_nativesdk-libva-utils ?= "nativesdk-libva-utils" 40PREFERRED_PROVIDER_nativesdk-libva-utils ?= "nativesdk-libva-utils"
diff --git a/conf/machine/include/meta-intel.inc b/conf/machine/include/meta-intel.inc
index f92438cb..ae613f1a 100644
--- a/conf/machine/include/meta-intel.inc
+++ b/conf/machine/include/meta-intel.inc
@@ -12,10 +12,6 @@ PREFERRED_PROVIDER_zlib = "zlib-intel"
12PREFERRED_PROVIDER_zlib-native = "zlib-native" 12PREFERRED_PROVIDER_zlib-native = "zlib-native"
13PREFERRED_PROVIDER_nativesdk-zlib = "nativesdk-zlib" 13PREFERRED_PROVIDER_nativesdk-zlib = "nativesdk-zlib"
14 14
15PREFERRED_PROVIDER_libva = "libva-intel"
16PREFERRED_PROVIDER_libva-native = "libva-intel-native"
17PREFERRED_PROVIDER_nativesdk-libva = "nativesdk-libva-intel"
18
19PREFERRED_PROVIDER_libva-utils = "libva-utils-intel" 15PREFERRED_PROVIDER_libva-utils = "libva-utils-intel"
20PREFERRED_PROVIDER_libva-native = "libva-utils-intel-native" 16PREFERRED_PROVIDER_libva-native = "libva-utils-intel-native"
21PREFERRED_PROVIDER_nativesdk-libva-utils = "nativesdk-libva-utils-intel" 17PREFERRED_PROVIDER_nativesdk-libva-utils = "nativesdk-libva-utils-intel"
diff --git a/recipes-multimedia/libva/libva-intel_2.7.0.bb b/recipes-multimedia/libva/libva-intel_2.7.0.bb
deleted file mode 100644
index cb7d2666..00000000
--- a/recipes-multimedia/libva/libva-intel_2.7.0.bb
+++ /dev/null
@@ -1,51 +0,0 @@
1# Latest upgrades for media components depend upon libva v2.7.0
2# So need this upgrade
3
4SUMMARY = "Video Acceleration (VA) API for Linux"
5DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
6and API specification which enables and provides access to graphics \
7hardware (GPU) acceleration for video processing on Linux and UNIX \
8based operating systems. Accelerated processing includes video \
9decoding, video encoding, subpicture blending and rendering. The \
10specification was originally designed by Intel for its GMA (Graphics \
11Media Accelerator) series of GPU hardware, the API is however not \
12limited to GPUs or Intel specific hardware, as other hardware and \
13manufacturers can also freely use this API for hardware accelerated \
14video decoding."
15
16HOMEPAGE = "https://01.org/linuxmedia/vaapi"
17BUGTRACKER = "https://github.com/intel/libva/issues"
18
19SECTION = "x11"
20LICENSE = "MIT"
21LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
22
23SRC_URI = "https://github.com/intel/libva/releases/download/${PV}/libva-${PV}.tar.bz2"
24SRC_URI[md5sum] = "bd5052569520e734eb8aeb0f503cfcae"
25SRC_URI[sha256sum] = "b75be416615dea75c74314fae8919dd72ca46d06b4e009e029661c2c51d87d70"
26
27S = "${WORKDIR}/libva-${PV}"
28
29UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
30
31DEPENDS = "libdrm virtual/mesa"
32
33inherit meson pkgconfig ${COMPAT_DISTRO_FEATURE_CHECK}
34
35REQUIRED_DISTRO_FEATURES = "opengl"
36
37PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
38PACKAGECONFIG[x11] = "-Dwith_x11=yes, -Dwith_x11=no,virtual/libx11 libxext libxfixes"
39PACKAGECONFIG[wayland] = "-Dwith_wayland=yes, -Dwith_wayland=no,wayland-native wayland"
40
41PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
42
43RDEPENDS_${PN}-x11 =+ "${PN}"
44RDEPENDS_${PN}-glx =+ "${PN}-x11"
45
46FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
47FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
48FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"
49
50PROVIDES = "libva"
51RPROVIDES_${PN} += "libva"